Επιλογή Σελίδας

α. Να αιτιολογήσετε γιατί ένα από τα πλεονεκτήματα του τμηματικού προγραμματισμού είναι το ότι απαιτεί λιγότερο χρόνο και προσπάθεια στη συγγραφή του προγράμματος   (μονάδες  2).

βΝα γράψετε τη σύνταξη της εντολής ΟΣΟ…  ΕΠΑΝΑΛΑΒΕ (μονάδα  1)
και να περιγράψετε τη λειτουργία της   (μονάδες  3).

Μονάδες  6

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΑΠΑΝΤΗΣΗ

α. Από κεφάλαιο 10.3.:
‘Πολύ συχνά χρειάζεται η ίδια λειτουργία σε διαφορετικά σημεία ενός προγράμματος. Από τη στιγμή που ένα υποπρόγραμμα έχει γραφεί, μπορεί το ίδιο να καλείτεαι από πολλά σημεία του προγράμματος. Έτσι μειώνονται το μέγεθος του προγράμματος, ο χρόνος που απαιτείται για τη συγγραφή του και οι πιθανότητες λάθους, ενώ ταυτόχρονα το πρόγραμμα γίνεται πιο εύληπτο και κατανοητό.’

β. Από κεφάλαιο 8.2.1:
Σύνταξη

ΟΣΟ συνθήκη ΕΠΑΝΑΛΑΒΕ
    εντολή-1
    εντολή-2
      ...
    εντολή-ν
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Παράδειγμα

Άθροισμα <—- 0
ΟΣΟ Άθροισμα < 1000 ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ A
    Άθροισμα <—- Άθροισμα + Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Λειτουργία
Ελέγχεται η συνθήκη και αν είναι Αληθής, εκτελούνται οι εντολές που βρίσκονται ανάμεσα στις ΟΣΟ_ΕΠΑΝΑΛΑΒΕ και ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ. Στη συνέχεια ελέγχεται πάλι η συνθήκη και αν ισχύει, εκτελούνται πάλι οι ίδιες εντολές. Όταν η λογική έκφραση γίνει Ψευδής, τότε σταματάει η επανάληψη και εκτελείται η εντολή μετά το ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ.

 

 

Share This