Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο διαβάζει από το πληκτρολόγιο μία σειρά μετρήσεων, ακεραίων μη μηδενικών αριθμών, υπολογίζει και τυπώνει το άθροισμά τους καθώς και το μέσο τους όρο. Ως τέλος της διαδικασίας εισαγωγής στοιχείων χρησιμοποιείται η τιμή 0.

ΠΡΟΓΡΑΜΜΑ Άθροισμα1  !Παρόραμα - ίδιο όνομα μεταβλητής
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ 
ΑΡΧΗ 
Πλήθος <--0 
Άθροισμα <-- 0 
ΓΡΑΨΕ 'Δώσε Αριθμό' 
ΔΙΑΒΑΣΕ Χ 
ΟΣΟ Χ<>0 ΕΠΑΝΑΛΑΒΕ 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Δώσε Αριθμό' 
    ΔΙΑΒΑΣΕ Χ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Πλήθος >0 ΤΟΤΕ  
   ΜΟ <-- Άθροισμα/Πλήθος 
   ΓΡΑΨΕ 'Το Άθροισμα είναι : ', Άθροισμα 
   ΓΡΑΨΕ 'Ο Μέσος όρος είναι : ', ΜΟ
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Δεν δόθηκαν στοιχεία' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παρατηρήσεις:

Η χρήση τιμών για τον τερματισμό μίας επαναληπτικής διαδικασίας, όπως στο παράδειγμα η αυθαίρετη επιλογή του 0, είναι συνήθης στον προγραμματισμό. Η τιμή αυτή ορίζεται από τον προγραμματιστή και αποτελεί μια σύμβαση για το τέλος του προγράμματος. Η τιμή αυτή είναι τέτοια, ώστε να μην είναι λογικά σωστή για το πρόβλημα, για παράδειγμα η τιμή 0 αποκλείεται από τις μετρήσεις σύμφωνα με την εκφώνηση του παραδείγματος. Η τιμή αυτή συχνά αποκαλείται «τιμή φρουρός«.

*Το όνομα του προγράμματος Άθροισμα (όπως υπάρχει στο βιβλίο) έχει το ίδιο όνομα με μεταβλητή που χρησιμοποιείται μέσα στο πρόγραμμα. (παρόραμα). Έγινε Άθροισμα1.

 

Share This