Επιλογή Σελίδας

Να γράψετε συμπληρωμένο στο τετράδιό σας το ακόλουθο τμήμα αλγορίθμου, το οποίο πραγματοποιεί αναζήτηση όλων των στοιχείων του πίνακα W[10] στον πίνακα S[1000], έτσι ώστε τα στοιχεία του πίνακα W[10] να καταλαμβάνουν συνεχόμενες θέσεις στον πίνακα S[1000]. Ο αλγόριθμος βρίσκει τη θέση i του S, απ’ όπου αρχίζει η πρώτη εμφάνιση των στοιχείων του W[10].

F <- ΨΕΥΔΗΣ
i <- 1
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
j <- Ν + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ……ΤΟΤΕ
F <- ΑΛΗΘΗΣ
ΑΛΛΙΣ
i <i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΣ
ΓΡΑΨΕ ΄ΔΕ ΒΡΕΘΗΚΕ’
ΤΕΛΟΣ_ΑΝ

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Share This