Επιλογή Σελίδας

11, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ, 25ος Π.Δ.Π (2013) A’ Φάση

Η αναπαράσταση ενός σήματος στο πεδίο των συχνοτήτων αποτελεί το φάσμα του. Εξαιρετικά σημαντική είναι η παρατήρηση ότι τα τεχνητά σήματα (τα σήματα δηλαδή που παράγονται από τεχνητά κατασκευασμένα συστήματα), έχουν μια μοναδική χαρακτηριστική κατανομή φάσματος. Η κατανομή αυτή ονομάζεται και χαρακτηριστική τριπλέτα επειδή συμμετρικά και εκατέρωθεν μιας δεδομένης συχνότητας, (χαρακτηριστική συχνότητα), εμφανίζονται δύο σήματα ίδιας ισχύος, και μάλιστα μικρότερης από το 50% της ισχύος του σήματος που αντιστοιχεί στη χαρακτηριστική συχνότητα.

Το Πανεπιστήμιο του Berkeley (California U.S.A.) έχει αναπτύξει ένα διεθνές πρόγραμμα επεξεργασίας σημάτων από εθελοντές χρήστες του Διαδικτύου, που αποσκοπεί στην αναζήτηση εξωγήινης νοημοσύνης και βασίζεται στην ανάλυση των σημάτων που συλλέγονται από ραδιοτηλεσκόπια (http://setiahome.berkeley.edu) Το Berkeley συλλέγει τα σήματα από τα ραδιοτηλεσκόπια και, αφού κάνει μια αρχική επεξεργασία, τα διανέμει στους συμμετέχοντες στο πρόγραμμα για να τα επεξεργαστούν. Αυτό που σας ζητείται σε αυτό το πρόβλημα είναι μία πολύ απλοποιημένη εκδοχή της επεξεργασίας που οι συμμετέχοντες καλούνται να κάνουν.

Σχήμα 1. Μετασχηματισμός σήματος από το πεδίο του χρόνου στο πεδίο των συχνοτήτων.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο θα διαβάζει τις τιμές στο πεδίο των συχνοτήτων που αντιστοιχούν σε ένα μετασχηματισμένο σήμα και θα τις καταχωρεί σε έναν Πίνακα 100 θέσεων. Στη συνέχεια θα αναγνωρίζει και θα εμφανίζει το πλήθος και τη θέση των χαρακτηριστικών συχνοτήτων μέσα στις αναγνωριζόμενες τριπλέτες. (πλήθος είναι και το 0)

Σημείωση:

Μία τριπλέτα σε ένα σήμα είναι μία τριάδα τιμών του σήματος με τις εξής ιδιότητες: (α) οι δύο ακραίες τιμές ισαπέχουν από τη μεσαία τιμή, και (β) οι δύο ακραίες τιμές είναι ίσες μεταξύ τους και μικρότερες του μισού της μεσαίας τιμής. Για παράδειγμα, η τριάδα τιμών που φαίνονται με έντονα γράμματα παρακάτω, είναι τριπλέτα:

Η μεσαία τιμή μίας τριπλέτας μας δίνει τη χαρακτηριστική συχνότητα, η οποία ισούται με τη θέση της μεσαίας τιμής στο σήμα. Στο παραπάνω παράδειγμα, η χαρακτηριστική συχνότητα είναι 6 (γιατί η μεσαία τιμή 5, είναι ο έκτος αριθμός που εμφανίζεται στο σήμα). ΕΠΥ, 25ος Π.Δ.Π. (2013) Α’ Φάση.

Παράδειγμα 1 (Ν=9)
Είσοδος: 4 1 2 1 3 5 3 1 4 Έξοδος: 2 (τριπλέτες), θέσεις: 5 6

Παράδειγμα 2 (Ν=20)
Είσοδος: 1 2 5 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  Έξοδος: 1 (τριπλέτες), θέσεις: 3

Παράδειγμα 3 (Ν=25)
Είσοδος: 4 4 5 5 5 6 6 6 6 7 7 7 6 6 6 6 5 5 5 4 4 3 2 1 0 Έξοδος: 0 (τριπλέτες), θέσεις: 

Παράδειγμα 4 (Ν=12)
Είσοδος: 1 2 2 5 3 2 1 6 1 2 1 4 Έξοδος: 3 (τριπλέτες), θέσεις: 4 5 8
1 2 2 5 3 2 1 6 1 2 1 4
1 2 2 5 3 2 1 6 1 2 1 4
1 2 2 5 3 2 1 6 1 2 1 4
1 2 2 5 3 2 1 6 1 2 1 4

ΛΥΣΗ

(περισσότερα…)

Θέμα A, Ερώτημα 1, 2013, Επαναληπτικές, Ημερήσια

Α1. α.   Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η εύρεση του μικρότερου από πέντε αριθμούς είναι πρόβλημα βελτιστοποίησης.
  2. Ο δείκτης εμπρός (front) μιας ουράς μας δίνει τη θέση του στοιχείου, το οποίο που σε πρώτη ευκαιρία θα εξαχθεί.
  3. Ο διαχωρισμός αποτελεί την αντίστροφη πράξη της συγχώνευσης.
  4. Στη ΓΛΩΣΣΑ, ο μέσος όρος ενός συνόλου ακεραίων μεταβλητών πρέπει να αποθηκευτεί σε μεταβλητή πραγματικού τύπου.

(μονάδες 4)

β. Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α και δίπλα το γράμμα της στήλης Β που αντιστοιχεί σωστά. Σημειώνεται ότι από τη στήλη Β περισσεύει μία επιλογή. (περισσότερα…)

Θέμα A, Ερώτημα 3, 2013, Επαναληπτικές, Ημερήσια

Να γράψετε συμπληρωμένο στο τετράδιό σας το ακόλουθο τμήμα αλγορίθμου, το οποίο πραγματοποιεί αναζήτηση όλων των στοιχείων του πίνακα W[10] στον πίνακα S[1000], έτσι ώστε τα στοιχεία του πίνακα W[10] να καταλαμβάνουν συνεχόμενες θέσεις στον πίνακα S[1000]. Ο αλγόριθμος βρίσκει τη θέση i του S, απ’ όπου αρχίζει η πρώτη εμφάνιση των στοιχείων του W[10].

F <- ΨΕΥΔΗΣ
i <- 1
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
j <- Ν + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ……ΤΟΤΕ
F <- ΑΛΗΘΗΣ
ΑΛΛΙΣ
i <i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΣ
ΓΡΑΨΕ ΄ΔΕ ΒΡΕΘΗΚΕ’
ΤΕΛΟΣ_ΑΝ

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα A, Ερώτημα 4, 2013, Επαναληπτικές, Ημερήσια

Πρώτος ονομάζεται ένας φυσικός αριθμός, όταν έχει ακριβώς δύο διαιρέτες: τον εαυτό του και τη μονάδα. Ο παρακάτω αλγόριθμος γράφτηκε, έτσι ώστε να εμφανίζει τους πρώτους αριθμούς από το 2 μέχρι και το 100.

ΑΛΓΟΡΙΘΜΟΣ πρώτοι
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
Μ <i
ΓΙΑ j ΑΠΟ 0 ΜΕΧΡΙ i
ΑΝ i / j = 0 ΤΟΤΕ
Μ <- Μ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ < 3 ΤΟΤΕ ΕΜΦΑΝΙΣΕ i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ πρώτοι
Ο παραπάνω αλγόριθμος έχει λάθη. Να τον γράψετε στο τετράδιό σας, κάνοντας τις απαραίτητες διορθώσεις, ώστε να λειτουργεί σωστά, χωρίς την προσθήκη νέων εντολών.

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Α, Ερώτημα 5, 2013, Επαναληπτικές, Ημερήσια

α. Οι πίνακες ακεραίων Α και Β είναι μονοδιάστατοι με πέντε και τρεις θέσεις αντιστοίχως. Το περιεχόμενό τους είναι:

er5thea2013epanhmer

Να γράψετε στο τετράδιό σας το περιεχόμενο του  πίνακα Α μετά την εκτέλεση των ακόλουθων εντολών.

Α[Β[1]] <- 7

Α[Β[2]] <- 2

Α[Β[3]] <- 8

(μονάδες 3)

β. Δίνεται η παρακάτω λογική έκφραση:

ΚΑΙ ΟΧΙ(Y)) Ή (ΟΧΙ(Χ) ΚΑΙ Y)

Να υπολογίσετε αναλυτικά την τιμή της, όταν Χ = ΑΛΗΘΗΣ και Υ = ΑΛΗΘΗΣ.

(μονάδες 3)

Μονάδες 6

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Β, 2013, Επαναληπτικές, Ημερήσια

Να μετατραπεί το παρακάτω διάγραμμα ροής σε ισοδύναμο αλγόριθμο με ψευδογλώσσα.

themav2013epanhmer

Μονάδες 11

Β2. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παραπάνω αλγορίθμου.

Μονάδες 9

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Γ, 2013, Επαναληπτικές, Ημερήσια

Ο σύλλογος γονέων και κηδεμόνων μιας περιοχής θέλει να διοργανώσει μια πολιτιστική εκδήλωση. Για το σκοπό αυτό, ζητά από κάθε σχολείο της περιοχής να προσφέρει κάποιο χρηματικό ποσό για την πραγματοποίησή της. Κάθε σχολείο έχει τη δυνατότητα να επικοινωνεί περισσότερες από μία φορές με το σύλλογο και να τροποποιεί την προσφορά του.

Να αναπτύξετε αλγόριθμο σε ψευδογλώσσα, ο οποίος:

Γ1. Να θεωρεί δεδομένο ένα πίνακα Σ[100] που περιέχει τα ονόματα των 100 σχολείων της περιοχής και να δημιουργεί πίνακα Π[100] που θα περιέχει τις αντίστοιχες χρηματικές προσφορές από κάθε σχολείο. Αρχικά να τοποθετηθεί σε κάθε στοιχείο του πίνακα Π[100] την τιμή -1.

Μονάδες 3

Γ2.     αΝα διαβάζει το όνομα ενός σχολείου και να το αναζητά στον πίνακα Σ.

(μονάδες 4)

β) Να εμφανίζει το μήνυμα «Άγνωστο», όταν το σχολείο δε βρεθεί. Όταν το σχολείο βρεθεί, να σταματά την αναζήτηση, να διαβάζει τη χρηματική προσφορά του σχολείου και να την τοποθετεί στην αντίστοιχη θέση του πίνακα Π. (Όταν δοθεί η τιμή 0, σημαίνει ότι το σχολείο δεν μπορεί να προσφέρει χρήματα, δηλαδή έδωσε μηδενική προσφορά).Όταν δεν είναι η πρώτη φορά που δίνει προσφορά τότε να εμφανίζει το μήνυμα «ΤΡΟΠΟΠΟΙΗΣΗ ΠΡΟΣΦΟΡΑΣ» και να αντικαθιστά την προηγούμενη προσφορά του με τη νέα.

(μονάδες 6)

Μονάδες 10

Γ3. Να επαναλαμβάνει τις ενέργειες που περιγράφονται στο ερώτημα Γ2, μέχρις ότου όλα τα σχολεία να δώσουν τουλάχιστον μία προσφορά.

Μονάδες 3

Γ4. Να εμφανίζει: α) το συνολικό χρηματικό ποσό που έχει συγκεντρωθεί, β) το πλήθος των σχολείων που έδωσαν μηδενική προσφορά, γ) το πλήθος των τροποποιήσεων που έγιναν στις προσφορές.

Μονάδες 4

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

ΛΥΣΗ  (περισσότερα…)

Θέμα Δ, 2013, Επαναληπτικές, Ημερήσια

Tα δεδομένα (κείμενο, εικόνα, ήχος, κλπ), κατά τη μετάδοσή τους μέσω ενσύρματων ή ασύρματων καναλιών επικοινωνίας, αλλοιώνονται λόγω του θορύβου που χαρακτηρίζει κάθε κανάλι. Ο τρόπος προστασίας των δεδομένων μετάδοσης είναι ο ακόλουθος:

Για κάθε bit (ακέραιος με τιμή 0 ή 1), που ο πομπός θέλει να στείλει, μεταδίδει μια λέξη, που αντιστοιχεί σε πίνακα ΜΕΤΑΔΟΣΗ[31] με όλες τις τιμές του ταυτόσημες με το προς μετάδοση bit, δηλαδή, αν πρόκειται να σταλεί το bit 1, τότε η λέξη που μεταδίδεται είναι η 11…1 μήκους 31 bits, ενώ αν πρόκειται να σταλεί το bit 0, τότε η λέξη που μεταδίδεται είναι η 00…0, μήκους 31 bits. Ο δέκτης λαμβάνει λέξη μήκους 31 bits, τα οποία τοποθετούνται σε πίνακα ΛΗΨΗ[31]. Έχουμε «ΛΑΝΘΑΣΜΕΝΗ ΛΗΨΗ», εάν υπάρχει τουλάχιστον ένα στοιχείο του πίνακα ΛΗΨΗ[31] με διαφορετική τιμή από αυτήν του αντίστοιχου στοιχείου του πίνακα ΜΕΤΑΔΟΣΗ[31]. Εάν το πλήθος των 1 του πίνακα ΛΗΨΗ[31] είναι μεγαλύτερο από το πλήθος των 0, τότε ο δέκτης αποφασίζει ότι ο πομπός έστειλε 1, ενώ σε αντίθετη περίπτωση ο δέκτης αποφασίζει ότι ο πομπός έστειλε 0. Σε κάθε περίπτωση, αν περισσότερα από τα μισά των 31 bits της λέξης μετάδοσης έχουν αλλοιωθεί, τότε ο δέκτης θα έχει πάρει «ΛΑΝΘΑΣΜΕΝΗ ΑΠΟΦΑΣΗ».

Να γραφεί πρόγραμμα σε ΓΛΩΣΣΑ, το οποίο να κάνει τα εξής:

Δ1. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων.

Μονάδες 3

Δ2. Για κάθε τιμή ποιότητας του καναλιού, που χαρακτηρίζεται από ακεραίους από 1 έως και 10, να πραγματοποιούνται το πολύ 100.000 διαφορετικές προσπάθειες μετάδοσης-λήψης και διόρθωσης λαθών. Εάν όμως ληφθούν 100 λανθασμένες αποφάσεις, τότε να διακόπτεται η διαδικασία για τη συγκεκριμένη τιμή ποιότητας του καναλιού.

Μονάδες 4

Δ3.Σε κάθε προσπάθεια μετάδοσης-λήψης και διόρθωσης λαθών να πραγματοποιούνται οι ακόλουθες ενέργειες:

α. Να διαβάζει (χωρίς έλεγχο εγκυρότητας των τιμών τους) τη μεταδοθείσα λέξη, καθώς και τη ληφθείσα λέξη και να ελέγχει, εάν αυτές ταυτίζονται.

β. Να διορθώνει τη ληφθείσα λέξη στο δέκτη, βάσει της παραπάνω περιγραφής του αλγορίθμου.

Μονάδες 9

Δ4. α. Να αποθηκεύει, για κάθε τιμή ποιότητας καναλιού, σε πίνακα ΛΑΘΗΑΠΟΦ[10] το ποσοστό των λανθασμένων αποφάσεων και σε πίνακα ΛΑΘΗΛΗΨ[10] το ποσοστό των λανθασμένων λήψεων.

β. Να εμφανίζει συγκεντρωτικά τα ποσοστά των λανθασμένων αποφάσεων και λανθασμένων λήψεων στο δέκτη.

Μονάδες 4

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η τιμή μιας μεταβλητής και ο τύπος της μπορούν να αλλάζουν κατά την εκτέλεση ενός προγράμματος.
  2. Όταν υπάρχουν δυο βρόχοι, ο ένας εμφωλευμένος μέσα στον άλλο, αυτός που ξεκινάει τελευταίος πρέπει να ολοκληρώνεται πρώτος.
  3. Μια διαφορά της εντολής Όσο σε σχέση με την εντολή Μέχρις_ότου οφείλεται στη θέση της λογικής συνθήκης στη ροή εκτέλεσης των εντολών.
  4. Αν Α=2, Β=3, Γ=4 και Δ=ΑΛΗΘΗΣ, τότε η τιμή της έκφρασης (Β*Γ>Α+Β) ΚΑΙ (ΟΧΙ(Δ)) είναι ΑΛΗΘΗΣ.
  5. Κατά την εκτέλεση της εντολής ΔΙΑΒΑΣΕ, το πρόγραμμα διακόπτει την εκτέλεσή του και περιμένει την εισαγωγή τιμών από το πληκτρολόγιο.
  6. Οι πίνακες δεν μπορούν να έχουν περισσότερες από δύο διαστάσεις.

Μονάδες 6

Θέμα Α, Ερώτημα 2, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω ημιτελές τμήμα αλγορίθμου:

k<-1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
ΑΝΤΟΤΕ
Α[k] <- i
Α[…]<- …
Α[…]<- …
k <-
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με τα κενά συμπληρωμένα, έτσι ώστε για τα μη μηδενικά στοιχεία ενός δισδιάστατου πίνακα ΠΙΝ[4,5] να τοποθετεί σε ένα μονοδιάστατο πίνακα Α[60] τις ακόλουθες πληροφορίες: τη γραμμή, τη στήλη, και κατόπιν την τιμή του.

Μονάδες 8

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 3, 2013, Μαΐου-Ιουνίου, Ημερήσια

α. Να αναφέρετε ονομαστικά τους λόγους για τους οποίους αναθέτουμε την επίλυση ενός προβλήματος σε υπολογιστή

(μονάδες 4).

β. Να γράψετε τις περιπτώσεις για τις οποίες δικαιολογείται η χρήση της σειριακής μεθόδου αναζήτησης σε έναν πίνακα

(μονάδες 3).

γ. Να γράψετε τα πλεονεκτήματα των γλωσσών υψηλού επιπέδου

(μονάδες 4).

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια