Επιλογή Σελίδας

Ερώτημα 1, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια,

Δίνεται η παρακάτω αλληλουχία εντολών:

α<- 1

Όσο α <> 6 επανάλαβε

α<- α + 2

Τέλος_επανάληψης

Εκτύπωσε α

α.   Να απαντήσετε στο τετράδιό σας με Ναι ή Όχι αν η  παραπάνω αλληλουχία εντολών ικανοποιεί όλα τα αλγοριθμικά κριτήρια.

Μονάδες 2

β.   Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

Ερώτημα 2, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια,

Δίνεται η παρακάτω αλληλουχία εντολών:

α<- 1

Όσο α <> 6 επανάλαβε

α<- α + 2

Τέλος_επανάληψης

Εκτύπωσε α

α.   Να απαντήσετε στο τετράδιό σας με Ναι ή Όχι αν η  παραπάνω αλληλουχία εντολών ικανοποιεί όλα τα αλγοριθμικά κριτήρια.

Μονάδες 2

β.   Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

 

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Ερώτημα 3, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος :

Αλγόριθμος Παράδειγμα_1

Διάβασε α

Αν α < 0  τότε

Α<- α * 5

Τέλος_αν

Εκτύπωσε α

Τέλος Παράδειγμα_1

Να γράψετε στο τετράδιό σας:

α. τις σταθερές

β. τις μεταβλητές

γ. τους λογικούς τελεστές

δ. τους αριθμητικούς τελεστές

ε. τις λογικές εκφράσεις

στ. τις εντολές εκχώρησης

που υπάρχουν στον παραπάνω αλγόριθμο.

Μονάδες 12

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Ερώτημα 4, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια

Σε ποιες στοιχειώδεις λογικές δομές στηρίζεται ο δομημένος προγραμματισμός; (Μονάδες 3).

Να αναφέρετε τέσσερα πλεονεκτήματα του δομημένου προγραμματισμού (Μονάδες 4).

Μονάδες 7

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Θέμα Β, 2003, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος :

Αλγόριθμος Αριθμοί

Διάβασε Α

Εκτύπωσε Α

S<-1

Αρχή_επανάληψης

Αν Α MOD K = 0 τότε

Β <- Α DIV K

Αν Κ <> Β τότε

   S<- S + K + B

Εκτύπωσε Κ, Β

αλλιώς

S<- S + K

       Εκτύπωσε K

Τέλος_αν

 Τέλος_αν

Κ<- Κ + 1

Μέχρις_ότου Κ > Ρίζα (Α)

Αν Α = S τότε

     Εκτύπωσε S

Τέλος_αν

Τέλος Αριθμοί

Η συνάρτηση Ρίζα (Α) επιστρέφει την τετραγωνική ρίζα του Α.

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   36

β.   28

Μονάδες 20

Παρατήρηση που αφορά στα ΘΕΜΑΤΑ 3ο και 4ο

Οι εντολές σε έναν αλγόριθμο μπορούν να γραφούν με μικρά ή κεφαλαία γράμματα.

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Θέμα Γ, 2003, Επαναληπτικές, Ημερήσια

Κάποια δημοτική αρχή ακολουθεί την εξής τιμολογιακή πολιτική για την κατανάλωση νερού ανά μήνα: Χρεώνει πάγιο ποσό 2 ευρώ και  εφαρμόζει κλιμακωτή χρέωση σύμφωνα με τον παρακάτω πίνακα:

Κατανάλωση σε κυβικά μέτρα Χρέωση ανά κυβικό
από 0 έως και 5 δωρεάν
από 5 έως και 10 0,5 ευρώ
από 10 έως και 20 0,7 ευρώ
από 20 και άνω 1,0 ευρώ

Στο ποσό που προκύπτει από την αξία του νερού και το πάγιο υπολογίζεται ο Φ.Π.Α. με συντελεστή 18%. Το τελικό ποσό προκύπτει από την άθροιση της αξίας του νερού, το πάγιο, το Φ.Π.Α. και το δημοτικό φόρο που είναι 5 ευρώ.

Να γράψετε αλγόριθμο ο οποίος:

α.   Να διαβάζει τη μηνιαία κατανάλωση του νερού.

Μονάδες 2

β.   Να υπολογίζει την αξία του νερού που καταναλώθηκε σύμφωνα με την παραπάνω τιμολογιακή πολιτική.

Μονάδες 10

γ.   Να υπολογίζει το Φ.Π.Α.

Μονάδες 4

δ.   Να υπολογίζει και να εκτυπώνει το τελικό ποσό.

Μονάδες 4

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Θέμα Δ, 2003, Επαναληπτικές, Ημερήσια

Κατά τη διάρκεια πρωταθλήματος μπάσκετ μια ομάδα που αποτελείται από δώδεκα (12) παίκτες έδωσε είκοσι (20) αγώνες, στους οποίους συμμετείχαν όλοι οι παίκτες.

Να αναπτύξετε στο τετράδιό σας αλγόριθμο ο οποίος:

α. Να διαβάζει τα ονόματα των παικτών και να τα αποθηκεύει σε μονοδιάστατο πίνακα.

Μονάδες 2

β. Να διαβάζει τους πόντους που σημείωσε κάθε παίκτης σε κάθε αγώνα και να τους αποθηκεύει σε πίνακα δύο διαστάσεων.

Μονάδες 3

γ. Να υπολογίζει για κάθε παίκτη το συνολικό αριθμό πόντων του σε όλους τους αγώνες και το μέσο όρο πόντων ανά αγώνα.

Μονάδες 6

δ. Να εκτυπώνει τα ονόματα των παικτών της ομάδας και το μέσο όρο πόντων του κάθε παίκτη ταξινομημένα με βάση το μέσο όρο τους κατά φθίνουσα σειρά.

Παρατήρηση: Σε περίπτωση ισοβαθμίας δεν μας ενδιαφέρει η σχετική σειρά των παικτών.

Μονάδες 9

Παρατήρηση που αφορά στα ΘΕΜΑΤΑ 3ο και 4ο

Οι εντολές σε έναν αλγόριθμο μπορούν να γραφούν με μικρά ή κεφαλαία γράμματα.

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Ερώτημα 1, Θέμα Α, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Ένας αλγόριθμος είναι μία πεπερασμένη σειρά ενεργειών.
  2. Οι ενέργειες που ορίζει ένας αλγόριθμος είναι αυστηρά καθορισμένες.
  3. Η έννοια του αλγόριθμου συνδέεται αποκλειστικά με την Πληροφορική.
  4. Ο αλγόριθμος τελειώνει μετά από πεπερασμένα βήματα εκτέλεσης εντολών.
  5. Ο πιο δομημένος τρόπος παρουσίασης αλγορίθμων είναι με ελεύθερο κείμενο.
  6. Ένας αλγόριθμος στοχεύει στην επίλυση ενός προβλήματος.

Μονάδες 12

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 2, Θέμα Α, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα τα γράμματα της Στήλης Β που αντιστοιχούν σωστά. (Να σημειωθεί ότι σε κάποια στοιχεία της ψευδογλώσσας της Στήλης  Α  αντιστοιχούν περισσότερα  από ένα παραδείγματα  εντολών της Στήλης Β).

Στήλη Α

Στοιχεία ψευδογλώσσας

Στήλη Β

Παραδείγματα εντολών

1.          εντολή εκχώρησης α. Επίλεξε*  Χ

Περίπτωση 1

    X <- Χ + 1

Περίπτωση 2

    X <- α * β

Τέλος_επιλογών

2. δομή επιλογής β.   Όσο   Χ   <   0 επανάλαβε

                 X <- Χ – 1

      Τέλος_επανάληψης

3. δομή επανάληψης γ. α <- β + 1
  δ. Αρχή_επανάληψης

        Ι <- Ι – 1

    Μέχρις_ότου Ι < 0

ε. Αν Χ = 2 τότε

          Χ <- Χ/2

   Τέλος_αν

Μονάδες 10

*H εντολή Επίλεξε είναι πλέον εκτός ύλης.

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια