Επιλογή Σελίδας

Δίνεται ο παρακάτω αλγόριθμος :

Αλγόριθμος Αριθμοί

Διάβασε Α

Εκτύπωσε Α

S<-1

Αρχή_επανάληψης

Αν Α MOD K = 0 τότε

Β <- Α DIV K

Αν Κ <> Β τότε

   S<- S + K + B

Εκτύπωσε Κ, Β

αλλιώς

S<- S + K

       Εκτύπωσε K

Τέλος_αν

 Τέλος_αν

Κ<- Κ + 1

Μέχρις_ότου Κ > Ρίζα (Α)

Αν Α = S τότε

     Εκτύπωσε S

Τέλος_αν

Τέλος Αριθμοί

Η συνάρτηση Ρίζα (Α) επιστρέφει την τετραγωνική ρίζα του Α.

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   36

β.   28

Μονάδες 20

Παρατήρηση που αφορά στα ΘΕΜΑΤΑ 3ο και 4ο

Οι εντολές σε έναν αλγόριθμο μπορούν να γραφούν με μικρά ή κεφαλαία γράμματα.

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Share This