Επιλογή Σελίδας

Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα τα γράμματα της Στήλης Β που αντιστοιχούν σωστά. (Να σημειωθεί ότι σε κάποια στοιχεία της ψευδογλώσσας της Στήλης  Α  αντιστοιχούν περισσότερα  από ένα παραδείγματα  εντολών της Στήλης Β).

Στήλη Α

Στοιχεία ψευδογλώσσας

Στήλη Β

Παραδείγματα εντολών

1.          εντολή εκχώρησης α. Επίλεξε*  Χ

Περίπτωση 1

    X <- Χ + 1

Περίπτωση 2

    X <- α * β

Τέλος_επιλογών

2. δομή επιλογής β.   Όσο   Χ   <   0 επανάλαβε

                 X <- Χ – 1

      Τέλος_επανάληψης

3. δομή επανάληψης γ. α <- β + 1
  δ. Αρχή_επανάληψης

        Ι <- Ι – 1

    Μέχρις_ότου Ι < 0

ε. Αν Χ = 2 τότε

          Χ <- Χ/2

   Τέλος_αν

Μονάδες 10

*H εντολή Επίλεξε είναι πλέον εκτός ύλης.

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Share This