Επιλογή Σελίδας

Θέμα Β, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές του:
1         Διάβασε Χ
2         Όσο X>1 επανάλαβε
3                 Aν Χ mod 2=0  τότε
4                        Χ<-Χ div 2
5                 αλλιώς
6                         Χ<-3*Χ+1
7                 Τέλος_αν
8       Τέλος_επανάληψης
Επίσης   δίνεται   το   παρακάτω   υπόδειγμα   πίνακα   (πίνακας τιμών), με συμπληρωμένη την αρχική τιμή της μεταβλητής Χ.

Αριθμός Εντολής Χ Χ>1 Χ mod 2=0
1 5

Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχική τιμή Χ=5 (που ήδη φαίνεται στον πίνακα).

Α.   Για   κάθε   εντολή   που   εκτελείται   να   γράψετε   σε   νέα γραμμή του πίνακα τα εξής:

  1. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
  2. Αν η γραμμή περιέχει εντολή εκχώρησης, τη νέα τιμή της μεταβλητής στην αντίστοιχη στήλη. Αν η γραμμή περιέχει έλεγχο συνθήκης, την τιμή της συνθήκης (Αληθής, Ψευδής) στην αντίστοιχη στήλη.

Μονάδες 16

Β.   Να κάνετε τη διαγραμματική αναπαράσταση του ανωτέρω τμήματος αλγορίθμου (διάγραμμα ροής).

Μονάδες 4

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Θέμα B, 2008, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα σε γλώσσα:

ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
ΔΙΑΒΑΣΕ x,n
m <- n
pow <- 1
z <- x
ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
         ΟΣΟ ( m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
m <- m DIV 2
z <- z * z
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
m <- m-1
         ΓΡΑΨΕ pow
pow <- pow*z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

α.   Να κατασκευάσετε το ισοδύναμο διάγραμμα ροής του προγράμματος Α.

Μονάδες 8

β.    Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί: x = 2, n = 3.

Μονάδες 12

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 2, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Ι <- 1
Όσο   Ι < 10  επανάλαβε
Εμφάνισε Ι
Ι <- Ι + 3
Τέλος_επανάληψης

  1. Να σχεδιάσετε το ισοδύναμο διάγραμμα ροής.

Μονάδες 4

  1. Να ξαναγράψετε το παραπάνω τμήμα αλγορίθμου χρησιμοποιώντας την εντολή ΓΙΑ αντί της εντολής ΟΣΟ.

Μονάδες 5

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Θέμα Α, Ερώτημα 3, 2007, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε φυσική γλώσσα κατά βήματα:

Βήμα 1: Αν Α > 0 τότε πήγαινε στο Βήμα 5

Βήμα 2: Αν Α = 0 τότε πήγαινε στο Βήμα 7

Βήμα 3: Τύπωσε “Αρνητικός’’

Βήμα 4: Πήγαινε στο Βήμα 8

Βήμα 5: Τύπωσε “Θετικός’’

Βήμα 6: Πήγαινε στο Βήμα 8

Βήμα 7: Τύπωσε “Μηδέν’’

Βήμα 8: Τύπωσε “Τέλος’’

  1. Να σχεδιάσετε το ισοδύναμο διάγραμμα ροής.

Μονάδες 6

  1. Να κωδικοποιήσετε τον αλγόριθμο σε ψευδογλώσσα σύμφωνα με τις αρχές του δομημένου προγραμματισμού.

Μονάδες 5

Τα θέματα σε pdf, 2007, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 1, Θέμα B, 2006, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής:

2016-10-04-16_43_35-aepp_2006_imerisia

α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα.

Μονάδες 7

β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Υ, όπως θα εμφανισθεί σε κάθε περίπτωση.

  1. Χ = 9
  2. Χ = 10
  3. Χ = 40

Μονάδες 3

Τα θέματα σε pdf, 2006, Μαΐου-Ιουνίου, Ημερήσια

 

Ερώτημα 2, Θέμα B, 2006, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος σε ψευδογλώσσα:

Αλγόριθμος Μετατροπή

Χ <- 0

Για Κ από 1 μέχρι 10

      Διάβασε Λ

      Αν Λ > 0 τότε

            Χ <- Χ + Λ

      Αλλιώς

Χ <- Χ – Λ

     Τέλος_Αν

Τέλος_Επανάληψης

Εμφάνισε Χ

Τέλος Μετατροπή

Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Τα θέματα σε pdf, 2006, Μαΐου-Ιουνίου, Ημερήσια