Επιλογή Σελίδας

Ένα πρατήριο υγρών καυσίμων διαθέτει έναν τύπο καυσίμου που αποθηκεύεται σε δεξαμενή χωρητικότητας 10.000 λίτρων. Να αναπτύξετε αλγόριθμο ο οποίος:
Γ1. να διαβάζει την ποσότητα (σε λίτρα) του καυσίμου που υπάρχει αρχικά στη δεξαμενή μέχρι να δοθεί έγκυρη τιμή.
Μονάδες 2
Για κάθε όχημα που προσέρχεται στο πρατήριο:
Γ2. να διαβάζει τον τύπο του οχήματος (“Β” για βυτιοφόρο όχημα που προμηθεύει το πρατήριο με καύσιμο και “E” για επιβατηγό όχημα που προμηθεύεται καύσιμο από το πρατήριο).
Μονάδες 2
Γ3. Αν το όχημα είναι βυτιοφόρο τότε να γεμίζει τη δεξαμενή μέχρι την πλήρωσή της. (μονάδες 3)
Αν το όχημα είναι επιβατηγό τότε να διαβάζει την ποσότητα καυσίμου την οποία θέλει να προμηθευτεί (μονάδες 2)
και, αν υπάρχει επάρκεια καυσίμου στη δεξαμενή, τότε το επιβατηγό όχημα να εφοδιάζεται με τη ζητούμενη ποσότητα καυσίμου, διαφορετικά το όχημα να μην εξυπηρετείται (μονάδες 3).
Μονάδες 8
Γ4. Η επαναληπτική διαδικασία να τερματίζεται, όταν αδειάσει η δεξαμενή του πρατηρίου ή όταν δεν εξυπηρετηθούν τρία διαδοχικά επιβατηγά οχήματα.
Μονάδες 4
Γ5.   Στο τέλος ο αλγόριθμος να εμφανίζει:
α. τη μέση ποσότητα καυσίμου ανά επιβατηγό όχημα που εξυπηρετήθηκε
β. τη συνολική ποσότητα καυσίμου με την οποία τα βυτιοφόρα ανεφοδίασαν τη δεξαμενή.
Μονάδες 4

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΛΥΣΗ


ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2011_ΕΠΑΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: Εξυπηρετήθηκαν, Πλήθος
 ΠΡΑΓΜΑΤΙΚΕΣ: Διαθέσιμο, Ανεφοδιασμός, Ποσότητα, S, ΜΟ
 ΧΑΡΑΚΤΗΡΕΣ: Τύπος
 ΛΟΓΙΚΕΣ: Τέλος
ΑΡΧΗ
! Γ1
Αρχή_επανάληψης
 Διάβασε Διαθέσιμο ! Διαθέσιμη ποσότητα
Μέχρις_ότου (Διαθέσιμο >= 0) ΚΑΙ (Διαθέσιμο <= 10000)

! Γ2 - Γ3
Τέλος <-- Ψευδής
Πλήθος <-- 0
S <-- 0
Εξυπηρετήθηκαν <-- 0
Ανεφοδιασμός <-- 0
Όσο Τέλος = Ψευδής επανάλαβε
 Γράψε 'Τύπος Οχήματος (Β ή Ε)'
 Διάβασε Τύπος
 Αν Τύπος = 'Β' τότε
    Ανεφοδιασμός <-- Ανεφοδιασμός+(10000-Διαθέσιμο)
    Διαθέσιμο <-- 10000
 αλλιώς_αν Τύπος = 'Ε' ΤΟΤΕ
    Διάβασε Ποσότητα
    Αν Διαθέσιμο - Ποσότητα >= 0 τότε
       S <-- S + Ποσότητα
       Εξυπηρετήθηκαν <-- Εξυπηρετήθηκαν + 1
       Διαθέσιμο <-- Διαθέσιμο - Ποσότητα
       Πλήθος <-- 0
       Αν Διαθέσιμο = 0 τότε
          Τέλος <-- Αληθής
       Τέλος_αν
    αλλιώς 
       Γράψε 'Το επιβατικό δεν μπορεί να εξυπηρετηθεί!'
       Πλήθος <-- Πλήθος+1
       Αν Πλήθος = 3 τότε
          Τέλος <-- Αληθής
       Τέλος_αν
    Τέλος_αν
 Τέλος_αν
Τέλος_επανάληψης

ΜΟ <-- S / Εξυπηρετήθηκαν
Γράψε 'ΜΟ ποσότητας Επιβατικών ', ΜΟ
Γράψε 'Συνολικός Ανεφοδιασμός', Ανεφοδιασμός

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This