Επιλογή Σελίδας

Ένας όμιλος αποτελείται από 20 εταιρίες. Να γράψετε πρόγραμμα το οποίο:
Δ1. να περιλαμβάνει τμήμα δηλώσεων.
Μονάδες 2
Δ2. να διαβάζει τα ονόματα των εταιριών του ομίλου και τα κέρδη τους για κάθε ένα από τα έτη 2001 έως και 2005. (Θεωρήστε ότι τα κέρδη είναι θετικοί αριθμοί.)
Μονάδες 2
Δ3. για κάθε εταιρία του ομίλου να καλεί συνάρτηση για τον υπολογισμό του συνολικού κέρδους της εταιρίας στην πενταετία. Στη συνέχεια να υπολογίζει και να εμφανίζει το μέσο ετήσιο κέρδος του ομίλου.
Μονάδες 5
Δ4. για κάθε εταιρία να βρίσκει την τριετία με το μεγαλύτερο συνολικό κέρδος και να εμφανίζει το όνομα της εταιρίας και το πρώτο έτος της συγκεκριμένης τριετίας. (Θεωρήστε ότι η τριετία αυτή είναι μοναδική.)
Μονάδες 5
Δ5.   Να κατασκευάσετε τη συνάρτηση που θα χρησιμοποιήσετε στο ερώτημα Δ3.
Μονάδες 6

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΛΥΣΗ 

ΘΕΜΑΔ_2011ΕΠΑΝΗΜΕΡ [demoδεδομέναγια_5εταιρίες]

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ_2011_ΕΠΑΝ_ΗΜΕΡ
ΣΤΑΘΕΡΕΣ
 ΕΤΑΙΡΙΕΣ=5 ! Ξαναδηλώνεται και στο υποπρόγραμμα, 5 για τα demo δεδομένα,
            ! 20 για την άσκηση
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, j, k, Tριετία
 ΠΡΑΓΜΑΤΙΚΕΣ: ΚΕΡΔΗ[ΕΤΑΙΡΙΕΣ, 5], Κέρδη_5ετιας, ΜΟ, Μέγιστο, Κέρδη_3ετιας[3]
 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[ΕΤΑΙΡΙΕΣ]
ΑΡΧΗ 
! Δ2 Ονόματα
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΕΤΑΙΡΙΕΣ
     ΔΙΑΒΑΣΕ ΟΝ[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

! Δ2 Κέρδη κάθε εταιρία σε γραμμή
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΕΤΑΙΡΙΕΣ
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
        ΔΙΑΒΑΣΕ ΚΕΡΔΗ[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ3
 ΓΡΑΨΕ 'ΜΟ ΚΕΡΔΩΝ 5ΕΤΙΑΣ:'
 ΓΡΑΨΕ 'ΕΤΑΙΡΙΑ - ΜΟ'
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΕΤΑΙΡΙΕΣ
     Κέρδη_5ετιας <-- Υπολογισμός_κερδών_5ετιας(ΚΕΡΔΗ, i)
     ΜΟ <-- Κέρδη_5ετιας/5
     ΓΡΑΨΕ ΟΝ[i], ΜΟ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ! Δ4
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΕΤΑΙΡΙΕΣ

     ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 3
         Κέρδη_3ετιας[k] <-- 0
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΓΙΑ k ΑΠΟ 0 ΜΕΧΡΙ 2
         ΓΙΑ j ΑΠΟ 1+k ΜΕΧΡΙ 3+k
             Κέρδη_3ετιας[k+1] <-- Κέρδη_3ετιας[k+1] + ΚΕΡΔΗ[i, j]
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     Μέγιστο <-- Κέρδη_3ετιας[1]
     Tριετία <-- 1
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 3
        ΑΝ Κέρδη_3ετιας[j] > Μέγιστο ΤΟΤΕ
           Μέγιστο <-- Κέρδη_3ετιας[j]
           Tριετία <-- j
        ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΓΡΑΨΕ ΟΝ[i]
     ΓΡΑΨΕ 'Η τριετία με το μεγαλύτερο κέρδος ήταν :'

     ΑΝ Tριετία = 1 ΤΟΤΕ
       ΓΡΑΨΕ '1η: 2001-2003'
     ΑΛΛΙΩΣ_ΑΝ Tριετία = 2 ΤΟΤΕ
       ΓΡΑΨΕ '2η: 2002-2004'
     ΑΛΛΙΩΣ
       ΓΡΑΨΕ '3η: 2003-2005'
     ΤΕΛΟΣ_ΑΝ

 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Δ5
ΣΥΝΑΡΤΗΣΗ Υπολογισμός_κερδών_5ετιας(ΚΕΡΔΗ, Εταιρία) : ΠΡΑΓΜΑΤΙΚΗ
ΣΤΑΘΕΡΕΣ
 ΕΤΑΙΡΙΕΣ=5
ΜΕΤΑΒΛΗΤΕΣ
 ΠΡΑΓΜΑΤΙΚΕΣ: ΚΕΡΔΗ[ΕΤΑΙΡΙΕΣ, 5], S
 ΑΚΕΡΑΙΕΣ: Εταιρία, j
ΑΡΧΗ
 S <-- 0
 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
     S <-- S + ΚΕΡΔΗ[Εταιρία, j]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Υπολογισμός_κερδών_5ετιας <-- S

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This