Επιλογή Σελίδας

Παράδειγμα 4, Κεφάλαιο 8, Βιβλίο, Άθροισμα Περιττών μέχρι το 100

Το παρακάτω πρόγραμμα υπολογίζει το άθροισμα των περιττών αριθμών που είναι μικρότεροι από το 100.

ΠΡΟΓΡΑΜΜΑ Περιττοί 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Άθροισμα, Αριθμός 
ΑΡΧΗ  
Άθροισμα <-- 0 
ΓΙΑ Αριθμός ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2   
    Άθροισμα <-- Άθροισμα + Αριθμός 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Άθροισμα περιττών αριθμών είναι: ', Άθροισμα 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Θέμα A, Ερώτημα 4, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, το οποίο εμφανίζει τα τετράγωνα των περιττών αριθμών από το 99 μέχρι το 1 με φθίνουσα σειρά.

Για i από 99 μέχρι 1 μεβήμα -2
x <- i ^2
εμφάνισε x
Τέλος
επανάληψης

α. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Όσο … επανάλαβε».

(μονάδες 5)

β. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Αρχήεπανάληψης … Μέχριςότου».

(μονάδες 5)

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 4, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Για Χ από Α μέχρι Μ με_βήμα Β
Εμφάνισε Χ
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας για καθεμία από τις παρακάτω περιπτώσεις τις τιμές των Α, Μ, Β, έτσι ώστε το αντίστοιχο τμήμα αλγορίθμου να εμφανίζει όλους:
1. τους ακεραίους από 1 μέχρι και 100
2. τους ακεραίους από 10 μέχρι και 200 σε φθίνουσα σειρά
3. τους ακεραίους από -1 μέχρι και -200 σε αύξουσα σειρά
4. τους άρτιους ακεραίους από 100 μέχρι και 200
5. τους θετικούς ακεραίους που είναι μικρότεροι του 8128 και πολλαπλάσια του 13.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Παράδειγμα 10. Υπολογισμός αθροίσματος αριθμών με επαναληπτική εντολή: για…από…μέχρι

Να βρεθεί και να εκτυπωθεί το άθροισμα των 100 ακεραίων από το 1 μέχρι το 100.
Όταν ο αριθμός των φορών που θα εκτελεστεί μια επαναληπτική διαδικασία είναι γνωστός εκ των προτέρων, τότε είναι προτιμότερο να χρησιμοποιείται η εντολή Για…από…μέχρι. Έτσι ο ζητούμενος αλγόριθμος είναι.

Αλγόριθμος Παράδειγμα10
Sum ← 0
Για i από 1 μέχρι 100
Sum ← Sum + i
Τέλος
επανάληψης
Εκτύπωσε Sum
Τέλος Παράδειγμα_10

Όπως γίνεται φανερό, η εντολή Για…από…μέχρι περιλαμβάνει όλα τα απαιτούμενα στοιχεία για την επανάληψη, δηλαδή αρχική τιμή της μεταβλητής i ( = 1) και τελική τιμή ( = 100). Το βήμα μεταβολής της μεταβλητής i είναι 1, το οποίο υπονοείται και δεν σημειώνεται, όταν είναι 1. Η μεταβλητή Sum που υποδέχεται το άθροισμα των διαδοχικών αριθμών, πρέπει να εκκινήσει με τιμή 0, ενώ το εκάστοτε μερικό άθροισμα υπολογίζεται με την εντολή εκχώρησης εντός του βρόχου. Στο τέλος η μεταβλητή Sum θα περιέχει το τελικό άθροισμα.

Παρατήρηση: Sum ← Sum + i ⇒ Η νέα τιμή του Sum είναι η παλιά συν i

Θέμα Β, 2002, Επαναληπτικές

Δίνεται μονοδιάστατος πίνακας Α, 10 θέσεων, ο οποίος στις θέσεις 1 έως 10 περιέχει αντίστοιχα τους αριθμούς:

15, 3, 0, 5, 16, 2, 17, 8, 19, 1

και τμήμα αλγορίθμου:

Για i από 1 μέχρι 9 μεβήμα 2
k<-((i+10) mod 10)+1
Α[i]<-Α[k]
εκτύπωσε i, k, A[i], A[k]
Τέλοςεπανάληψης

Ποιές τιμές τυπώνονται με την εντολή
εκτύπωσε i, k, A[i], A[k] καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου;
Μονάδες 20

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Χ <- Α
Αρχήεπανάληψης
Χ<-Χ+2
τύπωσε το Χ
μέχριςότου Χ >= Μ
α. Να δώσετε τη δομή επανάληψης “Για … από … μέχρι … βήμα” η οποία τυπώνει ακριβώς τις ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
Μονάδες 7
β. Τι θα τυπωθεί, αν Α = 4 και Μ = 9;
Μονάδες 3
γ. Τι θα τυπωθεί, αν Α = -5 και Μ = 0 ;
Μονάδες 3

ΛΥΣΗ: (περισσότερα…)