Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου, με αριθμημένες τις γραμμές του:

  1. max <- Π[1]
  2. Για i από 2 μέχρι 5
  3. Αν Π[i] > max τότε
  4. max <- Π[i]
  5. Τέλος_αν
  6. Τέλος_επανάληψης

α.   Τι υπολογίζει αυτό το τμήμα αλγορίθμου; (μονάδες 2)
β.   Πόσες φορές τουλάχιστον θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
γ.   Πόσες φορές το πολύ θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
δ. Να αιτιολογήσετε γιατί ο πίνακας Π δεν μπορεί να είναι πίνακας λογικών τιμών (μονάδες 4).
Μονάδες 10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

α. Υπολογίζει το μέγιστο στοιχείο από έναν πίνακα 5 θέσεων.
β. Καμία φορά.
γ. Τέσσερις (4) φορές.
δ. Στη γραμμή 3 τα στοιχεία του πίνακα Π συγκρίνονται με τη χρήση του συγκριτικού τελεστή >. Αυτό είναι δυνατό μόνο σε αριθμητικές και αλφαριθμητικές τιμές.

Share This