Επιλογή Σελίδας

Διάβασε προσεκτικά τα παρακάτω τμήματα προγράμματος. Ποια είναι τα λάθη; Διόρθωσέ τα, ώστε να λειτουργούν σωστά.Εκτέλεσε εικονικά τις εντολές στο χαρτί και σημείωνε τα αποτελέσματα που προκύπτουν. Με αυτόν τον τρόπο θα δεις τα λάθη και στη συνέχεια θα κάνεις τις διορθώσεις.

ΛΥΣΗ

Α)

ΔΙΑΒΑΣΕ Μισθός
ΑΘροισμα <-- 0 
ΟΣΟ Μισθός <>0 ΕΠΑΝΑΛΑΒΕ 
    Άθροισμα <- 0 
    ΑΝ Μισθός > Μέγιστος ΤΟΤΕ 
       Μέγιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    ΑΝ Μισθός < Ελάχιστος ΤΟΤΕ 
       Ελάχιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    Άθροισμα <- Άθροισμα+Μισθός 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β)

Άθροισμα <-- 0
Διάβασε Μισθός
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    Άθροισμα <- 0 
    ΑΝ Μισθός > Μέγιστος ΤΟΤΕ 
       Μέγιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    ΑΝ Μισθός < Ελάχιστος ΤΟΤΕ 
       Ελάχιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    Άθροισμα <- Άθροισμα+Μισθός 
    ΔΙΑΒΑΣΕ Μισθός 
ΜΕΧΡΙΣ_ΟΤΟΥ Μισθός<>0

Γ)

Άθροισμα <-- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100 
    Άθροισμα <- 0 
    ΔΙΑΒΑΣΕ Μισθός 
    ΑΝ Μισθός > Μέγιστος ΤΟΤΕ 
       Μέγιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    ΑΝ Μισθός < Ελάχιστος ΤΟΤΕ 
       Ελάχιστος <- Μισθός 
    ΤΕΛΟΣ_ΑΝ 
    Άθροισμα <- Άθροισμα+Μισθός 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Share This