Επιλογή Σελίδας

Έστω το παρακάτω τμήμα προγράμματος:

Κ <- 0 
ΓΙΑ Ι ΑΠΟ 0 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 5 
    Α <- Ι^3 
    Κ <- Κ+Α 
    ΓΡΑΨΕ Ι, Α 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Κ

Πόσες φορές θα εκτελεστεί ο βρόχος; Ποια η λειτουργία των εντολών; Γράψτε τις παραπάνω εντολές χρησιμοποιώντας την εντολή επανάληψης ΟΣΟ και την εντολή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. Ποιον από τους τρεις τρόπους προτιμάς και γιατί;

ΛΥΣΗ
Υπολογίζει το άθροισμα των κύβων των αριθμών που είναι πολλαπλάσια του 5 και είναι μικρότεροι ή ίσοι µε 100. Τυπώνει τους αριθμούς καθώς και την ύψωση τους στον κύβο και τέλος το άθροισμα τους.

Ι ← 0 
Κ ← 0 
ΟΣΟ Ι <=100 ΕΠΑΝΑΛΑΒΕ 
 Α ← Ι^3 
 Κ ← Κ+Α 
 ΓΡΑΨΕ Ι, Α 
 Ι ← Ι+5 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ Κ 

Ι ← 0 
Κ ← 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
 Α ← Ι^3 
 Κ ← Κ+Α 
 ΓΡΑΨΕ Ι, Α 
 Ι ← Ι+5 
ΜΕΧΡΙΣ_ΟΤΟΥ Ι > 100 
ΓΡΑΨΕ Κ

Ο καλύτερος τρόπος είναι µε χρήση της εντολής ΓΙΑ. Η εντολή ΓΙΑ πρέπει πάντα να χρησιμοποιείται όταν έχουμε προκαθορισμένο αριθμό επαναλήψεων.

Share This