Επιλογή Σελίδας

Έχουμε δύο πίνακες, ο ένας με τα μοντέλα των υπολογιστών και ο δεύτερος με τις τιμές τους. Να γράψετε τις εντολές που βρίσκουν και τυπώνουν το φθηνότερο μοντέλο καθώς και το ακριβότερο.

ΛΥΣΗ

!Μέγιστο
Μέγιστο←ΤΙΜΗ[1] 
ΘέσηΜεγ←1 
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν 
    ΑΝ ΤΙΜΗ [Ι] > Μέγιστο ΤΟΤΕ 
       Μέγιστο <--ΤΙΜΗ[Ι] 
       ΘέσηΜεγ <--Ι 
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

!Ελάχιστο
Ελάχιστο<--ΤΙΜΗ[1] 
ΘέσηΕλαχ<--1 
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΝ ΤΙΜΗ [Ι] < Ελάχιστο ΤΟΤΕ 
       Ελάχιστο<--ΤΙΜΗ[Ι] 
    ΘέσηΕλαχ<--Ι 
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Μοντέλο[ΘέσηΜεγ], Μοντέλο[ΘέσηΜεγ]
Share This