Επιλογή Σελίδας

Η πιο απλή μορφή αναζήτησης στοιχείου σε πίνακα είναι η σειριακή (sequential) ή γραμμική (linear) μέθοδος. Έτσι για τον επόμενο αλγόριθμο Sequential Search υποτίθεται ότι αναζητείται η τιμή key στο μη ταξινομημένο πίνακα table. Μετά την εκτέλεση του αλγορίθμου η μεταβλητή position επιστρέφει την τιμή 0, αν η αναζήτηση είναι ανεπιτυχής, ενώ αν η αναζήτηση είναι επιτυχής, τότε επιστρέφει τη θέση του στοιχείου στον πίνακα (δηλαδή, έναν αριθμό από 1 ως n).

ΛΥΣΗ:

Αλγόριθμος Sequential_Search
 Δεδομένα // n, table, key //
 done ← ψευδής
 position ← 0
 i ← 1
 Όσο (done=ψευδής) και (i<=n) επανάλαβε
      Αν table[i]=key τότε
         done ← αληθής
         position ← i
      αλλιώς
        i ← i+1
     Τέλος_αν
 Τέλος_επανάληψης
 Αποτελέσματα //done, position //
 Τέλος Sequential_Search
Share This