Επιλογή Σελίδας

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης
Share This