Β2. Δίνεται το παρακάτω υποπρόγραμμα σε ΓΛΩΣΣΑ με όνομα Π_Μ το οποίο ελέγχοντας τα στοιχεία 200 ατόμων υπολογίζει το πλήθος των ανήλικων ατόμων που έχουν κάποιο συγκεκριμένο όνομα.

(1) ………………… 
ΣΤΑΘΕΡΕΣ 
(2) ………………… 
ΜΕΤΑΒΛΗΤΕΣ 
(3) ΑΚΕΡΑΙΕΣ:………………… 
(4) ΧΑΡΑΚΤΗΡΕΣ: ………………… 
ΑΡΧΗ 
Π  0 
Για i από 1 μέχρι Ν 
     Αν ΗΛ[i] < 18 ΚΑΙ Ο[i]= Χ τότε 
        Π  Π+1 
     Τέλος_αν 
Τέλος_επανάληψης 
Π_Μ  Π 
(5) ………………… 
</code class="language-javascript">

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5 των γραμμών και δίπλα από κάθε αριθμό ό,τι χρειάζεται να συμπληρωθεί ώστε να είναι σωστή και πλήρης η σύνταξη του υποπρογράμματος.
Μονάδες 10

Share This