Επιλογή Σελίδας

Θέμα Α, Eρώτημα 1, 2015, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμίας από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επαναληπτικότητα των διαδικασιών είναι ένας από τους λόγους ανάθεσης της επίλυσης ενός προβλήματος σε υπολογιστή. (μονάδες 2)
  2. Ο βρόχος Για κ από 5 μέχρι 5 εκτελείται μία φορά. (μονάδες 2)
  3. Δεν υπάρχουν δομές δεδομένων δευτερεύουσας μνήμης. (μονάδες 2)
  4. Ένας από τους παράγοντες από τους οποίους εξαρτάται η επιλογή της καταλληλότερης γλώσσας προγραμματισμού για την ανάπτυξη μιας εφαρμογής είναι το είδος της εφαρμογής. (μονάδες 2)
  5. Ένα υποπρόγραμμα μπορεί να καλείται μόνο από το κύριο πρόγραμμα. (μονάδες 2)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ

  1. ΣΩΣΤΟ 2. ΣΩΣΤΟ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα Α, Ερώτημα 1, 2015, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5  και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη  λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η πράξη της σύζευξης δύο λογικών εκφράσεων δίνει ως αποτέλεσμα την τιμή ΨΕΥΔΗΣ, μόνον όταν και οι δύο εκφράσεις έχουν την  τιμή  ΨΕΥΔΗΣ.
  2. Συνηθέστατα παρατηρείται το φαινόμενο μια δομή δεδομένων να είναι αποδοτικότερη από μια άλλη δομή, με κριτήριο κάποια λειτουργία.
  3. Ο ιεραρχικός προγραμματισμός χρησιμοποιεί τη στρατηγική της συνεχούς διαίρεσης  του  προβλήματος  σε  υποπροβλήματα.
  4. Οι εντολές που βρίσκονται μέσα στο βρόχο μιας εντολής ΓΙΑ εκτελούνται τουλάχιστον  μία  φορά.
  5. Σε μία εντολή εκχώρησης δεν μπορεί να υπάρχει αναφορά σε περισσότερες από  μία  συναρτήσεις.

Μονάδες  10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

  1. Λάθος 2. Σωστό 3. Σωστό 4. Λάθος 5. Λάθος

 

Θέμα Α, Ερώτημα 4, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, με αριθμημένες τις γραμμές του:

  1. max <- Π[1]
  2. Για i από 2 μέχρι 5
  3. Αν Π[i] > max τότε
  4. max <- Π[i]
  5. Τέλος_αν
  6. Τέλος_επανάληψης

α.   Τι υπολογίζει αυτό το τμήμα αλγορίθμου; (μονάδες 2)
β.   Πόσες φορές τουλάχιστον θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
γ.   Πόσες φορές το πολύ θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
δ. Να αιτιολογήσετε γιατί ο πίνακας Π δεν μπορεί να είναι πίνακας λογικών τιμών (μονάδες 4).
Μονάδες 10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα A, Ερώτημα 4, 2014, Ημερήσια

α.      Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων με εντολές ΓΙΑ. (μονάδες 6)

β.     Ποιος είναι ο ρόλος του συντάκτη σε ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

γ.     Ποιος είναι ο ρόλος του συνδέτη-φορτωτή σε ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

δ.     Ποιος είναι ο ρόλος  του μεταγλωττιστή σε  ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

Μονάδες 12

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

 

Θέμα Β, Ερώτημα 1, 2014, Ημερήσια

Για την ταξινόμηση, σε φθίνουσα σειρά, των στοιχείων ενός μονοδιάστατου πίνακα αριθμών Π[30] μπορεί να ακολουθηθεί η παρακάτω διαδικασία: Αρχικά, ο πίνακας σαρώνεται από την αρχή μέχρι το τέλος του, προκειμένου να βρεθεί το μεγαλύτερο στοιχείο του. Αυτό το στοιχείο τοποθετείται στην αρχή του πίνακα, ανταλλάσσοντας θέσεις με το στοιχείο της πρώτης θέσης του πίνακα. Η σάρωση του πίνακα επαναλαμβάνεται, ξεκινώντας τώρα από το δεύτερο στοιχείο του πίνακα. Το μεγαλύτερο από τα στοιχεία που απέμειναν ανταλλάσσει θέσεις με το στοιχείο της δεύτερης θέσης του πίνακα. Η σάρωση επαναλαμβάνεται, ξεκινώντας από το τρίτο στοιχείο του πίνακα, μετά από το τέταρτο στοιχείο του πίνακα κ.ο.κ.

Το παρακάτω ημιτελές τμήμα αλγορίθμου κωδικοποιεί την παραπάνω διαδικασία:

Για k από 1 μέχρι 29

θ <- .(1.).

Για i από k μέχρι 30

Αν Π[i] … Π[θ] τότε
θ<- .(3..)

Τέλος_αν

Τέλοςεπανάληψης
αντιμετάθεσε .(4.). , .(5..)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε να γίνεται σωστά η ταξινόμηση.
Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 3, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο πίνακας Α[10], στον οποίο επιθυμούμε να αποθηκεύσουμε όλους τους ακεραίους αριθμούς από το 10 μέχρι το 1 με φθίνουσα σειρά. Στον πίνακα έχουν εισαχθεί ορισμένοι αριθμοί, οι οποίοι εμφανίζονται στο παρακάτω σχήμα:

1 2 3 4 5 6 7 8 9 10
10 9 5 4 1

α. Να συμπληρώσετε τις επόμενες εντολές εκχώρησης, ώστε τα κενά κελιά του πίνακα να αποκτήσουν τις επιθυμητές τιμές.

Α[3] <- 3 + Α[…]

Α[9] <- Α[…] – 2

Α[8] <- Α[…] – 5

Α[4] <- 5 + Α[…]

Α[5] <- (Α[…] + Α[7]) div 2

(μονάδες 5)

β.     Να συμπληρώσετε το παρακάτω τμήμα αλγορίθμου, το οποίο αντιμεταθέτει τις τιμές των κελιών του πίνακα Α, έτσι ώστε η τελική διάταξη των αριθμών να είναι από 1 μέχρι 10.

Για i απόμέχρι

αντιμετάθεσε Α[…], Α[…]

Τέλος_επανάληψης

(μονάδες 4)

Μονάδες 9

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, το οποίο εμφανίζει τα τετράγωνα των περιττών αριθμών από το 99 μέχρι το 1 με φθίνουσα σειρά.

Για i από 99 μέχρι 1 μεβήμα -2
x <- i ^2
εμφάνισε x
Τέλος
επανάληψης

α. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Όσο … επανάλαβε».

(μονάδες 5)

β. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Αρχήεπανάληψης … Μέχριςότου».

(μονάδες 5)

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 5, 2012, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου που χρησιμοποιεί ένα μονοδιάστατο πίνακα Α[20]. Ο πίνακας περιέχει άρτιους και περιττούς θετικούς ακεραίους, σε τυχαίες θέσεις. Το τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Β[20] στον οποίο υπάρχουν πρώτα οι άρτιοι και μετά ακολουθούν οι περιττοί. Να γράψετε στο τετράδιό σας τον αλγόριθμο συμπληρώνοντας τα κενά:

Κ <- 0
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 = 0 τότε
Κ    <-    ………….
Β[………… ] <- A[i]
Τέλος_αν
Τέλος_επανάληψης
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 =…………….. τότε
………………..
Β[………… ] <- A[………….. ]
Τέλος_αν
Τέλος_επανάληψης

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια