Επιλογή Σελίδας

Να εκπονηθεί ένας αλγόριθμος για την εύρεση όλων των ακεραίων λύσεων της εξίσωσης:
3x + 2y – 7z = 5
για τιμές των x, y, z μεταξύ των 0 και 100. Η επίλυση τέτοιων εξισώσεων με πολλές μεταβλητές που επιδέχονται πολλές λύσεις ονομάζεται διοφαντική ανάλυση.

Λύση: 

Αλγοριθμικά το πρόβλημα αντιμετωπίζεται ως εξής:

Αλγόριθμος Διοφαντική
Για x από 0 μέχρι 100
      Για y από 0 μέχρι 100
            Για z από 0 μέχρι 100
Αν 3* x+2* y-7* z=5 τότε
Εκτύπωσε x,y,z
           Τέλος_επανάληψης
      Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Share This