Επιλογή Σελίδας

Παράδειγμα 12, Βιβλίου, Πολλαπλασιασμός αλά ρωσικά

p12kef2bmΑς θεωρήσουμε την πράξη του πολλαπλασιασμού δύο ακεραίων αριθμών και ας θυμηθούμε πώς αυτή υλοποιείται χειρωνακτικά. Τοποθετούμε, λοιπόν, τους δύο αριθμούς τον ένα κάτω από τον άλλο και πολλαπλασιάζουμε κάθε ψηφίο του κάτω αριθμού με όλα τα ψηφία του επάνω αριθμού. Πιο συγκεκριμένα, για κάθε ψηφίο του κάτω αριθμού παράγεται ένα μερικό γινόμενο, ενώ τα μερικά γινόμενα τοποθετούνται το ένα κάτω από το άλλο με μία μετατόπιση από τα δεξιά προς τα αριστερά καθώς θεωρούμε διαδοχικά τα ψηφία των μονάδων, των δεκάδων, των εκατοντάδων κ.λπ. Στη συνέχεια γίνεται η πρόσθεση των επιμέρους γινομένων, αφού τα τοποθετήσουμε στην κατάλληλη διάταξη όπως φαίνεται στο σχήμα 2.7. (περισσότερα…)

Θέμα Β, 2010, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια

Υποερώτημα β, Ερώτημα 2, Θέμα Α. 2009, Μαΐου-Ιουνίου, Ημερήσια

Να μετατρέψετε σε εντολές εκχώρησης τις παρακάτω φράσεις:
α.   Εκχώρησε στο Ι τον μέσο όρο των Α, Β, Γ.
β.   Αύξησε την τιμή του Μ κατά 2.
γ.   Διπλασίασε την τιμή του Λ.
δ.   Μείωσε την τιμή του Χ κατά την τιμή του Ψ.
ε.    Εκχώρησε στο Α το υπόλοιπο της ακέραιας διαίρεσης του Α με το Β.
Μονάδες 5

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 1, Θέμα B, 2009, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται o παρακάτω αλγόριθμος, στον οποίο έχουν αριθμηθεί οι εντολές εκχώρησης:
Αλγόριθμος Πολλαπλασιασμός
Δεδομένα //α,β//
Αν α>β τότε αντιμετάθεσε α, β
1     γ<-0
       Όσο α>0 επανάλαβε
2                 δ<-α mod 10
                   Όσο δ>0 επανάλαβε
3                          δ<- δ – 1
4                          γ<- γ + β
Τέλος_επανάληψης
5             α<- α div 10
6             β<- β*10
Τέλος_επανάληψης
Αποτελέσματα //γ//
Τέλος πολλαπλασιασμός

Επίσης δίνεται υπόδειγμα πίνακα (πίνακας τιμών), με συμπληρωμένες τις αρχικές τιμές των μεταβλητών α,β (τιμές εισόδου), καθώς και της εντολής εκχώρησης με αριθμό 1.

Αριθμός Εντολής α β γ δ
20 50
1 0

Α. Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχικές τιμές α=20, β=50 (που ήδη φαίνονται στον πίνακα).

Για κάθε εντολή εκχώρησης που εκτελείται να γράψετε σε νέα γραμμή του πίνακα:
α.   Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
β.    Τη  νέα τιμή της μεταβλητής που  επηρεάζεται από την εντολή (στην αντίστοιχη στήλη).
Μονάδες 10

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 3, Θέμα B, 2009, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα:
δ<-α mod 10
Όσο δ>0 επανάλαβε
        δ<-δ-1
γ<-γ+β
Τέλος_επανάληψης
χρησιμοποιώντας αντί της εντολής Όσο την εντολή Για. Στο νέο τμήμα αλγορίθμου να χρησιμοποιήσετε μόνο τις μεταβλητές α,β,γ,δ, που χρησιμοποιεί το αρχικό τμήμα.

Μονάδες 5

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 4β, Θέμα Α, 2009, Επαναληπτικές, Ημερήσια

Δ2. Δίνονται οι τιμές των μεταβλητών Α=3, Β=1, Γ=15 και η παρακάτω έκφραση:

(ΟΧΙ (Α+Β*3>10)) ΚΑΙ MOD (A-B)=1)

Nα υπολογίσετε την τιμή της έκφρασης αναλυτικά ως εξής:
α. Να αντικαταστήσετε τις μεταβλητές με τις τιμές τους.

Μονάδα 1
β.  Να εκτελέσετε τις αριθμητικές πράξεις.

Μονάδα 1
γ. Να αντικαταστήσετε τις συγκρίσεις με την τιμή ΑΛΗΘΗΣ, αν η σύγκριση είναι αληθής, ή την τιμή ΨΕΥΔΗΣ, αν είναι ψευδής.

Μονάδα 1
δ. Να εκτελέσετε τις λογικές πράξεις, ώστε να υπολογίσετε την τελική τιμή της έκφρασης.

Μονάδες 2

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Θέμα Β, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές του:
1         Διάβασε Χ
2         Όσο X>1 επανάλαβε
3                 Aν Χ mod 2=0  τότε
4                        Χ<-Χ div 2
5                 αλλιώς
6                         Χ<-3*Χ+1
7                 Τέλος_αν
8       Τέλος_επανάληψης
Επίσης   δίνεται   το   παρακάτω   υπόδειγμα   πίνακα   (πίνακας τιμών), με συμπληρωμένη την αρχική τιμή της μεταβλητής Χ.

Αριθμός Εντολής Χ Χ>1 Χ mod 2=0
1 5

Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχική τιμή Χ=5 (που ήδη φαίνεται στον πίνακα).

Α.   Για   κάθε   εντολή   που   εκτελείται   να   γράψετε   σε   νέα γραμμή του πίνακα τα εξής:

  1. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
  2. Αν η γραμμή περιέχει εντολή εκχώρησης, τη νέα τιμή της μεταβλητής στην αντίστοιχη στήλη. Αν η γραμμή περιέχει έλεγχο συνθήκης, την τιμή της συνθήκης (Αληθής, Ψευδής) στην αντίστοιχη στήλη.

Μονάδες 16

Β.   Να κάνετε τη διαγραμματική αναπαράσταση του ανωτέρω τμήματος αλγορίθμου (διάγραμμα ροής).

Μονάδες 4

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Θέμα B, 2008, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα σε γλώσσα:

ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
ΔΙΑΒΑΣΕ x,n
m <- n
pow <- 1
z <- x
ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
         ΟΣΟ ( m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
m <- m DIV 2
z <- z * z
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
m <- m-1
         ΓΡΑΨΕ pow
pow <- pow*z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

α.   Να κατασκευάσετε το ισοδύναμο διάγραμμα ροής του προγράμματος Α.

Μονάδες 8

β.    Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί: x = 2, n = 3.

Μονάδες 12

Τα θέματα σε pdf, 2008, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2008, Επαναληπτικές, Ημερήσια

Α.   Δίνεται το παρακάτω πρόγραμμα σε «ΓΛΩΣΣΑ»

1.ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ-ΠΡΩΤΟΣ

2.ΜΕΤΑΒΛΗΤΕΣ

3.ΑΚΕΡΑΙΕΣ: Χ, i

4.ΧΑΡΑΚΤΗΡΕΣ: ΜΗΝΥΜΑ

5. ΑΡΧΗ

6.ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

7.ΔΙΑΒΑΣΕ Χ

8. ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0

9.C<- 0

10.ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Χ ΕΠΑΝΑΛΑΒΕ

11. AN (Χ MOD i) = 0 TOTE

12. C<- C + 1  

13. ΤΕΛΟΣ_ΑΝ

14.ΤΕΛΟΣ_ΓΙΑ

15.ΑΝ C=2 TOTE

16. MHNYMA<- ‘ EINAI ΠΡΩΤΟΣ’

17.ΑΛΛΙΩΣ

18.ΜΗΝΥΜΑ <- ‘ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ’ 

19.ΤΕΛΟΣ

20.ΓΡΑΨΕ ΜΗΝΥΜΑ

21.ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ

Β.

Να γράψετε στο τετράδιό σας τον αριθμό κάθε γραμμής του προγράμματος, στην οποία εντοπίζετε συντακτικό λάθος και να περιγράψετε το λάθος αυτό.

Μονάδες 12

Να  μεταφέρετε στο τετράδιό σας συμπληρωμένο τον παρακάτω πίνακα αληθείας.

Α Β (ΟΧΙ Α) ΚΑΙ (ΟΧΙ Β) ((ΟΧΙ Α) ΚΑΙ Β) Ή (Α ΚΑΙ (ΟΧΙ Β))
Ψευδής Ψευδής
Ψευδής Αληθής
Αληθής Ψευδής
Αληθής Αληθής

Μονάδες 8

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα B, 2006, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής:

2016-10-04-16_43_35-aepp_2006_imerisia

α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα.

Μονάδες 7

β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Υ, όπως θα εμφανισθεί σε κάθε περίπτωση.

  1. Χ = 9
  2. Χ = 10
  3. Χ = 40

Μονάδες 3

Τα θέματα σε pdf, 2006, Μαΐου-Ιουνίου, Ημερήσια

 

Θέμα B, 2005, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση:

Διάβασε Κ

L <- 2

Α <- 1

Όσο Α < 8 επανάλαβε

Αν Κ MOD L = Ο τότε

Χ <- Fun(Α, L)

αλλιώς

Χ <- Α + Ε

Τέλος_αν

Εμφάνισε L, Α, Χ

 

A <- A + 2

L <- L + 1

Tέλος_επανάληψης

……………

Συνάρτηση Fun(Β, Δ) : Ακέραια Μεταβλητές

Ακέραιες: Β, Δ Αρχή

Fun <- (B + Δ) DIV 2 Tέλος_συνάρτησης.

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε επανάληψη, όταν για είσοδο δώσουμε την τιμή 10.

Μονάδες 20

Τα θέματα σε pdf, 2005, Ημερήσια

Θέμα B, 2004, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Αριθμοί_ΜΕΡΣΕΝ

Διάβασε Α

B<-4

C<-2

Αρχή_επανάληψης

Β<-(Β^2) – 2

      Εμφάνισε Β

C<- C + 1

Μέχρις_ότου C > (Α – 1)

D <- (2^Α) – 1

Ε<-Β ΜΟD D

Εμφάνισε D

Αν Ε = 0 τότε

F <- (2^(C – 1)) * D

      Εμφάνισε «Τέλειος αριθμός:», F

G<- 0

      Όσο F > 0 επανάλαβε

              Ρ <- Ρ DIV 10

      Τέλος_επανάληψης

       Εμφάνισε G

Τέλος_αν

Τέλος Αριθμοί_ΜΕΡΣΕΝ

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   3

Μονάδες 12

β.   4

Μονάδες 8

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια