Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου που χρησιμοποιεί ένα μονοδιάστατο πίνακα Α[20]. Ο πίνακας περιέχει άρτιους και περιττούς θετικούς ακεραίους, σε τυχαίες θέσεις. Το τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Β[20] στον οποίο υπάρχουν πρώτα οι άρτιοι και μετά ακολουθούν οι περιττοί. Να γράψετε στο τετράδιό σας τον αλγόριθμο συμπληρώνοντας τα κενά:

Κ <- 0
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 = 0 τότε
Κ    <-    ………….
Β[………… ] <- A[i]
Τέλος_αν
Τέλος_επανάληψης
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 =…………….. τότε
………………..
Β[………… ] <- A[………….. ]
Τέλος_αν
Τέλος_επανάληψης

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Share This