Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια

Share This