Επιλογή Σελίδας

Να γραφεί ένα πρόγραμμα το οποίο να δέχεται έναν ακέραιο αριθμό d και μία βάση μετατροπής b, όπου 2 ≤ b ≤ 16 και να μετατρέπει τον αριθμό d σε σύστημα αρίθμησης με βάση b.

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ μετατροπή_βάσης
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: αριθμός, βάση, i, ψηφία, Α[50]
ΑΡΧΗ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ'
    ΔΙΑΒΑΣΕ αριθμός
ΜΕΧΡΙΣ_ΟΤΟΥ αριθμός > 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΣΗ ΜΕΤΑΤΡΟΠΗΣ (2-16)'
    ΔΙΑΒΑΣΕ βάση
ΜΕΧΡΙΣ_ΟΤΟΥ βάση >= 2 ΚΑΙ βάση <= 16
ψηφία <-- 0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ψηφία <-- ψηφία + 1
    Α[ψηφία]<-- αριθμός MOD βάση
    αριθμός <-- αριθμός DIV βάση
ΜΕΧΡΙΣ_ΟΤΟΥ (αριθμός = 0)
ΓΙΑ i ΑΠΟ ψηφία ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΑΝ Α[i]<10 ΤΟΤΕ
       ΓΡΑΨΕ Α[i]
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 10 ΤΟΤΕ
      ΓΡΑΨΕ 'Α'
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 11 ΤΟΤΕ
      ΓΡΑΨΕ 'B'
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 12 ΤΟΤΕ
      ΓΡΑΨΕ 'C'
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 13 ΤΟΤΕ
      ΓΡΑΨΕ 'D'
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 14 ΤΟΤΕ
      ΓΡΑΨΕ 'E'
    ΑΛΛΙΩΣ_ΑΝ Α[i] = 15 ΤΟΤΕ
      ΓΡΑΨΕ 'F'
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This