Παράρτημα Α – 2.5 Επιλογή – Άσκηση 5

Σε ένα σχολείο η φοίτηση ενός μαθητή χαρακτηρίζεται ως επαρκής, εάν το σύνολο όλων των απουσιών του δεν ξεπερνά τις 100, εκ των οποίων οι 60 είναι δικαιολογημένες ή το σύνολο
των απουσιών του δεν ξεπερνά τις 160 και οι 120 είναι δικαιολογημένες και ο Μέσος όρος βαθμολογίας του μαθητή μεγαλύτερος του 15. Διαφορετικά η φοίτηση χαρακτηρίζεται ως ανεπαρκής.
Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
1) Να διαβάζει από το πληκτρολόγιο τον Μέσο Όρο του μαθητή, το σύνολο των Δικαιολογημένων και το σύνολο των Αδικαιολόγητων απουσιών του.
2) Να εμφανίζει το μήνυμα ’Φοίτηση επαρκής’ ή ’Φοίτηση ανεπαρκής’, ανάλογα με τις απουσίες του.

ΛΥΣΗ (περισσότερα…)

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 8

Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ»,
το οποίο να δέχεται από το πληκτρολόγιο έναν ακέραιο αριθμό και να ελέγχει
εάν είναι διψήφιος και θετικός. Στην περίπτωση που ισχύει, να τυπώνεται
το μήνυμα «Θετικός, Διψήφιος αριθμός»,
ενώ διαφορετικά να τυπώνονται για κάθε περίπτωση
«Μόνο θετικός» ή «Μόνο διψήφιος» ή «Ούτε θετικός, !ούτε διψήφιος»

Λύση με flags | Λύση με σύνθετες λογικές συνθήκες | λύση με πολλαπλές επιλογές

ΛΙΓΕΣ ΣΚΕΨΕΙΣ
! 53 div 10 = 5, έχει δεκάδες
! 153 div 100 = 1, έχει εκατοντάδες συνεπώς είναι τριψήφιος
! ή διαφορετικά
! 153 div 10 = 15, > 9
! 03 div 10 = 0, δεν έχει δεκάδες
! 53 div 100 = 0, δεν είναι τριψήφιος
! αν υπάρχουν δεκάδες,
! δεν πρέπει να υπάρχουν εκατοντάδες
! > 0 αν είναι θετικός
! (0 μπορεί να πάει είτε στους θετικούς είτε στους αρνητικούς)

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v1
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΛΟΓΙΚΕΣ: θετικός, διψήφιος
ΑΡΧΗ
διψήφιος <– ΨΕΥΔΗΣ
θετικός <– ΨΕΥΔΗΣ
ΔΙΑΒΑΣΕ a
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
Αν a div 10 <> 0 και a div 100 = 0 τότε
διψήφιος <– ΑΛΗΘΗΣ
τέλος_αν

! α > 0 είναι θετικός
αν a > 0 τότε
θετικός <– ΑΛΗΘΗΣ
τέλος_αν

αν διψήφιος = ΑΛΗΘΗΣ και θετικός = ΑΛΗΘΗΣ τότε
Γράψε ‘διψήφιος και θετικός’
τέλος_αν

αν διψήφιος = ΑΛΗΘΗΣ και θετικός = ΨΕΥΔΗΣ τότε
Γράψε ‘διψήφιος’
Τέλος_αν

αν διψήφιος = ΨΕΥΔΗΣ και θετικός = ΑΛΗΘΗΣ τότε
Γράψε ‘θετικός’
Τέλος_αν

αν διψήφιος = ΨΕΥΔΗΣ και θετικός = ΨΕΥΔΗΣ τότε
Γράψε ‘Ούτε Διψήφιος, ούτε θετικός’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v2
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΑΡΧΗ
ΔΙΑΒΑΣΕ a

! αν a div 10 <> 0 τότε τουλάχιστον διψήφιος
! αν a div 100 = 0 τότε δεν είναι τριψήφιος
! αν a > 0 τότε είναι θετικός

! 1η περίπτωση (διψήφιος και θετικός)
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
! και
! α > 0 είναι θετικός
Αν a div 10 <> 0 και a div 100 = 0 και a > 0 τότε
Γράψε ‘διψήφιος και θετικός’

! 2η περίπτωση (μόνο διψήφιος – αρνητικός ή 0)
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
! και
! α < 0 είναι αρνητικός
Αλλιώς_αν a div 10 <> 0 και a div 100 = 0 και a < 0 τότε
Γράψε ‘διψήφιος’

! 3η περίπτωση (δεν είναι διψήφιος, μόνο θετικός)
! a div 10 = 0 είναι μονοψήφιος
! ή
! a div 100 <> 0 είναι τουλάχιστον τριψήφιος
! και
! α > 0 είναι θετικός
Αλλιώςαν a div 10 = 0 ή a div 100 <> 0 και a > 0 τότε
Γράψε ‘θετικός’
Αλλιώς
αν a div 10 = 0 ή a div 100 <> 0 και a <= 0 τότε
Γράψε ‘Ούτε Διψήφιος, Ούτε Θετικός’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v3
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΑΡΧΗ
ΔΙΑΒΑΣΕ a

! 1η περίπτωση (διψήφιος και θετικός)
Αν a >=10 και a <=99 τότε Γράψε ‘διψήφιος και θετικός’ Αλλιώςαν a> 0 τότε
Γράψε ‘μόνο θετικός, όχι διψήφιος’
Αλλιώς
αν a <= -10 και a >= -99 τότε
Γράψε ‘διψήφιος’
Αλλιώς
Γράψε ‘ούτε θετικός ούτε διψήφιος’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 7

Με το σύστημα πληρωμής των διοδίων, οι οδηγοί των τροχοφόρων έχουν τη δυνατότητα να πληρώνουν το αντίτιμο των διοδίων με ειδική μαγνητική κάρτα. Υποθέστε ότι υπάρχει μηχάνημα το οποίο διαθέτει είσοδο για την κάρτα και φωτοκύτταρο. Το μηχάνημα διαβάζει από την κάρτα το υπόλοιπο των χρημάτων και το αποθηκεύει σε μια μεταβλητή Υ και με το φωτοκύτταρο αναγνωρίζει τον τύπο του τροχοφόρου και το αποθηκεύει σε μια μεταβλητή Τ. Υπάρχουν τρεις τύποι τροχοφόρων: δίκυκλα (Δ), επιβατικά (Ε) και φορτηγά (Φ), με αντίτιμο διοδίων 1.20€, 2.40€ και 3.50€ αντίστοιχα.
Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
1) Να ελέγχει τον τύπο του τροχοφόρου και να εκχωρεί στη μεταβλητή Α το αντίτιμο των διοδίων, ανάλογα με τον τύπο του τροχοφόρου.
2) Να ελέγχει την πληρωμή των διοδίων με τον παρακάτω τρόπο:
Ι) Αν το υπόλοιπο της κάρτας επαρκεί για την πληρωμή του αντιτίμου των διοδίων, αφαιρεί το ποσό αυτό από την κάρτα.
ΙΙ) Αν η κάρτα δεν έχει υπόλοιπο, το μηχάνημα ειδοποιεί με μήνυμα για το ποσό που πρέπει να πληρωθεί.
ΙΙΙ) Αν το υπόλοιπο δεν επαρκεί, μηδενίζεται η κάρτα και δίνεται με μήνυμα το ποσό που απομένει να πληρωθεί.

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_7
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:Υ,Α
ΧΑΡΑΚΤΗΡΕΣ: Τ

ΑΡΧΗ
ΔΙΑΒΑΣΕ Υ,Τ
ΑΝ Τ = ‘Δ’ ΤΟΤΕ
Α <– 1.2
ΑΛΛΙΩΣΑΝ Τ = ‘Ε’ ΤΟΤΕ
Α <– 2.4
ΑΛΛΙΩΣ
Α <– 3.5
ΤΕΛΟΣ
ΑΝ

ΑΝ Υ >= Α ΤΟΤΕ ! ΜΠΟΡΕΙΣ ΝΑ ΤΟ ΠΛΗΡΩΣΕΙΣ
Υ <– Υ – Α
ΑΛΛΙΩΣΑΝ Υ = 0 ΤΟΤΕ
ΓΡΑΨΕ ‘ΠΡΕΠΕΙ ΝΑ ΠΛΗΡΩΘΕΙ’, Α
ΑΛΛΙΩΣ
Α <– Α – Υ ! ΥΠΟΛΟΓΙΖΕΙΣ ΤΙ ΑΠΟΜΕΝΕΙ ΝΑ ΠΛΗΡΩΘΕΙ
! ΑΦΟΥ ΚΡΑΤΗΣΕΙΣ ΤΟ ΥΠΟΛΟΙΠΟ ΤΗΣ ΚΑΡΤΑΣ
Υ <– 0 ! ΜΗΔΕΝΙΖΕΙΣ ΤΗΝ ΚΑΡΤΑ
ΓΡΑΨΕ ‘ΠΡΕΠΕΙ ΝΑ ΠΛΗΡΩΘΕΙ’, Α
ΤΕΛΟΣ
ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 6

!6. Το Υπουργείο Οικονομικών φορολογεί τους Ελεύθερους Επαγγελματίες
! σύμφωνα με τον παρακάτω πίνακα:
! 1. Από 1€ μέχρι 20.000€ – 22%
! 2. Από 20.001€ μέχρι 30.000€ – 29% (για τα επόμενα 10000€)
! 3. Από 30.001€ μέχρι 40.000€ – 37% (για τα επόμενα 10000€)
! 4. Από 40.001€ και άνω _ 45% (για όλα τα επόμενα €)

!Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ»,
!το οποίο να διαβάζει το εισόδημα ενός ελεύθερου επαγγελματία
!και στη συνέχεια να υπολογίζει και να εμφανίζει τον φόρο που του αναλογεί.
!Ο υπολογισμός φόρου γίνεται κλιμακωτά, σύμφωνα με τον παραπάνω πίνακα.

(περισσότερα…)

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 4

! Παράρτημα Α – Οδηγίες Μαθητή (β έκδοση) – 2.5 Επιλογή
! 4. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα ενός υπαλλήλου, τις ώρες
! εργασίας και το ωρομίσθιο του.
! Οι κρατήσεις που γίνονται στον υπάλληλο είναι 15%, αν ο μισθός του είναι μέχρι 1.000?,
! διαφορετικά είναι 20%.
! Σε περίπτωση που ο υπάλληλος έχει λιγότερες από 15 ώρες εργασίας τότε
! οι παραπάνω κρατήσεις μειώνονται κατά 2%.
! Υπόδειξη: Ο μισθός κάθε υπαλλήλου υπολογίζεται από τον τύπο:
! Ώρες x Ωρομίσθιο – Κρατήσεις

!Και οι κρατήσεις από τον τύπο:
!Κρατήσεις=(Ώρες x Ωρομίσθιο) x Ποσοστό/100
(περισσότερα…)

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 3

Παράρτημα Α – Οδηγίες Μαθητή (β έκδοση) – 2.5 Επιλογή
3. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει από το πληκτρολόγιο τρεις διαφορετικούς ακέραιους αριθμούς και στη συνέχεια να τυπώνει τον αριθμό που η αξία του είναι ανάμεσα στον μεγαλύτερο και στον μικρότερο από αυτούς (δηλαδή, αν δοθούν οι αριθμοί 107,53,42 τότε θα εμφανιστεί ο 53, διότι 107>53>42 ή 42<53<107).
(περισσότερα…)