Επιλογή Σελίδας

Να γράψεις τα υποπρογράμματα που υλοποιούν τα παρακάτω:

Α) Να διαβάζει έναν αριθμό και να επιστρέφει το τετράγωνό του.

Β) Να δέχεται δύο αριθμούς και να επιστρέφει το μικρότερο από δύο αριθμούς.

Γ) Να δέχεται την τιμή ενός προϊόντος και να υπολογίζει και να τυπώνει την αξία του ΦΠΑ.

Δ) Να ελέγχει αν ένας αριθμός είναι άρτιος.

ΛΥΣΗ

Α)
ΔΙΑΔΙΚΑΣΙΑ Τετράγωνο(Χ2)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Χ2
ΑΡΧΗ
ΔΙΑΒΑΣΕ Χ
Χ2<--Χ^2
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

Β)
ΔΙΑΔΙΚΑΣΙΑ Μικρότερο(Α,Β,Μικρ)
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Α,Β,Μικρ
ΑΡΧΗ
ΑΝ Α<Β ΤΟΤΕ
   Μικρ<--Β
ΑΛΛΙΩΣ
   Μικρ<--Α
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Γ)
ΔΙΑΔΙΚΑΣΙΑ Υπολογισµός_ΦΠΑ(Τιµή,ΦΠΑ)
ΠΡΑΓΜΑΤΙΚΕΣ:Τιµή, ΦΠΑ
ΑΡΧΗ
ΦΠΑ <-- Τιµή*0.18
ΓΡΑΨΕ ΦΠΑ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δ)
ΣΥΝΑΡΤΗΣΗ Άρτιος(Α):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣΑΡΧΗ
ΑΝ Α mod 2 = 0 TOTE
   Άρτιος <-- ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
   Άρτιος<--ΨΕΥΔΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This