Επιλογή Σελίδας

ΔΤ2, Κεφάλαιο 10, Διάφορα υποπρογράμματα, ύψωση σε δύναμη, άρτιος, ελάχιστος (min), υπολογισμός ΦΠΑ

Να γράψεις τα υποπρογράμματα που υλοποιούν τα παρακάτω:

Α) Να διαβάζει έναν αριθμό και να επιστρέφει το τετράγωνό του.

Β) Να δέχεται δύο αριθμούς και να επιστρέφει το μικρότερο από δύο αριθμούς.

Γ) Να δέχεται την τιμή ενός προϊόντος και να υπολογίζει και να τυπώνει την αξία του ΦΠΑ.

Δ) Να ελέγχει αν ένας αριθμός είναι άρτιος.

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Eρώτημα 2, 2015, Ημερήσια

α. Να αναφέρετε ονομαστικά τις κατηγορίες στις οποίες διακρίνονται τα προβλήματα με κριτήριο το είδος της επίλυσης που επιζητούν. (μονάδες 3)

β. Έστω τα παρακάτω επιλύσιμα προβλήματα:

  1. Δίδεται ένας ακέραιος αριθμός Ν και ζητείται ποια είναι η παραγοντοποίηση του Ν με το μεγαλύτερο πλήθος παραγόντων.
  2. Δίδεται ένας ακέραιος αριθμός Ν και το πρόβλημα που τίθεται είναι αν ο Ν είναι άρτιος.
  3. Δίδεται ένας ακέραιος αριθμός Ν και ζητείται να βρεθεί πόσες διαφορετικές παραγοντοποιήσεις του Ν υπάρχουν.

Για καθένα από τα προβλήματα αυτά, να γράψετε στο τετράδιό σας τον αριθμό του (1, 2 ή 3) και δίπλα την κατηγορία στην οποία ανήκει με κριτήριο το είδος της επίλυσης που επιζητεί. (μονάδες 3)

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ (Βλ. παράγραφο 1.5)

Α.2.α 

  • Υπολογιστικά
  • Απόφασης
  • Βελτιστοποίησης

Α.2.β

  1. Βελτιστοποίησης
  2. Απόφασης
  3. Υπολογιστικό

Θέμα Γ, 2014, Επαναληπτικές, Ημερήσια

Δίνεται η εξίσωση Α·x + B·y + Γ·z = Δ. Να αναπτύξετε αλγόριθμο, ο οποίος, θεωρώντας δεδομένες τις τιμές των Α, Β, Γ και Δ:

Γ 1. Να εμφανίζει όλες τις λύσεις (τριάδες) της εξίσωσης, εξετάζοντας όλους τους δυνατούς συνδυασμούς ακεραίων τιμών των x, y, z, που είναι μεγαλύτερες από 100 και μικρότερες από 100. Αν δεν υπάρχουν τέτοιες λύσεις, να εμφανίζει κατάλληλο μήνυμα.

Μονάδες 8

Εφόσον υπάρχουν τέτοιες λύσεις:

Γ2. Να εμφανίζει την πρώτη λύση (τριάδα) για την οποία το άθροισμα των x, y, z έχει τη μεγαλύτερη τιμή.

Μονάδες 4

Γ3. Να εμφανίζει το πλήθος των λύσεων της εξίσωσης για τις οποίες τα x, y, z είναι θετικοί άρτιοι αριθμοί.

Μονάδες 4

Γ4. Να εμφανίζει το ποσοστό των λύσεων της εξίσωσης για τις οποίες ένα μόνο από τα x, y, z είναι ίσο με μηδέν.

Μονάδες 4

ΛΥΣΗ  (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Θέμα A, Ερώτημα 5, 2012, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου που χρησιμοποιεί ένα μονοδιάστατο πίνακα Α[20]. Ο πίνακας περιέχει άρτιους και περιττούς θετικούς ακεραίους, σε τυχαίες θέσεις. Το τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Β[20] στον οποίο υπάρχουν πρώτα οι άρτιοι και μετά ακολουθούν οι περιττοί. Να γράψετε στο τετράδιό σας τον αλγόριθμο συμπληρώνοντας τα κενά:

Κ <- 0
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 = 0 τότε
Κ    <-    ………….
Β[………… ] <- A[i]
Τέλος_αν
Τέλος_επανάληψης
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 =…………….. τότε
………………..
Β[………… ] <- A[………….. ]
Τέλος_αν
Τέλος_επανάληψης

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Ερώτημα 4, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Για Χ από Α μέχρι Μ με_βήμα Β
Εμφάνισε Χ
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας για καθεμία από τις παρακάτω περιπτώσεις τις τιμές των Α, Μ, Β, έτσι ώστε το αντίστοιχο τμήμα αλγορίθμου να εμφανίζει όλους:
1. τους ακεραίους από 1 μέχρι και 100
2. τους ακεραίους από 10 μέχρι και 200 σε φθίνουσα σειρά
3. τους ακεραίους από -1 μέχρι και -200 σε αύξουσα σειρά
4. τους άρτιους ακεραίους από 100 μέχρι και 200
5. τους θετικούς ακεραίους που είναι μικρότεροι του 8128 και πολλαπλάσια του 13.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια