Επιλογή Σελίδας

Δίνεται η εξίσωση Α·x + B·y + Γ·z = Δ. Να αναπτύξετε αλγόριθμο, ο οποίος, θεωρώντας δεδομένες τις τιμές των Α, Β, Γ και Δ:

Γ 1. Να εμφανίζει όλες τις λύσεις (τριάδες) της εξίσωσης, εξετάζοντας όλους τους δυνατούς συνδυασμούς ακεραίων τιμών των x, y, z, που είναι μεγαλύτερες από 100 και μικρότερες από 100. Αν δεν υπάρχουν τέτοιες λύσεις, να εμφανίζει κατάλληλο μήνυμα.

Μονάδες 8

Εφόσον υπάρχουν τέτοιες λύσεις:

Γ2. Να εμφανίζει την πρώτη λύση (τριάδα) για την οποία το άθροισμα των x, y, z έχει τη μεγαλύτερη τιμή.

Μονάδες 4

Γ3. Να εμφανίζει το πλήθος των λύσεων της εξίσωσης για τις οποίες τα x, y, z είναι θετικοί άρτιοι αριθμοί.

Μονάδες 4

Γ4. Να εμφανίζει το ποσοστό των λύσεων της εξίσωσης για τις οποίες ένα μόνο από τα x, y, z είναι ίσο με μηδέν.

Μονάδες 4

ΛΥΣΗ 


! Για εκτέλεση στην Γλωσσομάθεια προσαρμόστε τα πεδία τιμών 
! των x,y,z σε [-5,5], [-10,10], [-20,20] 

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2014_ΕΠΑΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: πλήθος_λύσεων, πλήθος1, πλήθος2, Μέγιστο, Μεγ_x, Μεγ_y, Μεγ_z, Α, Β, Γ, Δ, x, y, z, d
 ΠΡΑΓΜΑΤΙΚΕΣ: ποσοστό
ΑΡΧΗ
! Έστω οι παρακάτω τιμές για Α,Β, Γ, Δ
 Α <-- 2
 Β <-- 1
 Γ <-- -1
 Δ <-- 0
 Μέγιστο <-- -10000
 πλήθος_λύσεων <-- 0
 πλήθος1 <-- 0
 πλήθος2 <-- 0

 ΓΙΑ x ΑΠΟ -99 ΜΕΧΡΙ 99
     ΓΙΑ y ΑΠΟ -99 ΜΕΧΡΙ 99
         ΓΙΑ z ΑΠΟ -99 ΜΕΧΡΙ 99
            ΑΝ Α * x + Β * y + Γ * z = Δ ΤΟΤΕ

               ! Γ1
               πλήθος_λύσεων <-- πλήθος_λύσεων + 1
               ΓΡΑΨΕ '(x,y,z) ', x, y, z

              ! Γ2
               ΑΝ x+y+z > Μέγιστο ΤΟΤΕ
                  Μέγιστο <-- x + y + z
                  Μεγ_x <-- x
                  Μεγ_y <-- y
                  Μεγ_z <-- z
               ΤΕΛΟΣ_ΑΝ
  
              ! Γ3
              ΑΝ (x>0) και (y>0) και (z>0) και (x mod 2 = 0) και (y mod 2 = 0) και (z mod 2 = 0) ΤΟΤΕ
                 πλήθος1 <-- πλήθος1 + 1 
              ΤΕΛΟΣ_ΑΝ 
              ! Γ4
              ΑΝ ( (x=0) και (y*z<>0) ) ή ( (y=0) και (x*z<>0) ) ή ( (z=0) και (x*z<>0) ) ΤΟΤΕ 
                 πλήθος2 <-- πλήθος2 + 1 
              ΤΕΛΟΣ_ΑΝ 
            ΤΕΛΟΣ_ΑΝ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
 Ποσοστό<--πλήθος2/πλήθος_λύσεων * 100
 ΓΡΑΨΕ 'ΜΕΓΙΣΤΟ ΑΘΡΟΙΣΜΑ x,y,z ', Μεγ_x, Μεγ_y, Μεγ_z
 ΓΡΑΨΕ 'ΠΛΗΘΟΣ ΣΥΝΔΥΑΣΜΩΝ ΘΕΤΙΚΩΝ ΑΡΤΙΩΝ x,y,z ', Πλήθος2
 ΓΡΑΨΕ 'ΠΟΣΟΣΤΟ', Ποσοστό
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This