Επιλογή Σελίδας

Θέμα A, Ερώτημα 3, 2017, Ημερήσια

i <– 0
k <–  12
Όσο i<=k επανάλαβε
         i <– i+2
         k <– k-1
         Γράψε i,k
Τέλος_επανάληψης
Να μεταφέρετε στο τετράδιό σας τον παρακάτω πίνακα και να συμπληρώσετε τις τιμές των μεταβλητών που θα εμφανίζει το παραπάνω απόσπασμα αλγορίθμου σε κάθε επανάληψη:

Οθόνη (εμφάνιση των i και k)

Επανάληψη 1
Επανάληψη 2

Μονάδες 10

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου.
01 ΔΙΑΒΑΣΕ X
02 ΠΛ<– 0
03 ΑΡ <– 1
04 ΔΕ <– 12
05 Β <– ΨΕΥΔΗΣ
ΟΣΟ Β = ΨΕΥΔΗΣ ΚΑΙ ΑΡ <= ΔΕ ΕΠΑΝΑΛΑΒΕ
06 Μ <– (ΑΡ + ΔΕ) DIV 2
AN A[M] = X TOTE
07 B <– ΑΛΗΘΗΣ
ΑΛΛΙΩΣ_ΑΝ Α[Μ] < Χ ΤΟΤΕ
08 ΑΡ <– Μ + 1
ΑΛΛΙΩΣ
09 ΔΕ <– Μ – 1
ΤΕΛΟΣ  ΑΝ
10 ΠΛ <– ΠΛ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Β = ΑΛΗΘΗΣ ΤΟΤΕ
11 ΕΜΦΑΝΙΣΕ Μ
ΑΛΛΙΩΣ
12 ΕΜΦΑΝΙΣΕ “ΔΕΝ ΒΡΕΘΗΚΕ”, ΠΛ
ΤΕΛΟΣ_ΑΝ

Για την παρακολούθηση της εκτέλεσης του τμήματος αλγορίθμου με τιμή εισόδου Χ = 35 και με δεδομένο τον πίνακα

1 2 3 4 5 6 7 8 9 10 11 12
Α 3 10 18 20 26 32 35 48 55 60 75 90
δίνεται το παρακάτω υπόδειγμα πίνακα τιμών,συμπληρωμένο ως εξής:
  • Στη στήλη με τίτλο «Αρ. Γρ.» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «Έξοδος» καταγράφεται η τιμή εξόδουεφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Οι  υπόλοιπες στήλες του πίνακα τμήματος του αλγορίθμου αντιστοιχούν στις μεταβλητές του τμήματος του αλγορίθμου.
Αρ.Γρ. Χ ΠΛ ΑΡ ΔΕ Β Μ Έξοδος
01 35
02 0
03 1
04 12
05 ΨΕΥΔΗΣ
……

Να μεταφέρετε τον πίνακα τιμών στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του τμήματος αλγορίθμου ως εξής: για κάθε αριθμημένη εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, 2003, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος :

Αλγόριθμος Αριθμοί

Διάβασε Α

Εκτύπωσε Α

S<-1

Αρχή_επανάληψης

Αν Α MOD K = 0 τότε

Β <- Α DIV K

Αν Κ <> Β τότε

   S<- S + K + B

Εκτύπωσε Κ, Β

αλλιώς

S<- S + K

       Εκτύπωσε K

Τέλος_αν

 Τέλος_αν

Κ<- Κ + 1

Μέχρις_ότου Κ > Ρίζα (Α)

Αν Α = S τότε

     Εκτύπωσε S

Τέλος_αν

Τέλος Αριθμοί

Η συνάρτηση Ρίζα (Α) επιστρέφει την τετραγωνική ρίζα του Α.

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   36

β.   28

Μονάδες 20

Παρατήρηση που αφορά στα ΘΕΜΑΤΑ 3ο και 4ο

Οι εντολές σε έναν αλγόριθμο μπορούν να γραφούν με μικρά ή κεφαλαία γράμματα.

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές

Θέμα Β, 2003, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Ν, Μ και Β, όπως αυτές τυπώνονται σε κάθε επανάληψη, και την τιμή της μεταβλητής Χ που τυπώνεται μετά το τέλος της επανάληψης, κατά την εκτέλεση του παρακάτω αλγόριθμου.

Αλγόριθμος Αριθμοί

Α <- 1

Β <- 1

Ν <- 0

Μ <- 2

Όσο Β < 6 επανάλαβε

        Χ <- Α + Β

       Αν Χ MOD 2 = 0 τότε

                 Ν <- Ν + 1

      αλλιώς

                Μ <- Μ + 1

     Τέλος_αν

     Α <- Β

     Β <- Χ

     Εμφάνισε Ν, Μ, Β

Τέλος_επανάληψης

Εμφάνισε Χ

Τέλος Αριθμοί

 

Μονάδες 20

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2002, Ημερήσια, Μαΐου-Ιουνίου

Να εκτελέσετε το παρακάτω τμήμα αλγορίθμου, για Κ = 24 και L = 40. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Υ καθώς αυτές τυπώνονται με την εντολή Εμφάνισε Χ, Υ (τόσο μέσα στη δομή επανάληψης όσο και στο τέλος του αλγορίθμου).

Χ <-  Κ

Y  <- L

Αν Χ < Υ τότε

ΤΕΜΡ <- Χ

Χ  <- Υ

Υ  <-   ΤΕΜΡ

Τέλος_αν

Όσο Υ<>0 επανάλαβε

ΤΕΜΡ <-  Υ

Υ  <- Χ ΜOD Y

Χ  <-   TEMP

Εμφάνισε Χ, Υ

Τέλος_επανάληψης

Υ  <-    (Κ * L) DIV X

Εμφάνισε Χ, Υ

Μονάδες 20

 

Τα θέματα σε pdf, 2002, Ιουνίου, Ημερήσια

Θέμα Β, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνεται το παρακάτω τμήμα αλγορίθμου.
 
 Χ <-- 1
 Όσο Χ<5 επανάλαβε
 Α <-- Χ+2
 Β <-- 3*Α-4
 C <-- Β-Α+4
 Αν Α > Β τότε
    Αν Α > C τότε 
       MAX <-- A
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 αλλιώς
    Αν Β > C τότε 
       MAX <-- Β
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 Τέλος_αν
 Εμφάνισε Χ, Α, Β, C, MAX
 Χ <-- Χ+2
 Τέλος_επανάληψης

 Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου;

Μονάδες 20

Σημείωση: Αντί του συμβόλου (<-) μπορεί ισοδύναμα να χρησιμοποιηθεί το σύμβολο (: =) ή το (=). Επίσης αντί του Όσο … επανάλαβε … Τέλος επανάληψης μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε … τέλοςόσο και αντί του Τέλος_αν μπορεί ισοδύναμα να χρησιμοποιηθεί το τέλοςαν.

ΛΥΣΗ: (περισσότερα…)