Επιλογή Σελίδας

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Ν, Μ και Β, όπως αυτές τυπώνονται σε κάθε επανάληψη, και την τιμή της μεταβλητής Χ που τυπώνεται μετά το τέλος της επανάληψης, κατά την εκτέλεση του παρακάτω αλγόριθμου.

Αλγόριθμος Αριθμοί

Α <- 1

Β <- 1

Ν <- 0

Μ <- 2

Όσο Β < 6 επανάλαβε

        Χ <- Α + Β

       Αν Χ MOD 2 = 0 τότε

                 Ν <- Ν + 1

      αλλιώς

                Μ <- Μ + 1

     Τέλος_αν

     Α <- Β

     Β <- Χ

     Εμφάνισε Ν, Μ, Β

Τέλος_επανάληψης

Εμφάνισε Χ

Τέλος Αριθμοί

 

Μονάδες 20

Τα θέματα σε pdf, 2003, Μαΐου-Ιουνίου, Ημερήσια

Share This