Επιλογή Σελίδας

Θέμα Α, Ερώτημα 1, 2015, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5  και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη  λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η πράξη της σύζευξης δύο λογικών εκφράσεων δίνει ως αποτέλεσμα την τιμή ΨΕΥΔΗΣ, μόνον όταν και οι δύο εκφράσεις έχουν την  τιμή  ΨΕΥΔΗΣ.
  2. Συνηθέστατα παρατηρείται το φαινόμενο μια δομή δεδομένων να είναι αποδοτικότερη από μια άλλη δομή, με κριτήριο κάποια λειτουργία.
  3. Ο ιεραρχικός προγραμματισμός χρησιμοποιεί τη στρατηγική της συνεχούς διαίρεσης  του  προβλήματος  σε  υποπροβλήματα.
  4. Οι εντολές που βρίσκονται μέσα στο βρόχο μιας εντολής ΓΙΑ εκτελούνται τουλάχιστον  μία  φορά.
  5. Σε μία εντολή εκχώρησης δεν μπορεί να υπάρχει αναφορά σε περισσότερες από  μία  συναρτήσεις.

Μονάδες  10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

  1. Λάθος 2. Σωστό 3. Σωστό 4. Λάθος 5. Λάθος

 

Θέμα Α, Ερώτημα 5, 2013, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α και δίπλα το γράμμα της στήλης Β που αντιστοιχεί σωστά.

Στήλη Α Στήλη Β
1 χαρακτήρες α Λογική τιμή
2 ελεύθερο κείμενο β Ουρά
3 ώθηση γ Κριτήριο αλγορίθμου
4 αληθής δ Επανάληψη
5 FIFO ε Τύπος μεταβλητής
6 Αποτελεσματικότητα στ Στοίβα
7 βρόχος ζ Τρόπος αναπαράστασης αλγορίθμου

Μονάδες 7

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 4, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση
Δεδομένα //Π,Ν,Χ//
flag <- ψευδής
Ι <- 1
Όσο   Ι ≤ Ν  και   flag=ψευδής  επανάλαβε
          Αν Π[Ι]=Χ  τότε
flag <- αληθής
         Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //flag//
Τέλος Αναζήτηση

  1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών; (Μονάδες 2)

Να αιτιολογήσετε την απάντησή σας. (Μονάδες 3)

Μονάδες 5

  1. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα A, 2008, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις, 1-5, και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Τα προβλήματα, με κριτήριο το είδος της επίλυσης που επιζητούν, διακρίνονται σε τρεις κατηγορίες: επιλύσιμα, ανοικτά και άλυτα.
  2. Μια υπολογιστική διαδικασία που δεν τελειώνει μετά από συγκεκριμένο αριθμό βημάτων αποτελεί αλγόριθμο.
  3. Η εγγραφή είναι δομή δεδομένων η οποία αποτελείται από πεδία που αποθηκεύουν χαρακτηριστικά.
  4. Η αντικειμενοστραφής σχεδίαση εκλαμβάνει τις «ενέργειες» ως πρωτεύοντα δομικά στοιχεία ενός προγράμματος.
  5. Σε μία συνάρτηση δεν επιτρέπεται η χρήση της εντολής ΔΙΑΒΑΣΕ.

Μονάδες 10

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα Α, 2005, Μαΐου-Ιουνίου, Ημερήσια

  1. Να αναφέρετε ονομαστικά τα κριτήρια που πρέπει απαραίτητα να ικανοποιεί ένας αλγόριθμος.

Μονάδες 5

  1. Ποιο κριτήριο δεν ικανοποιεί ο παρακάτω αλγόριθμος και γιατί;

Για Ι από 2 μέχρι 10 με_βήμα 0

S<-S+I

Τέλος_επανάληψης

Εμφάνισε S

Μονάδες 5