Επιλογή Σελίδας

Να γράψεις τις εντολές για τα παρακάτω:
Α) Αν η Βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από το Μέσο όρο (ΜΟ), τότε να τυπώνει “Πολύ καλά”, αν είναι ίση ή μικρότερη του Μέσου όρου μέχρι και 2 μονάδες, να τυπώνει “Καλά”, και, όταν είναι μικρότερη του Μέσου όρου περισσότερο από 2 μονάδες, να τυπώνει “Μέτρια”.
Β) Αν το τμήμα (ΤΜΗΜΑ) είναι Γ1 και η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από 15, τότε να τυπώνει το επώνυμο (ΕΠΩΝΥΜΟ).
Γ) Αν η απάντηση (ΑΠΑΝΤΗΣΗ) δεν είναι Ν ή ν ή Ο ή ο, τότε να τυπώνει το μήνυμα “Λάθος απάντηση… ” .
Δ) Αν ο αριθμός Χ είναι αρνητικός ή το ΗΜ(Χ)=0, τότε να τυπώνεται το μήνυμα “Λάθος δεδομένα… ” , αλλιώς να υπολογίζεται η παράσταση (Χ^2+5Χ)/(Τ_Ρ(Χ)ΗΜ(Χ)).

ΛΥΣΗ

Α. 
ΑΝ Βαθµός>ΜΟ ΤΟΤΕ 
   ΓΡΑΨΕ 'Πολύ καλά' 
ΑΛΛΙΩΣ_ΑΝ Βαθµός>=(ΜΟ-2) ΤΟΤΕ 
      ΓΡΑΨΕ 'Καλά' 
ΑΛΛΙΩΣ 
      ΓΡΑΨΕ 'Μέτρια' 
ΤΕΛΟΣ_ΑΝ 
 
Β. 
ΑΝ (Τµήµα ='Γ1' ΚΑΙ Βαθµός >15) ΤΟΤΕ 
    ΓΡΑΨΕ Επώνυµο 
ΤΕΛΟΣ_ΑΝ 
 
Γ. 
ΑΝ Απάντηση <>'ν' ΚΑΙ Απάντηση <>'Ν' ΚΑΙ Απάντηση <>'ο' ΚΑΙ Απάντηση <>'Ο' ΤΟΤΕ 
   ΓΡΑΨΕ 'Λάθος απάντηση' 
ΤΕΛΟΣ_ΑΝ
 
∆. 
ΑΝ Χ <= 0 Ή ΗΜ(Χ)=0 ΤΟΤΕ 
   ΓΡΑΨΕ 'Λάθος δεδοµένα' 
ΑΛΛΙΩΣ 
 Υ←(Χ^2+5*Χ)/(Τ_Ρ(Χ)* ΗΜ(Χ)) 
ΤΕΛΟΣ_ΑΝ 
Share This