Επιλογή Σελίδας

Θέμα Γ, 2015, Ημερήσια, Μαΐου-Ιουνίου

Μία εταιρεία μεταφοράς δεμάτων διαθέτει δύο αποθήκες, Α και Β, στο αεροδρόμιο. Κατά την παραλαβή δεμάτων, κάθε δέμα τοποθετείται στην αποθήκη που έχει εκείνη τη στιγμή τον περισσότερο ελεύθερο χώρο. Αν ο ελεύθερος χώρος της αποθήκης Α είναι ίσος με τον ελεύθερο χώρο της αποθήκης Β, το δέμα τοποθετείται στην αποθήκη Α. Όταν όμως το δέμα δεν χωρά σε καμία από τις δύο αποθήκες, προωθείται στις κεντρικές εγκαταστάσεις της εταιρείας, που βρίσκονται εκτός αεροδρομίου.

Γ1. Να κατασκευάσετε πρόγραμμα που:

α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 2)

β. Να διαβάζει τα μεγέθη ελεύθερου χώρου των αποθηκών Α και Β. (μονάδες 2)

γ. Να διαβάζει το μέγεθος κάθε εισερχόμενου δέματος και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία θα τοποθετηθεί αυτό ή να εμφανίζει το μήνυμα «Προώθηση», όταν το δέμα δεν χωρά σε καμία από τις αποθήκες Α ή Β. Η διαδικασία παραλαβής τερματίζεται, όταν εισαχθεί ως μέγεθος δέματος η τιμή 0. (μονάδες 6)

δ. Στη συνέχεια, να καλεί υποπρόγραμμα, το οποίο να βρίσκει και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία τοποθετήθηκαν τα περισσότερα δέματα, ή το μήνυμα «Ισάριθμα» σε περίπτωση που στις δύο αποθήκες Α και Β τοποθετήθηκαν ισάριθμα δέματα, ή το μήνυμα «Καμία αποθήκευση στο αεροδρόμιο», αν κανένα δέμα δεν τοποθετήθηκε σε οποιαδήποτε από τις αποθήκες Α ή Β. (μονάδες 2)

Μονάδες 12

Γ2. Να κατασκευάσετε το υποπρόγραμμα που περιγράφεται στο ερώτημα Γ1.δ.

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ (περισσότερα…)

Ερώτημα 3, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Να ξαναγράψετε στο τετράδιό σας καθένα από τα παρακάτω τμήματα αλγορίθμου, χρησιμοποιώντας μόνο μία δομή επανάληψης Για … Από …. Μέχρι και χωρίς τη χρήση δομής επιλογής.

(α)
i <- 1
j <- 1
Αρχή_επανάληψης
Εμφάνισε Α[i,j]
i <- i + 1
j <- j + 1
Μέχρις_ότου j > 100
(μονάδες 4)
(β)
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i = 50 τότε
Εμφάνισε Α[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης
(μονάδες 4)

Μονάδες 8

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΔΣ6, Κεφάλαιο 2, Τετράδιο Εργασιών

Πηγαίνεις σε ένα πολυκατάστημα και παρατηρείς τις παρακάτω τιμές για 4 διαφορετικά είδη γάλακτος.

Είδος Τιμή Ποσότητα
ΓΑΛΑ_Α 0,60€ 300ml
ΓΑΛΑ_Β 0,65€ 400ml
ΓΑΛΑ_Γ 1,20€ 500ml
ΓΑΛΑ_Δ 1,35€ 550ml

Να γράψεις έναν αλγόριθμο που θα υπολογίζει και θα εμφανίζει το είδος γάλακτος που έχει την πλέον συμφέρουσα τιμή.

Λύση:  (περισσότερα…)

Θέμα B, 2004, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Αριθμοί_ΜΕΡΣΕΝ

Διάβασε Α

B<-4

C<-2

Αρχή_επανάληψης

Β<-(Β^2) – 2

      Εμφάνισε Β

C<- C + 1

Μέχρις_ότου C > (Α – 1)

D <- (2^Α) – 1

Ε<-Β ΜΟD D

Εμφάνισε D

Αν Ε = 0 τότε

F <- (2^(C – 1)) * D

      Εμφάνισε «Τέλειος αριθμός:», F

G<- 0

      Όσο F > 0 επανάλαβε

              Ρ <- Ρ DIV 10

      Τέλος_επανάληψης

       Εμφάνισε G

Τέλος_αν

Τέλος Αριθμοί_ΜΕΡΣΕΝ

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   3

Μονάδες 12

β.   4

Μονάδες 8

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια

Θέμα Γ, 2004, Επαναληπτικές, Ημερήσια

Σε κάποια εξεταστική δοκιμασία κάθε γραπτό αξιολογείται αρχικά από δύο βαθμολογητές και υπάρχει περίπτωση το γραπτό να χρειάζεται αναβαθμολόγηση από τρίτο βαθμολογητή. Στην περίπτωση αναβαθμολόγησης ο τελικός βαθμός υπολογίζεται ως εξής:

  1. Αν ο βαθμός του τρίτου βαθμολογητή είναι ίσος με το μέσο όρο (Μ.Ο.) των βαθμών των δύο πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο Μ.Ο.
  2. Αν ο βαθμός του τρίτου βαθμολογητή είναι μικρότερος από το μικρότερο βαθμό (ΜΙΝ) των δύο πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο ΜΙΝ.
  3. Διαφορετικά, ο τελικός βαθμός είναι ο μέσος όρος του βαθμού του τρίτου βαθμολογητή με τον πλησιέστερο προς αυτόν βαθμό των δύο πρώτων βαθμολογητών.

Να αναπτύξετε αλγόριθμο υπολογισμού του τελικού βαθμού ενός γραπτού με αναβαθμολόγηση, ο οποίος:

α. να διαβάζει τους βαθμούς του πρώτου, του δεύτερου και του τρίτου βαθμολογητή ενός γραπτού.

Μονάδες 2

β. να υπολογίζει και να εκτυπώνει το μεγαλύτερο (ΜΑΧ) και το μικρότερο (ΜΙΝ) από τους βαθμούς του πρώτου και του δεύτερου βαθμολογητή.

Μονάδες 6

 

γ. να υπολογίζει και να εκτυπώνει τον τελικό βαθμό του γραπτού  σύμφωνα με την παραπάνω διαδικασία.

Μονάδες 12

Παρατήρηση: Θεωρήστε ότι και οι τρεις βαθμοί είναι θετικοί ακέραιοι αριθμοί και δεν απαιτείται έλεγχος των δεδομένων.

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια