Επιλογή Σελίδας

Πηγαίνεις σε ένα πολυκατάστημα και παρατηρείς τις παρακάτω τιμές για 4 διαφορετικά είδη γάλακτος.

Είδος Τιμή Ποσότητα
ΓΑΛΑ_Α 0,60€ 300ml
ΓΑΛΑ_Β 0,65€ 400ml
ΓΑΛΑ_Γ 1,20€ 500ml
ΓΑΛΑ_Δ 1,35€ 550ml

Να γράψεις έναν αλγόριθμο που θα υπολογίζει και θα εμφανίζει το είδος γάλακτος που έχει την πλέον συμφέρουσα τιμή.

Λύση: 

Για να υπάρξει έλεγχος για την πλέον συµφέρουσα τιµή χρειάζεται να υπολογισθεί η τιµή του κάθε γάλακτος για την ίδια ποσότητα. Επομένως ο αλγόριθμος υπολογίζει την τιµή του κάθε είδους γάλακτος για τα 100ml και μετά υπολογίζει την ελάχιστη από αυτές τις τιμές.
Αλγόριθμος Τιµή_Γάλα
Δεδομένα // ΓΑΛΑ_Α, ΓΑΛΑ_B, ΓΑΛΑ_Γ, ΓΑΛΑ_Δ //
ΓΑΛΑ_Α ← 195/3
ΓΑΛΑ_B ← 205/4
ΓΑΛΑ_Γ ← 400/5
ΓΑΛΑ_Δ ← 450/5.5
ΜΙΝ ← ΓΑΛΑ_Α
i ← 1
Αν ΓΑΛΑ_Β<ΜΙΝ τότε
ΜΙΝ ← ΓΑΛΑ_Β
i ← 2
Τέλος_αν
Αν ΓΑΛΑ_Γ<ΜΙΝ τότε
ΜΙΝ ΓΑΛΑ_Γ
i 3
Τέλος_αν
Αν ΓΑΛΑ_Δ<ΜΙΝ τότε
ΜΙΝ ← ΓΑΛΑ_Δ
i ← 4
Τέλος_αν
Αποτελέσµατα // i, ΜΙΝ //
Τέλος Τιµή_Γάλα

Share This