Επιλογή Σελίδας

Μία εταιρεία μεταφοράς δεμάτων διαθέτει δύο αποθήκες, Α και Β, στο αεροδρόμιο. Κατά την παραλαβή δεμάτων, κάθε δέμα τοποθετείται στην αποθήκη που έχει εκείνη τη στιγμή τον περισσότερο ελεύθερο χώρο. Αν ο ελεύθερος χώρος της αποθήκης Α είναι ίσος με τον ελεύθερο χώρο της αποθήκης Β, το δέμα τοποθετείται στην αποθήκη Α. Όταν όμως το δέμα δεν χωρά σε καμία από τις δύο αποθήκες, προωθείται στις κεντρικές εγκαταστάσεις της εταιρείας, που βρίσκονται εκτός αεροδρομίου.

Γ1. Να κατασκευάσετε πρόγραμμα που:

α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 2)

β. Να διαβάζει τα μεγέθη ελεύθερου χώρου των αποθηκών Α και Β. (μονάδες 2)

γ. Να διαβάζει το μέγεθος κάθε εισερχόμενου δέματος και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία θα τοποθετηθεί αυτό ή να εμφανίζει το μήνυμα «Προώθηση», όταν το δέμα δεν χωρά σε καμία από τις αποθήκες Α ή Β. Η διαδικασία παραλαβής τερματίζεται, όταν εισαχθεί ως μέγεθος δέματος η τιμή 0. (μονάδες 6)

δ. Στη συνέχεια, να καλεί υποπρόγραμμα, το οποίο να βρίσκει και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία τοποθετήθηκαν τα περισσότερα δέματα, ή το μήνυμα «Ισάριθμα» σε περίπτωση που στις δύο αποθήκες Α και Β τοποθετήθηκαν ισάριθμα δέματα, ή το μήνυμα «Καμία αποθήκευση στο αεροδρόμιο», αν κανένα δέμα δεν τοποθετήθηκε σε οποιαδήποτε από τις αποθήκες Α ή Β. (μονάδες 2)

Μονάδες 12

Γ2. Να κατασκευάσετε το υποπρόγραμμα που περιγράφεται στο ερώτημα Γ1.δ.

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ


ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_ΜΑΙΟΥ_ΗΜΕΡ_2015
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: πλήθοςΑ, πλήθοςΒ
 ΠΡΑΓΜΑΤΙΚΕΣ: μέγεθος, ΕΧΑ, ΕΧΒ
ΑΡΧΗ
 ΓΡΑΨΕ 'Δώστε Ελεύθερο Χώρο Αποθήκης Α: '
 ΔΙΑΒΑΣΕ ΕΧΑ
 ΓΡΑΨΕ 'Δώστε Ελεύθερο Χώρο Αποθήκης Β: '
 ΔΙΑΒΑΣΕ ΕΧΒ

 πλήθοςΑ <-- 0 !πλήθος δεμάτων αποθ.Α
 πλήθοςΒ <-- 0 !πλήθος δεμάτων αποθ.Β
 ΓΡΑΨΕ 'Δώστε Μέγεθος Δέματος:'
 ΔΙΑΒΑΣΕ Μέγεθος
 ΟΣΟ Μέγεθος <> 0 ΕΠΑΝΑΛΑΒΕ
     ΑΝ ΕΧΑ >= ΕΧΒ ΚΑΙ Μέγεθος <= ΕΧΑ ΤΟΤΕ
        ΕΧΑ <-- ΕΧΑ - Μέγεθος         !Εισάγω το δέμα
        πλήθοςΑ <-- ΠλήθοςΑ + 1       !Προσμετρώ το δέμα
        ΓΡΑΨΕ 'Α'                     !Εμφανίζω την αποθήκη που δέχθηκε
     ΑΛΛΙΩΣ_ΑΝ ΕΧΑ <= ΕΧΒ ΚΑΙ Μέγεθος <= ΕΧΒ ΤΟΤΕ
        ΕΧΒ <-- ΕΧΒ - Μέγεθος
        πλήθοςΒ <-- ΠλήθοςΒ + 1
        ΓΡΑΨΕ 'Β'
     ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΠΡΟΩΘΗΣΗ'
     ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ 'Δώστε Μέγεθος Δέματος: '
        ΔΙΑΒΑΣΕ Μέγεθος
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΚΑΛΕΣΕ Μήνυμα(πλήθοςΑ, ΠλήθοςΒ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Μήνυμα(πΑ, πΒ)
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: πΑ, πΒ
ΑΡΧΗ
 ΑΝ πΑ > πΒ ΤΟΤΕ
    ΓΡΑΨΕ 'Α'
 ΑΛΛΙΩΣ_ΑΝ πΑ < πΒ τότε
    ΓΡΑΨΕ 'Β'
 ΑΛΛΙΩΣ_ΑΝ πΑ = πΒ ΚΑΙ πΑ <>0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΙΣΑΡΙΘΜΑ'
 ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Καμιά αποθήκευση στο αεροδρόμιο'
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Share This