Επιλογή Σελίδας

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Αριθμοί_ΜΕΡΣΕΝ

Διάβασε Α

B<-4

C<-2

Αρχή_επανάληψης

Β<-(Β^2) – 2

      Εμφάνισε Β

C<- C + 1

Μέχρις_ότου C > (Α – 1)

D <- (2^Α) – 1

Ε<-Β ΜΟD D

Εμφάνισε D

Αν Ε = 0 τότε

F <- (2^(C – 1)) * D

      Εμφάνισε «Τέλειος αριθμός:», F

G<- 0

      Όσο F > 0 επανάλαβε

              Ρ <- Ρ DIV 10

      Τέλος_επανάληψης

       Εμφάνισε G

Τέλος_αν

Τέλος Αριθμοί_ΜΕΡΣΕΝ

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   3

Μονάδες 12

β.   4

Μονάδες 8

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια

Share This