Επιλογή Σελίδας

3, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ 19ος Π.Δ.Π (2007) Τελική Φάση (2ο Θέμα) – Ελληνικές υαλόσφαιρες

Η εταιρεία «Ελληνικές υαλόσφαιρες» κατασκευάζει γυάλινες μπάλες από ειδικό γυαλί. Κάθε μέρα παράγει ένα σύνολο από μπάλες ίδιας αντοχής. Ωστόσο, διαφορετικά σύνολα μπορεί να έχουν διαφορετική αντοχή. Για να μετρήσει την αντοχή κάθε συνόλου, ο μηχανικός παραγωγής ακολουθεί την εξής διαδικασία: Αφήνει σε ελεύθερη πτώση κάποιες μπάλες (από ένα σύνολο) από διαφορετικά επίπεδα ενός κτιρίου και, επομένως, παριστάνει την αντοχή τους με το χαμηλότερο επίπεδο στο οποίο η μπάλα θα σπάσει στην ελεύθερη πτώση. Κάθε επίπεδο καθορίζεται από ένα όροφο. Στην αρχή αποφασίζει να ανεβαίνει ένα – ένα τα πατώματα και να εκτελεί το πείραμα διαδοχικά. Επομένως αν μια μπάλα έχει αντοχή 10, θα εκτελέσει 10 προσπάθειες. Μετά αποφάσισε να κάνει κάτι πιο γρήγορο, με κόστος να χρησιμοποιεί περισσότερες μπάλες. Έτσι αποφάσισε να εκτελεί τυχαία πειράματα από διαφορετικούς ορόφους ώστε να περιορίζει τους ορόφους που θα κάνει προσπάθειες. Το «αφεντικό» του όμως βρίσκει ότι σπάει πολλές μπάλες έτσι και του προτείνει να βρίσκει την αντοχή χρησιμοποιώντας μόνο δύο μπάλες από κάθε σύνολο. Μετά από σκέψη ο μηχανικός αποφασίζει να κάνει το εξής. Θα χρησιμοποιήσει την πρώτη μπάλα για μια προσπάθεια από τον μεσαίο όροφο. Αν η μπάλα σπάσει, είναι σίγουρο ότι η αντοχή της είναι μικρότερη ή ίση από αυτή που αντιστοιχεί στο μεσαίο επίπεδο. Επομένως, θα χρησιμοποιήσει την δεύτερη μπάλα για να ελέγξει την αντοχή σειριακά ξεκινώντας από το πρώτο επίπεδο και δοκιμάζοντας διαδοχικά κάθε επίπεδο. Αν όμως δεν σπάσει όταν αφεθεί σε ελεύθερη πτώση από το μεσαίο επίπεδο, τότε θα αποκλείσει το κάτω μισό του κτιρίου και θα συνεχίσει με τον ίδιο τρόπο για το άνω μισό. Δηλαδή χρησιμοποιώντας πάλι την πρώτη μπάλα θα προσπαθήσει να βρει την αντοχή της συνεχίζοντας από το μεσαίο επίπεδο του πάνω μισού του κτιρίου. Παρόμοια, θα εκτελεί ένα βήμα τύπου δυαδικής αναζήτησης αν η πρώτη μπάλα αντέχει στην ελεύθερη πτώση ή ένα βήμα γραμμικής αναζήτησης μετά από το σπάσιμο της πρώτης μπάλας.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα, το οποίο αφού καταχωρήσει σε έναν Πίνακα [20 Χ 2] θέσεων τα επίπεδα ελέγχου και την αντοχή κάθε μπάλας στη συνέχεια, θα υπολογίζει και θα εμφανίζει για κάθε μπάλα το μικρότερο αριθμό προσπαθειών που απαιτείται για να υπολογιστεί η αντοχή της (Καμιά μπάλα δεν σπάει στο ισόγειο). ΕΠΥ, 19* Π.Δ.Π. (2007) Τελική Φάση (2° θέμα)

Λύση:

(περισσότερα…)

2, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ 18ος Π.Δ.Π (2006) Τελική Φάση (1ο Θέμα), Κυκλικός Επιταχυντής

Εκφώνηση

Οι συμμετέχοντες στο camp του 18ου ΠΔΠ, επισκέφθηκαν το νέο Κυκλικό Επιταχυντή Στοιχειωδών Σωματείων (ΚΕΣΣ) Θεσσαλονίκης. Ο επιταχυντής αυτός, περιλαμβάνει Ν θυρίδες εισόδου σωματείων. Στην είσοδο κάθε θυρίδας τα σωμάτια λαμβάνουν ενέργεια Εin(N) (όπου Ν ο αριθμός της θυρίδας). Κατά την τροχιά τους μέχρι την επόμενη θυρίδα, τα σωμάτια, δαπανούν ενέργεια που αντιστοιχεί σε φράγμα δυναμικού Εout(Ν) που πρέπει να «υπερπηδήσουν». Αν Εin(Ν) >= Εout(Ν) το σωμάτιο θα φθάσει στην επόμενη θυρίδα (Ν+1), στην οποία και θα λάβει ενέργεια Εin(N+1). Η συνολική λοιπόν ενέργεια του σωματίου στην Ν+1 θυρίδα (εφόσον μπήκε στην Ν) θα είναι: Εin(Ν) – Εout(Ν) + Εin(Ν+1).

Πρόβλημα

Να αναπτύξετε πρόγραμμα σε Γλώσσα, το οποίο αφού καταχωρίσει δεδομένα σε έναν πίνακα 50 Χ 2 θέσεων όπου στην [Ν-οστή, 1] θέση θα καταχωρείται η τιμή Εin(Ν) και στην [Ν-οστή, 2] θέση θα καταχωρείται η τιμή Εout(Ν). Το πρόγραμμα στη συνέχεια θα προσδιορίζει και θα εμφανίζει την πρώτη (με το μικρότερο αριθμό) θυρίδα από την οποία αν εισέλθει το σωμάτιο, θα ολοκληρώσει μια πλήρη κυκλική τροχιά εντός του επιταχυντή. ΕΠΥ, 18ος Π.Δ.Π. (2006) Τελική Φάση (1° θέμα)

Λύση

(περισσότερα…)

1, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ 18ος Π.Δ.Π (2006) Α’ Φάση, Μάρμαρα Παρθενώνα, ταξινόμηση με σταθερά στοιχεία

Εκφώνηση:

Η Ακρόπολη των Αθηνών αποτελεί, αν όχι το σημαντικότερο, ένα από τα σημαντικότερα δημιουργήματα της ανθρωπότητας. Η κατασκευή της Ακρόπολης από τη σύλληψη, τη σχεδίαση, τη μελέτη, το κτίσιμο και τη δημιουργία των αιώνιων γλυπτών της, αποκαλύπτουν το μεγαλείο του Ελληνικού πολιτισμού. Ένα από τα πάρα πολλά προβλήματα που είχαν να αντιμετωπίσουν οι Αρχαίοι Έλληνες ήταν η ανύψωση των μαρμάρων στον ιερό βράχο. Για να το επιτύχουν χρησιμοποίησαν ένα σύστημα με τροχαλίες, έτσι ώστε όταν κατέρχονταν μια άδεια άμαξα, να χρησιμοποιείται σαν αντίβαρο για την ανερχόμενη. Για την καλύτερη επίτευξη του σκοπού αυτού, ήταν προτιμότερο οι ελαφρύτερες άμαξες να ανέλθουν πρώτες. Ωστόσο, κατά η δημιουργία των γλυπτών της μετώπης του Παρθενώνα, μερικά ξεχωριστά κομμάτια πεντελικού μαρμάρου έπρεπε να μεταφερθούν άμεσα και σε συγκεκριμένη σειρά. Τα κομμάτια αυτά ήταν μικρά και πρακτικά μικρού βάρους (ενδεικτικό βάρος 1).

Πρόβλημα:

Να αναπτύξετε πρόγραμμα σε Γλώσσα, το οποίο αφού καταχωρίσει σε έναν πίνακα 100 θέσεων τα βάρη των μαρμάρων που πρέπει να μεταφερθούν με βάσει τη σειρά εξόρυξης, θα υπολογίσει και θα εμφανίζει τη σειρά μεταφοράς τους από το ελαφρύτερο προς το βαρύτερο. Τα βάρη με την ενδεικτική τιμή 1, αντιστοιχούν σε αυτά τα ξεχωριστά κομμάτια μαρμάρου, τα οποία πρέπει να μεταφερθούν με τη δεδομένη σειρά εμφάνισης (να εξαιρεθούν δηλαδή της ταξινόμησης). ΕΠΥ, 18ος Π.Δ.Π. (2006) Α’ Φάση

Λύση:

(περισσότερα…)

ΔΣ3. Κεφάλαιο 10. Επικρατούσα τιμή στοιχείων πίνακα

Να επεκτείνεις το παράδειγμα 1, ώστε να υπολογίζει την επικρατούσα τιμή, δηλαδή την τιμή που εμφανίζεται περισσότερες φορές.

ΛΥΣΗ

! εύρεση της τιμής που εμφανίζεται συχνότερα σε έναν πίνακα
ΠΡΟΓΡΑΜΜΑ Επικρατούσα_Τιμή
ΜΕΤΑΒΛΗΤΕΣ  
ΑΚΕΡΑΙΕΣ: ΣΤΟΙΧΕΙΑ[100], ΠΛΗΘΟΣ, ΤΙΜΗ[100], ΣΥΧΝΟΤΗΤΑ[100], ΘΕΣΗ
ΑΡΧΗ 
ΚΑΛΕΣΕ Εισαγωγή_δεδ(ΣΤΟΙΧΕΙΑ, ΠΛΗΘΟΣ)
ΚΑΛΕΣΕ Ταξινόμησε(ΣΤΟΙΧΕΙΑ, ΠΛΗΘΟΣ)
ΚΑΛΕΣΕ Συχνότητα_στοιχείων(ΣΤΟΙΧΕΙΑ, ΠΛΗΘΟΣ, ΤΙΜΗ, ΣΥΧΝΟΤΗΤΑ)
ΘΕΣΗ<-- Θέση_μέγιστο_πίνακα(ΣΥΧΝΟΤΗΤΑ, ΠΛΗΘΟΣ)
! απαιτείται επέκταση για περισσότερες τιμές με ίδια μέγιστη συχνότητα
ΓΡΑΨΕ 'Επικρατούσα τιμή =', ΤΙΜΗ[ΘΕΣΗ] 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! εισαγωγή στοιχείων σε πίνακα ίσα με πλήθος
ΔΙΑΔΙΚΑΣΙΑ Εισαγωγή_δεδ(στοιχεία, πλήθος)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: i, πλήθος, στοιχεία[100]
ΑΡΧΗ
! Εισαγωγή στοιχείων 
ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)' 
ΔΙΑΒΑΣΕ πλήθος 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ πλήθος 
    ΓΡΑΨΕ 'Δώσε έναν αριθμό' 
    ΔΙΑΒΑΣΕ στοιχεία[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Ταξινόμησε(Πίνακας, Ν) 
!Ταξινόμηση των στοιχείων του πίνακα ('έξυπνη')
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:I,Ν1,Τ,Βοηθητική, Πίνακας[100], Ν 
ΑΡΧΗ 
Ν1 <-- Ν 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    Τ <-- 0 
    ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ Ν1-1 
        ΑΝ Πίνακας[I] > Πίνακας[I+1] ΤΟΤΕ
           Βοηθητική <-- Πίνακας[I] 
           Πίνακας[I] <-- Πίνακας[I+1] 
           Πίνακας[I+1] <-- Βοηθητική 
           Τ <-- I 
        ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    Ν1 <-- Τ 
ΜΕΧΡΙΣ_ΟΤΟΥ Τ=0 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

! δέχεται ως είσοδο ΤΑΞΙΝΟΜΗΜΕΝΟ πίνακα με στοιχεία ίσα με πλήθος
! καταχωρεί σε 2 νέους παράλληλους πίνακες τις μοναδικές τιμές στον πίνακα τιμή
! και τη συχνότητα εμφάνισης τους στον πίνακα συχνότητα
ΔΙΑΔΙΚΑΣΙΑ Συχνότητα_στοιχείων(στοιχεία, πλήθος, τιμή, συχνότητα)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: στοιχεία[100], πλήθος, i, j, συχνότητα[100], τιμή[100]
ΑΡΧΗ
! Αρχικοποίηση πίνακα-μετρητή συχνότητα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ πλήθος
    συχνότητα[i]<--0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

τιμή[1]<-- στοιχεία[1]
συχνότητα[1] <-- 1
j<--1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ πλήθος
    ΑΝ στοιχεία[i] <> στοιχεία[i-1] ΤΟΤΕ
       j<--j+1
       τιμή[j]<--στοιχεία[i]
    ΤΕΛΟΣ_ΑΝ
    συχνότητα[j] <-- συχνότητα[j] + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

! επιστρέφει τη θέση του μέγιστου στοιχείου ενός πίνακα
ΣΥΝΑΡΤΗΣΗ Θέση_μέγιστο_πίνακα(συχνότητα,πλήθος) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: συχνότητα[100], θέση, πλήθος, max, i
ΑΡΧΗ
θέση<--1
max<--συχνότητα[1]
ΓΙΑ i ΑΠΟ 2 ΜΈΧΡΙ πλήθος
    ΑΝ συχνότητα[i]> max ΤΌΤΕ
       max<--συχνότητα[i]
       θέση<--i
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Θέση_μέγιστο_πίνακα<-- θέση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Παράδειγμα 1, Κεφάλαιο 9, Βιβλίο, Θερμοκρασίες μήνα σε πίνακα

Για παράδειγμα ένα πρόγραμμα το οποίο διαβάζει τις θερμοκρασίες διαφόρων ημερών του μήνα, έστω 30, και υπολογίζει τη μέση θερμοκρασία, μπορεί πολύ απλά να γραφεί ως εξής:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο  
ΑΚΕΡΑΙΕΣ: i, Ημέρες 
ΑΡΧΗ  
Σύνολο <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΓΡΑΨΕ 'Δώσε τη θερμοκρασία'  
    ΔΙΑΒΑΣΕ Θερμοκρασία[i]   
    Σύνολο <-- Σύνολο+ Θερμοκρασία[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ  
Μέση <-- Σύνολο/30  
Ημέρες <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΑΝ Θερμοκρασία[i] < Μέση ΤΟΤΕ    
       Ημέρες <-- Ημέρες+1  
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Μέση Θερμοκρασία:', Μέση 
ΓΡΑΨΕ 'Ημέρες με μικρότερη θερμοκρασία', Ημέρες 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 2, Κεφάλαιο 9, Βιβλίο, Στατιστικά μεγέθη στοιχείων πίνακα, μέση τιμή, τυπική απόκλιση, διάμεσος τιμή

Να γραφεί πρόγραμμα το οποίο να υπολογίζει τα βασικά στατιστικά μεγέθη, τη μέση τιμή, την τυπική απόκλιση και τη διάμεσο τιμή Ν ακεραίων αριθμών, όπου το Ν είναι από 2 μέχρι 100.
Τα δεδομένα εισάγονται από το πληκτρολόγιο και καταχωρούνται στον πίνακα Χ.

Η μέση τιμή μ δίνεται από τον τύπο  

Η τυπική απόκλιση σ δίνεται από τον τύπο 

Για να βρεθεί η διάμεσος τιμή πρέπει υποχρεωτικά οι αριθμοί να ταξινομηθούν κατά αύξουσα σειρά. Τότε διάμεσος τιμή, είναι η τιμή για την οποία οι μισοί αριθμοί είναι μικρότεροι και οι άλλοι μισοί μεγαλύτεροι. Στην περίπτωση που το πλήθος των αριθμών είναι περιττό, τότε διάμεσος είναι ο μεσαίος, ενώ στην περίπτωση που είναι άρτιο, τότε διάμεσος είναι το ημιάθροισμα των δύο μεσαίων αριθμών. Η ταξινόμηση των στοιχείων γίνεται με τη μέθοδο ταξινόμησης ευθείας ανταλλαγής, η οποία παρουσιάστηκε στο κεφάλαιο 3.

ΠΡΟΓΡΑΜΜΑ Στατιστική 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ : i, Ν, Χ[100], Άθροισμα, Άθροισμα_2, Βοηθητική, ΝΖ, ΝΜ, j ! Παρόραμα δεν δηλώθηκε η j
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΤ, Τυπ_Απόκλιση, Διάμεσος 
ΑΡΧΗ 
! Εισαγωγή δεδομένων 
ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)' 
ΔΙΆΒΑΣΕ Ν 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
    ΓΡΑΨΕ 'Δώσε τον ',i,'-το αριθμό' 
    ΔΙΑΒΑΣΕ Χ[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός αθροισμάτων 
Άθροισμα <-- 0 
Άθροισμα_2 <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
   ! ΓΡΑΨΕ 'Δώσε τον',i,'-το αριθμό'  Παρόραμα - Ξαναδιαβάζει τους αριθμούς
   ! ΔΙΑΒΑΣΕ Χ[i] 
    Άθροισμα <-- Άθροισμα + Χ[i] 
    Άθροισμα_2 <-- Άθροισμα_2 + Χ[i]^2 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός μέσου όρου 
ΜΤ <-- Άθροισμα/Ν 
!Υπολογισμός τυπικής απόκλισης 
Τυπ_Απόκλιση <-- Τ_Ρ(Άθροισμα_2/Ν - ΜΤ^2) 
!Ταξινόμηση των στοιχείων του πίνακα 
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν 
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1 
       ΑΝ Χ[j-1] > Χ[j] ΤΟΤΕ 
! Αντιμετάθεση των στοιχείων j και j-1 
      Βοηθητική <-- Χ[j-1] 
      Χ[j-i] <-- Χ[j] 
      Χ[j] <-- Βοηθητική 
      ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! j 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! i 
!Υπολογισμός διαμέσου
ΝΖ <--Ν DIV 2
ΝΜ <--(Ν DIV 2) + 1
ΑΝ Ν MOD 2 =0 ΤΟΤΕ 
   Διάμεσος <-- (Χ[Ν div 2]+Χ[(Ν div 2)]+1)/2 !Παρόραμα - Πρόβλημα με την δήλωση τύπου του Ν
ΑΛΛΙΩΣ 
   Διάμεσος <-- Χ[(Ν+1)div 2] ! Παρόραμα
ΤΕΛΟΣ_ΑΝ 
! Εκτύπωση αποτελεσμάτων 
ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ' 
ΓΡΑΨΕ '============' 
ΓΡΑΨΕ 'Πλήθος τιμών =', Ν 
ΓΡΑΨΕ 'Μέση τιμή = ', ΜΤ 
ΓΡΑΨΕ 'Τυπική απόκλιση = ', Τυπ_Απόκλιση 
ΓΡΑΨΕ 'Διάμεσος = ', Διάμεσος 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 9, Βιβλίο, Μέση Θερμοκρασία πόλεων

Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον προηγούμενο πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες 10 πόλεων). Επίσης, για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση.

ΛΥΣΗ (περισσότερα…)

ΔΤ1, Κεφάλαιο 9, Μετατροπή φυσικής γλώσσας σε κωδικοποίηση, δήλωση και εισαγωγή στοιχείων σε πίνακα

Να γράψετε τις δηλώσεις των παρακάτω πινάκων, καθώς και τις εντολές με τις οποίες εκχωρούνται οι τιμές σε αυτά.

Α) Πίνακας 5 στοιχείων που κάθε στοιχείο έχει την τιμή του δείκτη του.

Β) Πίνακας που θα περιέχει τα ψηφία.

Γ) Πίνακας που περιέχει τα ονόματα των συμμαθητών σου.

Δ) Πίνακας με 10 στοιχεία, πρώτο στοιχείο τον αριθμό 500 και κάθε επόμενο στοιχείο να είναι το μισό του προηγούμενου, δηλαδή το δεύτερο 250, το τρίτο 125 κ.ο.κ.

ΛΥΣΗ (περισσότερα…)

ΔΤ2, Κεφάλαιο 9, Ελάχιστο – Μεγιστο στοιχείο μονοδιάστατου πίνακα, Min – Max, Τυπικές επεξεργασίες

Έχουμε δύο πίνακες, ο ένας με τα μοντέλα των υπολογιστών και ο δεύτερος με τις τιμές τους. Να γράψετε τις εντολές που βρίσκουν και τυπώνουν το φθηνότερο μοντέλο καθώς και το ακριβότερο.

ΛΥΣΗ (περισσότερα…)