Επιλογή Σελίδας

Λόγω της διεύρυνσης της οικονομικής κρίσης και προκειμένου αυτή να μην λάβει χαρακτηριστικά κοινωνικής καταστροφής, ιδρύματα (εκπαιδευτικά και μη), μη κυβερνητικές οργανώσεις και εκατοντάδες συλλογικότητες σε ολόκληρη την Ελλάδα, αναπτύσσουν δράσεις κοινωνικής αλληλεγγύης και προστασίας. Ανταλλαγή αγαθών και υπηρεσιών,  διανομή ειδών πρώτης ανάγκης, παροχή υπηρεσιών υγείας και εκπαιδευτικής υποστήριξης είναι μερικές από τις πολλαπλές δράσεις που αναπτύσσονται στον τόπο μας. Αυτό που από την αρχή έγινε φανερό, ήταν ότι οι δράσεις αυτές είναι τόσο περισσότερο αποτελεσματικές, όσο   πιο   συντονισμένες   είναι   και   όσο μεγαλύτερη διασπορά έχουν στην Ελληνική επικράτεια. Βασικός μοχλός και για τα δύο, είναι οι σύνδεση και συνεργασία μεταξύ των δομών αλληλεγγύης. Οι μαθητές ενός σχολείου δεύτερης ευκαιρίας ανέλαβαν την πρωτοβουλία να καταγράψουν τις υφιστάμενες δομές και να εντοπίσουν εκείνες που έχουν σύνδεση με λιγότερες από δύο άλλες δομές.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα, το οποίο αφού καταχωρίσει σε έναν Πίνακα [Ν Χ 2] όλες τις υφιστάμενες συνδέσεις σε ένα δίκτυο δομών αλληλεγγύης θα εμφανίζει το πλήθος των δομών που έχουν λιγότερες από δύο συνδέσεις.

Παράδειγμα:

Στον παρακάτω πίνακα εισόδου το αποτέλεσμα της επεξεργασίας είναι 2 (οι δομές 2 & 7 έχουν μόνο μια σύνδεση η καθεμιά τους). ΕΠΥ, 26ος Π.Δ.Π. (2014) Α’ Φάση.

ΛΥΣΗ:

! Θα πρέπει να καθορίζεται, εκτός από το πλήθος των διασυνδέσεων Ν, και το πλήθος των δομών Μ

ΠΡΟΓΡΑΜΜΑ ΑΣΚ12_ΠΑΡ_Β_ΠΙΝ_ΔΟΜΕΣ_ΑΛΛΗΛΕΓΓΥΗΣ
ΣΤΑΘΕΡΕΣ
  Ν=8  ! Πλήθος διασυνδέσεων
  Μ=7  ! Πλήθος Δομών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, Δ[Ν,2], Π[Ν], ελάχιστος
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      ΔΙΑΒΑΣΕ Δ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν                   
    Π[i] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                                                


  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν   ! διασυνδέσεις
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      Π[ Δ[i,j] ] <-- Π [ Δ[i,j] ] + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ελάχιστος <-- Π[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Μ   ! δομές
    ΑΝ ελάχιστος > Π[i] ΤΟΤΕ
      ελάχιστος <-- Π[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'ΔΟΜΕΣ ΜΕ ΤΙΣ ΛΙΓΟΤΕΡΕΣ ΔΙΑΣΥΝΔΕΣΕΙΣ'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΑΝ Π[i] = ελάχιστος  ΤΟΤΕ
      ΓΡΑΨΕ i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Είσοδος (7 δομές, 8 Διασυνδέσεις):
 7
 2
 4
 4
 1
 3
 5
 4
 3
 1
 3
 5
 1
 5
 6





Share This