Επιλογή Σελίδας

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Νέο

Ο αριθμός π εκφράζει το πηλίκο της περιμέτρου ενός κύκλου προς τη διάμετρό του. Η τιμή του μπορεί να υπολογιστεί, κατά προσέγγιση, από την παρακάτω παράσταση:
er1the-v-aepp-2016-imerisia-neo
Ο υπολογισμός της τιμής της παράστασης, για 100 όρους του αθροίσματος, γίνεται από το παρακάτω τμήμα αλγορίθμου που περιλαμβάνει 5 κενά.

παρονομαστής < (1)   
 Σ< 0
 πρόσημο < 1
 Για i από 1 μέχρι 100
       όρος < 1/παρονομαστής
       όρος<  (2)  * πρόσημο
       (3)   < Σ + όρος
       πρόσημο < πρόσημο * ( (4) )
       παρονομαστής < παρονομαστής + 2 
 Τέλος_Επανάληψης
 π <- (5) * Σ

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε ο αλγόριθμος να υπολογίζει την τιμή του π όπως περιγράφηκε.
Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Νέο

Κατά την είσοδό τους σε μια τράπεζα οι πελάτες παίρνουν διαδοχικούς αριθμούς προτεραιότητας 1, 2, 3… που καθορίζουν τη σειρά τους στην ουρά του μοναδικού ταμείου.

Κάθε 2 λεπτά της ώρας προσέρχεται ένας νέος πελάτης και προστίθεται στην ουρά. Ο ταμίας εξυπηρετεί κάθε φορά τον πρώτο πελάτη στην ουρά και η εξυπηρέτησή του διαρκεί 3 λεπτά ακριβώς. Μετά την εξυπηρέτησή του ο πελάτης αποχωρεί από την ουρά.

Κατά την αρχή της διαδικασίας (χρόνος 0) στην ουρά υπάρχει μόνο ο πελάτης με αριθμό προτεραιότητας 1.

Να γράψετε διαδοχικά, σε ξεχωριστές γραμμές, με τη σωστή σειρά, τους αριθμούς προτεραιότητας των πελατών που βρίσκονται στην ουρά του ταμείου αμέσως μετά το 1ο , 2ο , 3ο , 4ο , 5ο και 6ο λεπτό.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ

(περισσότερα…)

Θέμα Γ, 2016, Ημερήσια, Νέο

Μία εταιρεία πληροφορικής προσφέρει υπολογιστές σε τιμές οι οποίες μειώνονται ανάλογα με την ποσότητα της παραγγελίας, όπως φαίνεται στον παρακάτω πίνακα:

ΠΟΣΟΤΗΤΑ ΤΙΜΗ ΜΟΝΑΔΑΣ
1-50 580
51-100 520
101-200 470
Πάνω από 200 440

Να κατασκευάσετε πρόγραμμα το οποίο:
Γ1. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2
Γ2. Να διαβάζει τον αριθμό υπολογιστών που έχει προς πώληση (απόθεμα), ελέγχοντας ότι δίνεται θετικός αριθμός
Μονάδες 2
Γ3. Για κάθε παραγγελία, να διαβάζει την απαιτούμενη ποσότητα και, εφόσον το απόθεμα επαρκεί για την κάλυψη της ποσότητας να εκτελεί την παραγγελία με την ποσότητα που ζητήθηκε. Αν το απόθεμα δεν επαρκεί, διατίθεται στον πελάτη το διαθέσιμο απόθεμα. Η εισαγωγή παραγγελιών τερματίζεται, όταν εξαντληθεί το απόθεμα.
Μονάδες 6
Για κάθε παραγγελία να εμφανίζει:
Γ4. το κόστος της παραγγελίας
Μονάδες 4
Γ5. το επιπλέον ποσό που θα κόστιζε η παραγγελία, εάν ο υπολογισμός γινόταν κλιμακωτά με τις τιμές που φαίνονται στον πίνακα.
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ
(περισσότερα…)

Θέμα Δ, 2016, Ημερήσια, Νέο

Το Πανελλήνιο Σχολικό Δίκτυο παρέχει πρόσβαση στο Διαδίκτυο (Ίντερνετ) σε 150.000 μαθητές και διατηρεί τα στοιχεία τους, καθώς και στατιστικά στοιχεία, σχετικά με την πρόσβασή τους στο Διαδίκτυο. Να κατασκευάσετε πρόγραμμα το οποίο:

Δ1. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Δ2. Για κάθε μαθητή να διαβάζει:
α) τον αλφαριθμητικό κωδικό του και να τον καταχωρίζει σε μονοδιάστατο πίνακα με όνομα ΚΩΔ
β) το φύλο του, «Α» αν είναι αγόρι και «Κ» αν είναι κορίτσι, και να το καταχωρίζει σε μονοδιάστατο πίνακα με όνομα Φ
γ) τον συνολικό χρόνο πρόσβασής του στο Διαδίκτυο ανά μήνα, για ένα έτος, και να τον καταχωρίζει σε δισδιάστατο πίνακα ΧΡ.
Μονάδες 3

Δ3. Να υπολογίζει και να καταχωρίζει σε πίνακα ΣΧ το συνολικό ετήσιο χρόνο πρόσβασης κάθε μαθητή.
Μονάδες 3

Δ4. Να εμφανίζει τον κωδικό του αγοριού με το μεγαλύτερο συνολικό χρόνο πρόσβασης και, στη συνέχεια, τον κωδικό του κοριτσιού με το μεγαλύτερο συνολικό χρόνο πρόσβασης, καλώντας τη συνάρτηση ΘΕΣΗ_ΜΑΧ, που περιγράφεται στο ερώτημα Δ5, μία φορά για τα αγόρια και μία για τα κορίτσια.
Μονάδες 4

Δ5. Να αναπτύξετε συνάρτηση ΘΕΣΗ_ΜΑΧ η οποία:
α) να δέχεται ως παραμέτρους: τον πίνακα του φύλου, τον πίνακα του συνολικού ετήσιου χρόνου πρόσβασης των μαθητών και τον χαρακτήρα «Α» ή «Κ» που αντιστοιχεί στο φύλο (μονάδες 2)
β) να βρίσκει τη θέση της μέγιστης τιμής του ετήσιου χρόνου πρόσβασης αγοριών ή κοριτσιών, ανάλογα με την τιμή «Α» ή «Κ» του φύλου (μονάδες 4)
γ) να επιστρέφει τη θέση της μέγιστης τιμής (μονάδες 2)
Μονάδες 8

(Σημείωση: Δεν απαιτείται έλεγχος εγκυρότητας. Να θεωρήσετε ότι όλες οι εισαγωγές γίνονται σωστά και όλες οι συνολικές τιμές χρόνου πρόσβασης είναι μοναδικές).

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επίλυση της δευτεροβάθμιας εξίσωσης αποτελεί ένα αδόμητο πρόβλημα.
  2. Η εντολή Αρχή_επανάληψης .. Μέχρις_ότου εκτελείται οπωσδήποτε μία φορά.
  3. Τα στοιχεία των στατικών δομών δεδομένων αποθηκεύονται σε μη συνεχόμενες θέσεις μνήμης.
  4. Οι μεταβλητές που χρησιμοποιούνται σ’ ένα πρόγραμμα αντιστοιχούνται από το μεταγλωττιστή σε συγκεκριμένες θέσεις μνήμης του υπολογιστή.
  5. Η ακολουθιακή δομή εντολών χρησιμοποιείται, όταν είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ
1. Λάθος
2. Σωστό
3. Λάθος
4. Σωστό
5. Σωστό

Θέμα Α, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Να αναφέρετε επιγραμματικά πέντε από τα πλεονεκτήματα του δομημένου προγραμματισμού.

Μονάδες 10

ΑΠΑΝΤΗΣΗ  (5 από τα παρακάτω 6)

  1. Δημιουργία απλούστερων προγραμμάτων.
  2. Άμεση μεταφορά των αλγορίθμων σε προγράμματα.
  3. Διευκόλυνση ανάλυσης του προγράμματος σε τμήματα.
  4. Περιορισμός των λαθών κατά την ανάπτυξη του προγράμματος.
  5. Διευκόλυνση στην ανάγνωση και κατανόηση του προγράμματος από τρίτους.
  6. Ευκολότερη διόρθωση και συντήρηση.

Θέμα Α, Ερώτημα 3, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Αν x > 0 ή y > 0 τότε
      Εμφάνισε “Ένας τουλάχιστον θετικός αριθμός” 
Αλλιώς_αν x < 0 και y < 0 τότε
      Εμφάνισε “Δύο αρνητικοί αριθμοί” 
Τέλος_αν

Να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο να παράγει το ίδιο αποτέλεσμα με το παραπάνω, χρησιμοποιώντας μόνο τις λογικές συνθήκες x > 0, x < 0, y > 0, y < 0 και χωρίς να χρησιμοποιήσετε λογικούς τελεστές.

Μονάδες 7

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

Αν x > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός' 
Αλλιώς_αν y > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός'
Αλλιώς
    Αν x < 0
       Αν y < 0
          Εμφάνισε 'Δύο αρνητικοί αριθμοί' 
       Τέλος_αν
    Τέλος_αν
Τέλος_αν

Θέμα Α, Ερώτημα 4, 2016, Ημερήσια, Παλαιό

Να γράψετε συμπληρωμένο κατάλληλα στο τετράδιό σας το παρακάτω τμήμα αλγορίθμου, ώστε να εμφανίζει διαδοχικά τις τιμές: 2, 4, 8, 10, 14.

Για Ι από ……… μέχρι ……… με_βήμα ………
       Αν ……… και ……… τότε
             Εμφάνισε Ι 
       Τέλος_αν 
Τέλος_επανάληψης

Μονάδες 5

Τα Θέματα σε pdf, 2016, Μαϊου-Ιουνίου, Ημερήσια, Παλαιό

ΛΥΣΗ

Για Ι από …2… μέχρι …14… με_βήμα …2…
       Αν …Ι MOD 2 = 0… και …I MOD 3 <> 0… τότε
             Εμφάνισε Ι 
       Τέλος_αν 
Τέλος_επανάληψης

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α καιδίπλατο γράμμα της στήλης Β που αντιστοιχεί σωστά. (Να θεωρήσετε ότι ο είναι θετικός ακέραιος).
 
Στήλη   Α Στήλη  Β
1. X DIV 1000 = 0 α. Βρίσκει την τιμή του ψηφίου των χιλιάδων.
2. X DIV 1000 MOD 10 β. Ελέγχει αν ο αριθμός έχει τουλάχιστον τρία  ψηφία.
3. X DIV 100 <> 0 γ. Βρίσκει την τιμή του ψηφίου των εκατοντάδων.
4. X MOD 1000 DIV 100 δ. Ελέγχει  αν ο αριθμός έχει  το πολύ τρία ψηφία.

Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

1. δ
2. α
3. β
4. γ

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου.
01 ΔΙΑΒΑΣΕ X
02 ΠΛ<– 0
03 ΑΡ <– 1
04 ΔΕ <– 12
05 Β <– ΨΕΥΔΗΣ
ΟΣΟ Β = ΨΕΥΔΗΣ ΚΑΙ ΑΡ <= ΔΕ ΕΠΑΝΑΛΑΒΕ
06 Μ <– (ΑΡ + ΔΕ) DIV 2
AN A[M] = X TOTE
07 B <– ΑΛΗΘΗΣ
ΑΛΛΙΩΣ_ΑΝ Α[Μ] < Χ ΤΟΤΕ
08 ΑΡ <– Μ + 1
ΑΛΛΙΩΣ
09 ΔΕ <– Μ – 1
ΤΕΛΟΣ  ΑΝ
10 ΠΛ <– ΠΛ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Β = ΑΛΗΘΗΣ ΤΟΤΕ
11 ΕΜΦΑΝΙΣΕ Μ
ΑΛΛΙΩΣ
12 ΕΜΦΑΝΙΣΕ “ΔΕΝ ΒΡΕΘΗΚΕ”, ΠΛ
ΤΕΛΟΣ_ΑΝ

Για την παρακολούθηση της εκτέλεσης του τμήματος αλγορίθμου με τιμή εισόδου Χ = 35 και με δεδομένο τον πίνακα

1 2 3 4 5 6 7 8 9 10 11 12
Α 3 10 18 20 26 32 35 48 55 60 75 90
δίνεται το παρακάτω υπόδειγμα πίνακα τιμών,συμπληρωμένο ως εξής:
  • Στη στήλη με τίτλο «Αρ. Γρ.» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «Έξοδος» καταγράφεται η τιμή εξόδουεφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Οι  υπόλοιπες στήλες του πίνακα τμήματος του αλγορίθμου αντιστοιχούν στις μεταβλητές του τμήματος του αλγορίθμου.
Αρ.Γρ. Χ ΠΛ ΑΡ ΔΕ Β Μ Έξοδος
01 35
02 0
03 1
04 12
05 ΨΕΥΔΗΣ
……

Να μεταφέρετε τον πίνακα τιμών στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του τμήματος αλγορίθμου ως εξής: για κάθε αριθμημένη εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Δίνεται ο πίνακας αριθμών Χ[50], ταξινομημένος κατά φθίνουσα σειρά, και ο πίνακας Υ[100], ταξινομημένος κατά αύξουσα σειρά. Να θεωρήσετε ότι οι τιμές κάθε πίνακα είναι διαφορετικές μεταξύ τους και ότι οι δύο πίνακες δεν έχουν κοινές τιμές.

Το παρακάτω ημιτελές τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Ζ[10], ταξινομημένο σε φθίνουσα σειρά, με τις δέκα μεγαλύτερες τιμές από τις εκατόν πενήντα (150) τιμές των δύο πινάκων.

i <--(1)
j <-- (2)
Για k από 1 μέχρι 10
      Αν Χ[ i ] (3) Υ[ j ] τότε 
            Ζ[ k ] <-- Χ[ i ] 
            i <-- i (4) 1 
     Αλλιώς
            Ζ[ k ] <-- Υ[ j ] 
             j <-- j (5) 1 
    Τέλος_αν
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Γ, 2016, Ημερήσια, Παλαιό

Ένας μαθητής αγόρασε έναν εξωτερικό δίσκο χωρητικότητας 1000 GB, προκειμένου να αποθηκεύσει σε αυτόν ψηφιακά αρχεία.
Να γραφεί πρόγραμμα σε ΓΛΩΣΣΑ, το οποίο:

Γ1.      
αΝα περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 2)
β. Για κάθε ψηφιακό αρχείο που θέλει να αποθηκεύσει ο μαθητής στον εξωτερικό δίσκο, να διαβάζει το όνομά του και το μέγεθός του (σε GB) και να ελέγχει, αν επαρκεί η διαθέσιμη χωρητικότητα του εξωτερικού δίσκου. Εφόσον επαρκεί, να εμφανίζει το μήνυμα «Επιτρεπτή αποθήκευση» και να υπολογίζει τη νέα διαθέσιμη χωρητικότητα του εξωτερικού δίσκου. Να τερματίζει τον έλεγχο της αποθήκευσης ψηφιακών αρχείων στον εξωτερικό δίσκο, όταν το μέγεθος του αρχείου που θέλει να αποθηκεύσει ο μαθητής είναι μεγαλύτερο από τη διαθέσιμη χωρητικότητα του εξωτερικού δίσκου. (μονάδες 6)
Μονάδες 8

Γ2.       Να υπολογίζει  και να εμφανίζει το ποσοστό του αριθμού των αρχείων που αποθηκεύτηκαν και έχουν μέγεθος μεγαλύτερο των 10 GB.
Μονάδες 4

Γ3.       Να βρίσκει και να εμφανίζει τα ονόματα των δύο μικρότερων σε μέγεθος αρχείων που αποθηκεύτηκαν στον εξωτερικό δίσκο.
Μονάδες 8

Να θεωρήσετε ότι:
α)       θα αποθηκευτούν τουλάχιστον δύο αρχεία στον εξωτερικό δίσκο,
β)       τα μεγέθη όλων των αρχείων που αποθηκεύονται, είναι διαφορετικά μεταξύ τους.

ΛΥΣΗ (περισσότερα…)