Επιλογή Σελίδας

Θέμα A, Ερώτημα 1, 2014, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Οι εκφράσεις διαμορφώνονται από τους τελεστέους και τους τελεστές. (μονάδες 2)
  2. Σκοπός της ταξινόμησης είναι να διευκολυνθεί στη συνέχεια η αναζήτηση των στοιχείων του ταξινομημένου πίνακα. (μονάδες 2)
  3. To εκτελέσιμο πρόγραμμα δημιουργείται ακόμα και στην περίπτωση που το αρχικό πρόγραμμα περιέχει λογικά, αλλά όχι συντακτικά λάθη. (μονάδες 2)
  4. Οι λογικές τιμές είναι οι εξής: ΟΧΙ, ΚΑΙ, Ή. (μονάδες 2)
  5. Μεταξύ των εντολών του σώματος μιας συνάρτησης πρέπει υποχρεωτικά να υπάρχει τουλάχιστον μία εντολή εκχώρησης τιμής στο όνομα της συνάρτησης. (μονάδες 2)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2013, Επαναληπτικές, Ημερήσια

Πρώτος ονομάζεται ένας φυσικός αριθμός, όταν έχει ακριβώς δύο διαιρέτες: τον εαυτό του και τη μονάδα. Ο παρακάτω αλγόριθμος γράφτηκε, έτσι ώστε να εμφανίζει τους πρώτους αριθμούς από το 2 μέχρι και το 100.

ΑΛΓΟΡΙΘΜΟΣ πρώτοι
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
Μ <i
ΓΙΑ j ΑΠΟ 0 ΜΕΧΡΙ i
ΑΝ i / j = 0 ΤΟΤΕ
Μ <- Μ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ < 3 ΤΟΤΕ ΕΜΦΑΝΙΣΕ i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ πρώτοι
Ο παραπάνω αλγόριθμος έχει λάθη. Να τον γράψετε στο τετράδιό σας, κάνοντας τις απαραίτητες διορθώσεις, ώστε να λειτουργεί σωστά, χωρίς την προσθήκη νέων εντολών.

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Ερώτημα 3, Θέμα Α. 2009, Μαΐου-Ιουνίου, Ημερήσια

1.   Η  κατανόηση  ενός προβλήματος αποτελεί συνάρτηση δύο παραγόντων. Να τους αναφέρετε.
Μονάδες 4
2.  α. Πότε εμφανίζονται τα συντακτικά λάθη ενός προγράμματος και πότε τα λογικά;
Μονάδες 2
β.    Δίνονται   οι   παρακάτω   λανθασμένες   εντολές   για τον υπολογισμό του μέσου όρου δύο αριθμών:

  1. Γ<- Α+Β/2
  2. Γ<- (Α+Β/2
  3. Γ<- (Α+Β/2)
  4. Γ<- (Α+Β):2

Να γράψετε στο τετράδιό σας τον αριθμό της κάθε εντολής (1, 2, 3, 4) και δίπλα τη λέξη συντακτικό ή τη λέξη λογικό, ανάλογα με το είδος του λάθους.
Μονάδες 4

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 4, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση
Δεδομένα //Π,Ν,Χ//
flag <- ψευδής
Ι <- 1
Όσο   Ι ≤ Ν  και   flag=ψευδής  επανάλαβε
          Αν Π[Ι]=Χ  τότε
flag <- αληθής
         Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //flag//
Τέλος Αναζήτηση

  1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών; (Μονάδες 2)

Να αιτιολογήσετε την απάντησή σας. (Μονάδες 3)

Μονάδες 5

  1. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Θέμα Β, 2008, Επαναληπτικές, Ημερήσια

Α.   Δίνεται το παρακάτω πρόγραμμα σε «ΓΛΩΣΣΑ»

1.ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ-ΠΡΩΤΟΣ

2.ΜΕΤΑΒΛΗΤΕΣ

3.ΑΚΕΡΑΙΕΣ: Χ, i

4.ΧΑΡΑΚΤΗΡΕΣ: ΜΗΝΥΜΑ

5. ΑΡΧΗ

6.ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

7.ΔΙΑΒΑΣΕ Χ

8. ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0

9.C<- 0

10.ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Χ ΕΠΑΝΑΛΑΒΕ

11. AN (Χ MOD i) = 0 TOTE

12. C<- C + 1  

13. ΤΕΛΟΣ_ΑΝ

14.ΤΕΛΟΣ_ΓΙΑ

15.ΑΝ C=2 TOTE

16. MHNYMA<- ‘ EINAI ΠΡΩΤΟΣ’

17.ΑΛΛΙΩΣ

18.ΜΗΝΥΜΑ <- ‘ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ’ 

19.ΤΕΛΟΣ

20.ΓΡΑΨΕ ΜΗΝΥΜΑ

21.ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ

Β.

Να γράψετε στο τετράδιό σας τον αριθμό κάθε γραμμής του προγράμματος, στην οποία εντοπίζετε συντακτικό λάθος και να περιγράψετε το λάθος αυτό.

Μονάδες 12

Να  μεταφέρετε στο τετράδιό σας συμπληρωμένο τον παρακάτω πίνακα αληθείας.

Α Β (ΟΧΙ Α) ΚΑΙ (ΟΧΙ Β) ((ΟΧΙ Α) ΚΑΙ Β) Ή (Α ΚΑΙ (ΟΧΙ Β))
Ψευδής Ψευδής
Ψευδής Αληθής
Αληθής Ψευδής
Αληθής Αληθής

Μονάδες 8

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια

Θέμα Α, Ερώτημα 1, 2001, Ημερήσια, Επαναληπτικές

Να γράψετε στο τετράδιο σας, ποιες από τις παρακάτω εντολές εκχώρησης είναι συντακτικά σωστές και ποιες λάθος.
α. 2* Α  <- Α
β. Α <- 3*Α + 5
γ. Β + 5 <- “Α”

Μονάδες 3

ΛΥΣΗ: (περισσότερα…)