Επιλογή Σελίδας

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα B, Ερώτημα 2, 2012, Επαναληπτικές, Ημερήσια

Δίνονται οι πίνακες DATA[7], L[7], R[7], οι οποίοι περιέχουν δεδομένα, όπως φαίνονται στα παρακάτω σχήματα:
er2themabaepp-2012-imerisia-epanaliptikes
Χρησιμοποιώντας τους ανωτέρω πίνακες, να εκτελέσετε το παρακάτω τμήμα αλγορίθμου και να συμπληρώσετε τον πίνακα τιμών, αφού τον μεταφέρετε στο τετράδιό σας.
ΓΡΑΜΜΑ <- ΄Σ΄
Κ <- 1
Όσο DATA[K] <> ΓΡΑΜΜΑ
επανάλαβε
Εκτύπωσε DATA[K]
Αν DATA[K] > ΓΡΑΜΜΑ τότε
Κ <- L[K]
αλλιώς
Κ <- R[K]
Τέλοςαν
Τέλος
επανάληψης
Εκτύπωσε DATA[K]

Πίνακας τιμών

ΓΡΑΜΜΑ Κ ΟΘΟΝΗ (ΕΚΤΥΠΩΣΗ)
Σ

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

 

Ερώτημα 2, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο πίνακας Α τεσσάρων στοιχείων με τιμές:
Α[1]=3, Α[2]=5, Α[3]=8, Α[4]=13 και το παρακάτω τμήμα αλγορίθμου:
i <- 1 j <- 4
Όσο i<=3 επανάλαβε
πρόχειρο <- Α[j]
A[j] <- Α[i]
Α[i] <- πρόχειρο
Γράψε   Α[1], Α[2], Α[3]
i <- i + 1
j <- j – 1
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανισθούν κατά την εκτέλεσή του.
Μονάδες 9

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Θέμα Β, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Κ= 4
Όσο Κ >= 1 επανάλαβε
Α<-1
Αν Κ<>2 τότε
Για i από 1 μέχρι Κ
Α<-2*Α
Τύπωσε  i , Α
Τέλος_επανάληψης
Τέλος_αν
Κ<-Κ/2
Τέλος_επανάληψης
Καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου, ποιες τιμές τυπώνονται με την εντολή Τύπωσε i , Α;

Μονάδες 20

ΛΥΣΗ:  (περισσότερα…)