Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Κ= 4
Όσο Κ >= 1 επανάλαβε
Α<-1
Αν Κ<>2 τότε
Για i από 1 μέχρι Κ
Α<-2*Α
Τύπωσε  i , Α
Τέλος_επανάληψης
Τέλος_αν
Κ<-Κ/2
Τέλος_επανάληψης
Καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου, ποιες τιμές τυπώνονται με την εντολή Τύπωσε i , Α;

Μονάδες 20

ΛΥΣΗ: 

Οι τιμές που θα εκτυπωθούν είναι οι 10 παρακάτω :

i Α
1η επανάληψη 1 2
2 4
3 8
4 16
2η επανάληψη Δεν θα εκτυπωθεί τίποτε επειδή Κ=2 και δεν εκτελείται η εντολή τύπωσε i, A
3η επανάληψη 1 2

Τα θέματα σε pdf, 2001, Επαναληπτικές, Ημερήσια

Share This