Θέμα Α, Eρώτημα 1, 2015, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμίας από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επαναληπτικότητα των διαδικασιών είναι ένας από τους λόγους ανάθεσης της επίλυσης ενός προβλήματος σε υπολογιστή. (μονάδες 2)
  2. Ο βρόχος Για κ από 5 μέχρι 5 εκτελείται μία φορά. (μονάδες 2)
  3. Δεν υπάρχουν δομές δεδομένων δευτερεύουσας μνήμης. (μονάδες 2)
  4. Ένας από τους παράγοντες από τους οποίους εξαρτάται η επιλογή της καταλληλότερης γλώσσας προγραμματισμού για την ανάπτυξη μιας εφαρμογής είναι το είδος της εφαρμογής. (μονάδες 2)
  5. Ένα υποπρόγραμμα μπορεί να καλείται μόνο από το κύριο πρόγραμμα. (μονάδες 2)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ

  1. ΣΩΣΤΟ 2. ΣΩΣΤΟ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ

Θέμα A, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Να χαρακτηρίσετε τις προτάσεις που ακολουθούν, γράφοντας στο τετράδιό σας δίπλα στο γράμμα που αντιστοιχεί σε κάθε πρόταση, τη λέξη Σωστό, αν η πρόταση είναι σωστή, ή Λάθος, αν η πρόταση είναι λανθασμένη.

α.   Δομημένα χαρακτηρίζονται εκείνα τα προβλήματα, των οποίων η επίλυση προέρχεται από μία αυτοματοποιημένη διαδικασία.
β.   Ένας αλγόριθμος μπορεί να μην έχει έξοδο.
γ.   Οι δομές δεδομένων διακρίνονται σε τρεις μεγάλες κατηγορίες: τις στατικές, τις δυναμικές και τις ημιδομημένες.
δ.    Πραγματικές ονομάζονται οι παράμετροι που χρησιμοποιούνται κατά την κλήση ενός υποπρογράμματος.
ε.    Η σύγκριση ΄ΑΛΗΘΗΣ΄ > ΄ΑΛΗΘΕΣ΄ δίνει τιμή ΨΕΥΔΗΣ.

Μονάδες 5

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια,

Δίνεται η παρακάτω αλληλουχία εντολών:

α<- 1

Όσο α <> 6 επανάλαβε

α<- α + 2

Τέλος_επανάληψης

Εκτύπωσε α

α.   Να απαντήσετε στο τετράδιό σας με Ναι ή Όχι αν η  παραπάνω αλληλουχία εντολών ικανοποιεί όλα τα αλγοριθμικά κριτήρια.

Μονάδες 2

β.   Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

Ερώτημα 2, Θέμα Α, 2003, Επαναληπτικές, Ημερήσια,

Δίνεται η παρακάτω αλληλουχία εντολών:

α<- 1

Όσο α <> 6 επανάλαβε

α<- α + 2

Τέλος_επανάληψης

Εκτύπωσε α

α.   Να απαντήσετε στο τετράδιό σας με Ναι ή Όχι αν η  παραπάνω αλληλουχία εντολών ικανοποιεί όλα τα αλγοριθμικά κριτήρια.

Μονάδες 2

β.   Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

 

Τα θέματα σε pdf, 2003, Ημερήσια, Επαναληπτικές