Επιλογή Σελίδας

Θέμα A, Ερώτημα 4, 2017, Ημερήσια

Α4. Έστω ότι έχουμε το παρακάτω απόσπασμα αλγορίθμου:
S <– 0
Για i από 5 μέχρι 20 με βήμα 3
Διάβασε Χ
     S <– S + X
Τέλοςεπανάληψης
Να ξαναγράψετε το παραπάνω απόσπασμα αλγορίθμου χρησιμοποιώντας αντί για την εντολή Για… Τέλος
επανάληψης:
α) την εντολή Όσο…Τέλοςεπανάληψης
(μονάδες 5)
β) την εντολή Αρχή
επανάληψης…Μέχρις_ότου
(μονάδες 5)
Μονάδες 10

Θέμα Α, Ερώτημα 3, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Αν x > 0 ή y > 0 τότε
      Εμφάνισε “Ένας τουλάχιστον θετικός αριθμός” 
Αλλιώς_αν x < 0 και y < 0 τότε
      Εμφάνισε “Δύο αρνητικοί αριθμοί” 
Τέλος_αν

Να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο να παράγει το ίδιο αποτέλεσμα με το παραπάνω, χρησιμοποιώντας μόνο τις λογικές συνθήκες x > 0, x < 0, y > 0, y < 0 και χωρίς να χρησιμοποιήσετε λογικούς τελεστές.

Μονάδες 7

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

Αν x > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός' 
Αλλιώς_αν y > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός'
Αλλιώς
    Αν x < 0
       Αν y < 0
          Εμφάνισε 'Δύο αρνητικοί αριθμοί' 
       Τέλος_αν
    Τέλος_αν
Τέλος_αν

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Θέμα Β, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)