Επιλογή Σελίδας

Θέμα Α, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να αναφέρετε ονομαστικά τις τυπικές επεξεργασίες πινάκων.

Μονάδες 10

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Ερώτημα 3, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

  1. Να αναφέρετε ονομαστικά τις κατηγορίες στις οποίες διακρίνονται τα προβλήματα, με κριτήριο το είδος της επίλυσης που επιζητούν αυτά.

Μονάδες 3

  1. Να αναφέρετε δύο βασικές λειτουργίες επί των δομών δεδομένων που δεν μπορούν να χρησιμοποιηθούν στους πίνακες. Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

  1. Ποια η διαφορά μεταξύ:

α.   μεταβλητών και παραμέτρων;

Μονάδες 3

β.    τυπικών και πραγματικών παραμέτρων;

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια