Επιλογή Σελίδας

Θέμα Γ, 2013, Μαΐου-Ιουνίου, Ημερήσια

Η χρήση των κινητών τηλεφώνων, των φορητών υπολογιστών, των tablet υπολογιστών από τους νέους αυξάνεται ραγδαία. Ένας από τους στόχους των ερευνητών είναι να διερευνήσουν αν υπάρχουν επιπτώσεις στην υγεία των ανθρώπων από την αυξημένη έκθεση στα ηλεκτρομαγνητικά πεδία. Για τον σκοπό αυτό γίνονται μετρήσεις του ειδικού ρυθμού απορρόφησης (SAR) της ηλεκτρομαγνητικής ακτινοβολίας, πάνω στο ανθρώπινο σώμα. Ο δείκτης SAR μετράται σε Watt/Kgr και ο παγκόσμιος οργανισμός υγείας έχει θεσμοθετήσει ότι τα επιτρεπτά όρια για το κεφάλι και τον κορμό είναι μέχρι και 2 Watt/Kgr, ενώ για τα άκρα μέχρι και 4 Watt/Kgr. Θέλοντας να προσομοιάσουμε την έρευνα, θεωρούμε ότι σε 30 μαθητές έχουν τοποθετηθεί στον καθένα δυο μετρητές του δείκτη SAR, ο ένας στο κεφάλι και ο άλλος σε ένα από τα άνω άκρα, οι οποίοι καταγράφουν τις τιμές του αντίστοιχου δείκτη SAR κάθε 6 λεπτά.

Να αναπτύξετε αλγόριθμο σε ψευδογλώσσα, ο οποίος:

Γ1. Να διαβάζει τους πίνακες: ΚΩΔ[30], ο οποίος θα περιέχει τους κωδικούς των 30 μαθητών, τον πίνακα ΚΕΦ[30,10], του οποίου κάθε γραμμή θα αντιστοιχεί σε έναν μαθητή και θα έχει 10 τιμές που αντιστοιχούν στο SAR της κεφαλής για μια ώρα, καθώς και τον πίνακα ΑΚΡ[30,10] που κάθε γραμμή θα αντιστοιχεί σε έναν μαθητή και θα έχει 10 τιμές που αντιστοιχούν στο SAR του άκρου για μια ώρα.

Μονάδες 2

Γ2.     Για κάθε μαθητή να καταχωρεί σε δισδιάστατο πίνακα ΜΟ[30,2] τις μέσες τιμές του SAR για το κεφάλι στην 1η στήλη και για το άκρο στη 2η στήλη.

Μονάδες 4

Γ3.     Να εμφανίζει για κάθε μαθητή τον κωδικό του και ένα από τα μηνύματα, «Χαμηλός SAR», «Κοντά στα όρια», «Εκτός ορίων», όταν η μέση τιμή του SAR της κεφαλής, καθώς και η μέση τιμή του SAR ενός εκ των άκρων του κυμαίνονται στις παρακάτω περιοχές:

Μ.Ο. SAR κεφαλής <=1,8 >1,8 και <=2 >2
Μ.Ο. SAR άκρου <=3,6 >3,6   και <=4 >4
Μήνυμα «Χαμηλός SAR» «Κοντά στα όρια» «Εκτός ορίων»

Το μήνυμα που θα εμφανίζεται θα πρέπει να είναι ένα μόνο για κάθε μαθητή και θα εξάγεται από τον συνδυασμό των τιμών των μέσων όρων των δυο SAR, όπου βαρύτητα θα έχει ο μέσος όρος, ο οποίος θα βρίσκεται σε μεγαλύτερη περιοχή τιμών. Για παράδειγμα, αν ο μέσος όρος SAR του άκρου έχει τιμή 3,8 και της κεφαλής έχει τιμή 1,5 τότε πρέπει να εμφανίζεται το μήνυμα «Κοντά στα όρια» και κανένα άλλο.

Μονάδες 7

Γ4. Θεωρώντας ότι όλες οι τιμές του πίνακα ΜΟ[30,2] είναι διαφορετικές, να εμφανίζει τις τρεις μεγαλύτερες τιμές για τον μέσο όρο SAR της κεφαλής και τους κωδικούς των μαθητών που αντιστοιχούν σε αυτές. Μετά να εμφανίζει τις τρεις μεγαλύτερες τιμές για τον μέσο όρο SAR του άκρου και τους κωδικούς των μαθητών που αντιστοιχούν σε αυτές.

Μονάδες 7

2012, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ (περισσότερα…)

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Παράδειγμα 3, Τετράδιο Εργασιών, Τιμές θερμοκρασίας από μετεωρολογικό Κέντρο

Σε ένα μετεωρολογικό κέντρο χρειάζεται να βρεθεί η μέγιστη και η ελάχιστη θερμοκρασία από τις μέσες ημερήσιες θερμοκρασίες ενός μήνα. Να γραφεί ένας αλγόριθμος που θα διαβάζει τη μέση ημερήσια θερμοκρασία για κάθε ημέρα ενός μήνα 30 ημερών και θα υπολογίζει την ελάχιστη και τη μέγιστη από αυτές τις θερμοκρασίες.

Παρατήρηση: Για τον υπολογισμό ελάχιστης και μέγιστης θερμοκρασίας είναι βασικό να δοθούν αρχικές τιμές στις μεταβλητές που θα κρατήσουν τις τιμές για να μπορεί να γίνει σωστά η σύγκριση. Εάν, για παράδειγμα, στη μεταβλητή ΜΙΝ δώσουμε αρχική τιμή 0, δεν θα καταλήξουμε σε σωστή ελάχιστη θερμοκρασία, εφόσον στο μήνα δεν υπάρχουν αρνητικές θερμοκρασίες. Αντίθετα, εάν στο MAX δώσουμε αρχική τιμή 0, δεν θα καταλήξουμε σε σωστή μέγιστη θερμοκρασία, στην περίπτωση που όλος ο μήνας είχε καθημερινή αρνητική μέση θερμοκρασία. Επομένως είναι χρήσιμο η ΜΙΝ να έχει αρκετά υψηλή θερμοκρασία ως αρχική τιμή, ενώ αντίθετα η MAX να έχει αρκετά χαμηλή θερμοκρασία ως αρχική τιμή.

Αλγόριθμος Ελάχιστη_Μέγιστη1
ΜΙΝ ← 100
MAX ← -100
Για i από 1 μέχρι 30
Διάβασε ΤΗΕΡ
Αν ΤΗΕΡ < ΜΙΝ τότε
ΜΙΝ ← ΤΗΕΡ
Αν ΤΗΕΡ > MAX τότε
MAX ← ΤΗΕΡ
Τέλος_επανάληψης
Αποτελέσματα // ΜΙΝ, MAX//
Τέλος Ελάχιστη_Μέγιστη1

Παράδειγμα 5, Βιβλίο μαθητή, Επιλογή ορίων

Να εισαχθεί ένας ακέραιος που αντιστοιχεί σε μια ηλικία και να βρεθεί σε ποια όρια εντάσσεται η δεδομένη ηλικία εμφανίζοντας σχετικό μήνυμα.

Αλγόριθμος Παράδειγμα 5.
Εμφάνισε “Σε ποια ηλικία άρχισες να μαθαίνεις προγραμματισμό;”
Διάβασε age
Επίλεξε age
Περίπτωση < 0
Εμφάνισε “Είπαμε ηλικία …”
Περίπτωση < 5
Εμφάνισε “Μάλλον τα παραλές !!”
Περίπτωση < 60
Εμφάνισε “Μπράβο”
Περίπτωση < 100
Εμφάνισε “Ποτέ δεν είναι αργά”
Περίπτωση αλλιώς
Εμφάνισε “Κάλλιο αργά παρά ποτέ”
Τέλος_επιλογών
Τέλος Παράδειγμα_5