Επιλογή Σελίδας

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2016, Επαναληπτικές, Νέο

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Α, Eρώτημα 5, 2015, Ημερήσια

α. Δίνονται οι παρακάτω προτάσεις σε φυσική γλώσσα:

  1. Αύξησε το Χ κατά 2.
  2. Εκχώρησε στο Υ τον μέσο όρο των Κ, Λ, Μ.
  3. Το τελευταίο ψηφίο του Α είναι
  4. Ο Β είναι διψήφιος.

Να θεωρήσετε ότι οι Α και Β είναι θετικοί ακέραιοι. Να γράψετε στο τετράδιό σας τον αριθμό της κάθε πρότασης και δίπλα την κωδικοποίησή της σε ΓΛΩΣΣΑ. (μονάδες 4)
β. Δίνεται το παρακάτω τμήμα αλγορίθμου:

 Διάβασε Χ 
 Αν Χ > 15 τότε
     Γράψε 1 
 αλλιώς_αν Χ > 23 τότε
     Γράψε 2 
 αλλιώς
     Γράψε 3 
 Τέλος_αν

Μια εντολή εξόδου στο παραπάνω τμήμα δεν πρόκειται να εκτελεστεί, όποια και αν είναι η τιμή του Χ.

  1. Ποια είναι η εντολή αυτή; (μονάδες 2)
  2. Να γράψετε τις εντολές εξόδου που είναι δυνατόν να εκτελεστούν και, δίπλα σε καθεμία από αυτές, το διάστημα τιμών του Χ για το οποίο θα εκτελεστεί η εντολή. (μονάδες 4)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.5.α.

  1. Χ ← Χ + 2

  2. Υ ← ( Κ + Λ + Μ ) /3

  3. Α mod 10 = 5

  4. B >= 10 KAI B < 100

A.5.β

  1. Η εντολή Γράψε 2

  2. Γράψε 1 για x > 15

Γράψε 3 για x <= 15

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια