Επιλογή Σελίδας

Παράδειγμα 5, Κεφάλαιο 8, Βιβλίο, Προπαίδεια

Να γραφεί πρόγραμμα το οποίο να εκτυπώνει την προπαίδεια του πολλαπλασιασμού.

ΠΡΟΓΡΑΜΜΑ Προπαίδεια 
!Πρόγραμμα εκτύπωσης της προπαίδειας των αριθμών 1 έως 10 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Α, Β, Γ 
!A:Πολλαπλασιαστέος
!Β:Πολαπλασιαστής
!Γ:Γινόμενο
ΑΡΧΗ
ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10   
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
        Γ <- Α*Β
        ΓΡΑΨΕ A,'X',Β,'=',Γ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ  !Εισαγωγή κενής γραμμής στην εκτύπωση 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 8, Τετράδιο Εργασιών, Βολή μπάλας στον αέρα, μεταβολή γωνίας βολής και αρχικής ταχύτητας

Στο παράδειγμα 1 του προηγούμενου κεφαλαίου με την μπάλα που εκτοξεύεται στον αέρα η γωνία βολής μπορεί να μεταβάλλεται από 20 έως 80 μοίρες σε βήματα των 10 μοιρών. Επίσης η αρχική ταχύτητα μπορεί να μεταβάλλεται από 10 μ/sec έως 40 μ/sec σε βήματα των 10 μ/sec. Να γραφεί πρόγραμμα που να υπολογίζει την οριζόντια απόσταση (το βεληνεκές) για κάθε συνδυασμό γωνίας και αρχικής ταχύτητας.

ΠΡΟΓΡΑΜΜΑ Τροχιά_μπάλας2 
ΣΤΑΘΕΡΕΣ 
G = 9.81 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ:V0,VX0,VY0,Θ, Βεληνεκές 
ΑΡΧΗ 
ΓΙΑ Θ ΑΠΟ 20 ΜΕΧΡΙ 80 ΜΕ ΒΗΜΑ 10 
    ΓΡΑΨΕ 'Γωνία:',Θ 
    ΓΙΑ V0 ΑΠΟ 10 ΜΕΧΡΙ 40 ΜΕ ΒΗΜΑ 10
        VX0 <-- V0*ΣΥΝ(Θ) 
        VY0 <-- V0*ΗΜ(Θ) 
        Βεληνεκές <-- 2*VX0*VY0/G
        ΓΡΑΨΕ 'Ταχύτητα:',V0,'Βεληνεκές:',Βεληνεκές 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Θέμα Γ, 2014, Επαναληπτικές, Ημερήσια

Δίνεται η εξίσωση Α·x + B·y + Γ·z = Δ. Να αναπτύξετε αλγόριθμο, ο οποίος, θεωρώντας δεδομένες τις τιμές των Α, Β, Γ και Δ:

Γ 1. Να εμφανίζει όλες τις λύσεις (τριάδες) της εξίσωσης, εξετάζοντας όλους τους δυνατούς συνδυασμούς ακεραίων τιμών των x, y, z, που είναι μεγαλύτερες από 100 και μικρότερες από 100. Αν δεν υπάρχουν τέτοιες λύσεις, να εμφανίζει κατάλληλο μήνυμα.

Μονάδες 8

Εφόσον υπάρχουν τέτοιες λύσεις:

Γ2. Να εμφανίζει την πρώτη λύση (τριάδα) για την οποία το άθροισμα των x, y, z έχει τη μεγαλύτερη τιμή.

Μονάδες 4

Γ3. Να εμφανίζει το πλήθος των λύσεων της εξίσωσης για τις οποίες τα x, y, z είναι θετικοί άρτιοι αριθμοί.

Μονάδες 4

Γ4. Να εμφανίζει το ποσοστό των λύσεων της εξίσωσης για τις οποίες ένα μόνο από τα x, y, z είναι ίσο με μηδέν.

Μονάδες 4

ΛΥΣΗ  (περισσότερα…)

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια