Συσκευασία αυγών

Να υλοποιηθεί πρόγραμμα που θα διαβάζει τα μεγέθη των αυγών ενός κέντρου παραγωγής και θα τα κατατάσσει σε κατηγορίες ανάλογα με το μέγεθος του. Οι κατηγορίες είναι Μ (μεγάλα), Μεσαία (Μεσαία), Μ (Μικρά) για μεγέθη διαμέτρου >30, >20, >10.
Τα αυγά τοποθετούνται σε συσκευασίες των 10. Κάθε φορά που γεμίζει 1 συσκευασία, προωθείται νέα. Η διαδικασία τερματίζεται όταν δοθεί είσοδος 999. Στο τέλος εμφανίζεται ο αριθμός συσκευασιών κάθε κατηγορίας.

ΜΕΧΡΙΣ ΟΤΟΥ |ΟΣΟ ΕΠΑΝΑΛΑΒΕ | FLAG

ΛΥΣΗ

(περισσότερα…)

Ηλικία εξεταζομένων εξεταστικού κέντρου

Να υλοποιηθεί πρόγραμμα που διαβάζει τον αριθμό των αιθουσών ενός εξεταστικού κέντρου και κατόπιν το αριθμό των ατόμων που μπορεί να υποδεχθεί κάθε αίθουσα. Για κάθε αίθουσα θα διαβάζει την ηλικία των εξεταζόμενων και υπολογίζει και εμφανίζει την μεγαλύτερη, την μικρότερη ηλικία και τον μέσο όρο.
Προέκταση: Θα εμφανίζει τον μεγαλύτερο, μικρότερο εξεταζόμενο του εξεταστικού κέντρου και τον συνολικό μέσο όρο ηλικίας τους.

ΛΥΣΗ

(περισσότερα…)

Ύψος μαθητών σχολείου

Να υλοποιηθεί πρόγραμμα που θα διαβάζει το ύψος των μαθητών των τάξεων του σχολείου. Αρχικά θα διαβάζει και θα εκτυπώνει το τμήμα, κατόπιν θα διαβάζει το ύψος μαθητών μέχρι να διαβαστεί η τιμή 0. Για κάθε τμήμα υπολογίζεται και εμφανίζεται ο ΜΟ όρος ύψους των μαθητών.
Το διάβασμα των τμημάτων σταματά όταν διαβαστεί διαβαστεί η τιμή ΤΕΛΟΣ.

ΛΥΣΗ

(περισσότερα…)

Υπολογισμός Επιβατών Λεωφορείου

Να υλοποιηθεί πρόγραμμα που θα υπολογίζει τα άτομα που βρίσκονται στο τέλος της διαδρομής ενός λεωφορείου.
Το πρόγραμμα θα διαβάζει την χωρητικότητα λεωφορείου. Σε κάθε στάση θα διαβάζει τον αριθμό των επιβατών που κατεβαίνουν και ανεβαίνουν. Το λεωφορείο σταματά όταν δεχτεί 0 για είσοδο στο λεωφορείο. Στο τέρμα της διαδρομής εμφανίζει τα άτομα που βρίσκονται στο λεωφορείο.
Προέκταση1: Εμφανίζει τα άτομα που συνολικά εξυπηρετήθηκαν από το λεωφορείο.
Προέκταση2: Αντί να διαβάζει την χωρητικότητα λεωφορείου, διαβάζει θέσεις όρθιων και καθήμενων. Αρχικά γεμίζει τις θέσεις καθημένων και κατόπιν ορθίων.

Λύση
(περισσότερα…)

Αποθήκη Μεταφοράς Δεμάτων

Μία εταιρεία μεταφοράς δεμάτων διαθέτει δύο αποθήκες, Α και Β, στο αεροδρόμιο. Κατά την παραλαβή δεμάτων, κάθε δέμα τοποθετείται στην αποθήκη που έχει εκείνη τη στιγμή τον περισσότερο ελεύθερο χώρο. Αν ο ελεύθερος χώρος της αποθήκης Α είναι ίσος με τον ελεύθερο χώρο της αποθήκης Β, το δέμα τοποθετείται στην αποθήκη Α. Όταν όμως το δέμα δεν χωρά σε καμία από τις δύο αποθήκες, προωθείται στις κεντρικές εγκαταστάσεις της εταιρείας, που βρίσκονται εκτός αεροδρομίου.
Γ1. Να κατασκευάσετε πρόγραμμα που:
α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 0,5)
β. Να διαβάζει τα μεγέθη ελεύθερου χώρου των αποθηκών Α και Β. (μονάδες 0,5) ! ο χώρος είναι ακέραια κυβικά μέτρα
γ. Να διαβάζει το μέγεθος κάθε εισερχόμενου δέματος (κυβικά μέτρα με υποδιαστολή) και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία θα τοποθετηθεί αυτό ή να εμφανίζει το μήνυμα «Προώθηση», όταν το δέμα δεν χωρά σε καμία από τις αποθήκες Α ή Β. Η διαδικασία παραλαβής τερματίζεται, όταν εισαχθεί ως μέγεθος δέματος η τιμή 0. (μονάδες 4)

Βλέπε Θέμα Γ, 2015
https://aepp.gr/thema-g-2015-imerisia/

Λύση
(περισσότερα…)

Έκθεση και Υπολογισμός Επισκεπτών

Να υλοποιηθεί πρόγραμμα που θα υπολογίζει τον αριθμό επισκεπτών μιας έκθεσης. Η έκθεση λειτουργεί καθημερινά για ένα διάστημα ημερών που διαβάζεται από τον χρήστη. Η έκθεση έχει 3 εισόδους. Το πρόγραμμα διαβάζει τους επισκέπτες κάθε ημέρας για κάθε είσοδο και υπολογίζει το σύνολο των επισκεπτών και το εμφανίζει το σύνολο ανά ημέρα. Στο τέλος εμφανίζει τον συνολικό αριθμό επισκεπτών.
Προέκταση: Η μία είσοδος είναι μόνο για έξοδο και οι άλλες 2 για είσοδο.

Λύση
(περισσότερα…)

Εμφάνιση θετικών αριθμών, 2 συνθήκες εξόδου, Τιμή – Φρουρός ή πλήθος

! Να υλοποιηθεί αλγόριθμος που, θα διαβάζει επαναληπτικά θετικούς αριθμούς, θα τους εμφανίζει στην οθόνη, θα σταματά όταν δεχτεί την τιμή 100 ή αν δοθούν 20 αριθμοί.
! να υλοποιηθεί αλγόριθμος που:
! θα διαβάζει επαναληπτικά θετικούς αριθμούς,
! θα τους εμφανίζει στην οθόνη,
! θα σταματά όταν δεχτεί την τιμή 100
! ΠΡΟΕΚΤΑΣΗ: ή αν δοθούν 20 αριθμοί

Λύση
(περισσότερα…)

Παράρτημα Α – 3.7 Επανάληψη – Άσκηση 9

Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει θετικό ακέραιο αριθμό Ν. Στη συνέχεια, να διαβάζει θετικούς αριθμούς μέχρι το άθροισμά τους να γίνει μεγαλύτερο από τον
αριθμό Ν. Τέλος, να υπολογίζει και να τυπώνει τον μεγαλύτερο αριθμό που πληκτρολογήθηκε.
Να γίνεται έλεγχος των αριθμών που πληκτρολογούνται, ώστε να είναι θετικοί, σε αντίθετη περίπτωση να εμφανίζεται μήνυμα λάθους και να ζητείται η πληκτρολόγηση ενός θετικού αριθμού.

ΛΥΣΗ (περισσότερα…)

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 5

Σε ένα σχολείο η φοίτηση ενός μαθητή χαρακτηρίζεται ως επαρκής, εάν το σύνολο όλων των απουσιών του δεν ξεπερνά τις 100, εκ των οποίων οι 60 είναι δικαιολογημένες ή το σύνολο
των απουσιών του δεν ξεπερνά τις 160 και οι 120 είναι δικαιολογημένες και ο Μέσος όρος βαθμολογίας του μαθητή μεγαλύτερος του 15. Διαφορετικά η φοίτηση χαρακτηρίζεται ως ανεπαρκής.
Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
1) Να διαβάζει από το πληκτρολόγιο τον Μέσο Όρο του μαθητή, το σύνολο των Δικαιολογημένων και το σύνολο των Αδικαιολόγητων απουσιών του.
2) Να εμφανίζει το μήνυμα ’Φοίτηση επαρκής’ ή ’Φοίτηση ανεπαρκής’, ανάλογα με τις απουσίες του.

ΛΥΣΗ (περισσότερα…)

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 8

Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ»,
το οποίο να δέχεται από το πληκτρολόγιο έναν ακέραιο αριθμό και να ελέγχει
εάν είναι διψήφιος και θετικός. Στην περίπτωση που ισχύει, να τυπώνεται
το μήνυμα «Θετικός, Διψήφιος αριθμός»,
ενώ διαφορετικά να τυπώνονται για κάθε περίπτωση
«Μόνο θετικός» ή «Μόνο διψήφιος» ή «Ούτε θετικός, !ούτε διψήφιος»

Λύση με flags | Λύση με σύνθετες λογικές συνθήκες | λύση με πολλαπλές επιλογές

ΛΙΓΕΣ ΣΚΕΨΕΙΣ
! 53 div 10 = 5, έχει δεκάδες
! 153 div 100 = 1, έχει εκατοντάδες συνεπώς είναι τριψήφιος
! ή διαφορετικά
! 153 div 10 = 15, > 9
! 03 div 10 = 0, δεν έχει δεκάδες
! 53 div 100 = 0, δεν είναι τριψήφιος
! αν υπάρχουν δεκάδες,
! δεν πρέπει να υπάρχουν εκατοντάδες
! > 0 αν είναι θετικός
! (0 μπορεί να πάει είτε στους θετικούς είτε στους αρνητικούς)

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v1
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΛΟΓΙΚΕΣ: θετικός, διψήφιος
ΑΡΧΗ
διψήφιος <– ΨΕΥΔΗΣ
θετικός <– ΨΕΥΔΗΣ
ΔΙΑΒΑΣΕ a
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
Αν a div 10 <> 0 και a div 100 = 0 τότε
διψήφιος <– ΑΛΗΘΗΣ
τέλος_αν

! α > 0 είναι θετικός
αν a > 0 τότε
θετικός <– ΑΛΗΘΗΣ
τέλος_αν

αν διψήφιος = ΑΛΗΘΗΣ και θετικός = ΑΛΗΘΗΣ τότε
Γράψε ‘διψήφιος και θετικός’
τέλος_αν

αν διψήφιος = ΑΛΗΘΗΣ και θετικός = ΨΕΥΔΗΣ τότε
Γράψε ‘διψήφιος’
Τέλος_αν

αν διψήφιος = ΨΕΥΔΗΣ και θετικός = ΑΛΗΘΗΣ τότε
Γράψε ‘θετικός’
Τέλος_αν

αν διψήφιος = ΨΕΥΔΗΣ και θετικός = ΨΕΥΔΗΣ τότε
Γράψε ‘Ούτε Διψήφιος, ούτε θετικός’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v2
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΑΡΧΗ
ΔΙΑΒΑΣΕ a

! αν a div 10 <> 0 τότε τουλάχιστον διψήφιος
! αν a div 100 = 0 τότε δεν είναι τριψήφιος
! αν a > 0 τότε είναι θετικός

! 1η περίπτωση (διψήφιος και θετικός)
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
! και
! α > 0 είναι θετικός
Αν a div 10 <> 0 και a div 100 = 0 και a > 0 τότε
Γράψε ‘διψήφιος και θετικός’

! 2η περίπτωση (μόνο διψήφιος – αρνητικός ή 0)
! a div 10 <> 0 είναι τουλάχιστον διψήφιος
! και
! a div 100 = 0 δεν είναι τριψήφιος
! και
! α < 0 είναι αρνητικός
Αλλιώς_αν a div 10 <> 0 και a div 100 = 0 και a < 0 τότε
Γράψε ‘διψήφιος’

! 3η περίπτωση (δεν είναι διψήφιος, μόνο θετικός)
! a div 10 = 0 είναι μονοψήφιος
! ή
! a div 100 <> 0 είναι τουλάχιστον τριψήφιος
! και
! α > 0 είναι θετικός
Αλλιώςαν a div 10 = 0 ή a div 100 <> 0 και a > 0 τότε
Γράψε ‘θετικός’
Αλλιώς
αν a div 10 = 0 ή a div 100 <> 0 και a <= 0 τότε
Γράψε ‘Ούτε Διψήφιος, Ούτε Θετικός’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_8_v3
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΑΡΧΗ
ΔΙΑΒΑΣΕ a

! 1η περίπτωση (διψήφιος και θετικός)
Αν a >=10 και a <=99 τότε Γράψε ‘διψήφιος και θετικός’ Αλλιώςαν a> 0 τότε
Γράψε ‘μόνο θετικός, όχι διψήφιος’
Αλλιώς
αν a <= -10 και a >= -99 τότε
Γράψε ‘διψήφιος’
Αλλιώς
Γράψε ‘ούτε θετικός ούτε διψήφιος’
Τέλος_αν

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 7

Με το σύστημα πληρωμής των διοδίων, οι οδηγοί των τροχοφόρων έχουν τη δυνατότητα να πληρώνουν το αντίτιμο των διοδίων με ειδική μαγνητική κάρτα. Υποθέστε ότι υπάρχει μηχάνημα το οποίο διαθέτει είσοδο για την κάρτα και φωτοκύτταρο. Το μηχάνημα διαβάζει από την κάρτα το υπόλοιπο των χρημάτων και το αποθηκεύει σε μια μεταβλητή Υ και με το φωτοκύτταρο αναγνωρίζει τον τύπο του τροχοφόρου και το αποθηκεύει σε μια μεταβλητή Τ. Υπάρχουν τρεις τύποι τροχοφόρων: δίκυκλα (Δ), επιβατικά (Ε) και φορτηγά (Φ), με αντίτιμο διοδίων 1.20€, 2.40€ και 3.50€ αντίστοιχα.
Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
1) Να ελέγχει τον τύπο του τροχοφόρου και να εκχωρεί στη μεταβλητή Α το αντίτιμο των διοδίων, ανάλογα με τον τύπο του τροχοφόρου.
2) Να ελέγχει την πληρωμή των διοδίων με τον παρακάτω τρόπο:
Ι) Αν το υπόλοιπο της κάρτας επαρκεί για την πληρωμή του αντιτίμου των διοδίων, αφαιρεί το ποσό αυτό από την κάρτα.
ΙΙ) Αν η κάρτα δεν έχει υπόλοιπο, το μηχάνημα ειδοποιεί με μήνυμα για το ποσό που πρέπει να πληρωθεί.
ΙΙΙ) Αν το υπόλοιπο δεν επαρκεί, μηδενίζεται η κάρτα και δίνεται με μήνυμα το ποσό που απομένει να πληρωθεί.

ΠΡΟΓΡΑΜΜΑ parartima_a_sel_36_7
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ:Υ,Α
ΧΑΡΑΚΤΗΡΕΣ: Τ

ΑΡΧΗ
ΔΙΑΒΑΣΕ Υ,Τ
ΑΝ Τ = ‘Δ’ ΤΟΤΕ
Α <– 1.2
ΑΛΛΙΩΣΑΝ Τ = ‘Ε’ ΤΟΤΕ
Α <– 2.4
ΑΛΛΙΩΣ
Α <– 3.5
ΤΕΛΟΣ
ΑΝ

ΑΝ Υ >= Α ΤΟΤΕ ! ΜΠΟΡΕΙΣ ΝΑ ΤΟ ΠΛΗΡΩΣΕΙΣ
Υ <– Υ – Α
ΑΛΛΙΩΣΑΝ Υ = 0 ΤΟΤΕ
ΓΡΑΨΕ ‘ΠΡΕΠΕΙ ΝΑ ΠΛΗΡΩΘΕΙ’, Α
ΑΛΛΙΩΣ
Α <– Α – Υ ! ΥΠΟΛΟΓΙΖΕΙΣ ΤΙ ΑΠΟΜΕΝΕΙ ΝΑ ΠΛΗΡΩΘΕΙ
! ΑΦΟΥ ΚΡΑΤΗΣΕΙΣ ΤΟ ΥΠΟΛΟΙΠΟ ΤΗΣ ΚΑΡΤΑΣ
Υ <– 0 ! ΜΗΔΕΝΙΖΕΙΣ ΤΗΝ ΚΑΡΤΑ
ΓΡΑΨΕ ‘ΠΡΕΠΕΙ ΝΑ ΠΛΗΡΩΘΕΙ’, Α
ΤΕΛΟΣ
ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 6

!6. Το Υπουργείο Οικονομικών φορολογεί τους Ελεύθερους Επαγγελματίες
! σύμφωνα με τον παρακάτω πίνακα:
! 1. Από 1€ μέχρι 20.000€ – 22%
! 2. Από 20.001€ μέχρι 30.000€ – 29% (για τα επόμενα 10000€)
! 3. Από 30.001€ μέχρι 40.000€ – 37% (για τα επόμενα 10000€)
! 4. Από 40.001€ και άνω _ 45% (για όλα τα επόμενα €)

!Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ»,
!το οποίο να διαβάζει το εισόδημα ενός ελεύθερου επαγγελματία
!και στη συνέχεια να υπολογίζει και να εμφανίζει τον φόρο που του αναλογεί.
!Ο υπολογισμός φόρου γίνεται κλιμακωτά, σύμφωνα με τον παραπάνω πίνακα.

(περισσότερα…)