ΘΕΜΑ Δ
Σε ένα πρωτάθλημα στίβου, στο αγώνισμα του άλματος εις μήκος συμμετέχουν 20 αθλητές, οι οποίοι κάνουν 6 άλματα ο καθένας.
Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ, το οποίο:
Δ1. α) Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων (2 μονάδες).
β) Να διαβάζει και να αποθηκεύει τα ονόματα των 20 αθλητών σε μονοδιάστατο πίνακα (1 μονάδα).
γ) Να διαβάζει και να αποθηκεύει σε δισδιάστατο πίνακα τις επιδόσεις του κάθε αθλητή στα 6 άλματα (δεν απαιτείται έλεγχος εγκυρότητας) (1 μονάδα).
Μονάδες 4
Δ2. Να εμφανίζει τη μεγαλύτερη επίδοση που σημειώθηκε στο αγώνισμα και τον αριθμό του άλματος στο οποίο σημειώθηκε. Να θεωρήσετε ότι η μεγαλύτερη επίδοση σημειώθηκε από έναν μόνο αθλητή και σε ένα μόνο άλμα.
Μονάδες 5
Δ3. Να εμφανίζει τα ονόματα των αθλητών που σημείωσαν τουλάχιστον δύο (2) άκυρα άλματα. Στα άκυρα άλματα έχει καταχωριστεί ως επίδοση η τιμή 0.
Μονάδες 5
Δ4. Να εμφανίζει για κάθε αθλητή το όνομά του και τις επιδόσεις του, ταξινομημένες από τη μεγαλύτερη προς τη μικρότερη.
Μονάδες 6

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ
!Δ1α (2Μ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, αρ_αλμ, πλ0, κ
  ΠΡΑΓΜΑΤΙΚΕΣ: επ[20, 6], μαξεπ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: ον[20] 
ΑΡΧΗ
!Δ1β (1Μ)
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ ον[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ1γ (1Μ)
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΔΙΑΒΑΣΕ επ[ι, ξ] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Δ2 (5Μ)
!1Μ
  μαξεπ <- επ[1, 1] 
  αρ_αλμ <- 1 !1Μ ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20 ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 6 !2Μ ΑΝ επ[ι, ξ] > μαξεπ ΤΟΤΕ
        μαξεπ <- επ[ι, ξ] 
        αρ_αλμ <- ξ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!1Μ
  ΓΡΑΨΕ μαξεπ, αρ_αλμ

!Δ3 (5Μ)
!1Μ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    πλ0 <- 0
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 6
!2Μ
      ΑΝ επ[ι, ξ] = 0 ΤΟΤΕ
!1Μ
        πλ0 <- πλ0 + 1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ πλ0 >= 2 ΤΟΤΕ
!1Μ
      ΓΡΑΨΕ ον[ι] 
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Δ4 (6Μ)
!1Μ
  ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 20
!1Μ
    ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 6
      ΓΙΑ ξ ΑΠΟ 6 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
!2Μ
        ΑΝ επ[κ, ξ] > επ[κ, ξ - 1] ΤΟΤΕ
        ! 1Μ
          τεμπ <- επ[κ, ξ] 
          επ[κ, ξ] <- επ[κ, ξ - 1] 
          επ[κ, ξ - 1] <- τεμπ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!1Μ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ ον[ι] 
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ επ[ι, ξ] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ</code class="language-javascript">
Share This